Freezes on boot Ryzen 7 2700u


#1

I purchased a new laptop with a Ryzen 7 2700u processor and both Project-Trident and FreeBSD freeze on boot. It will get to “arc4random: no preloaded entropy cache” but stops there and will not go any further regardless of the amount of time given. ( Remember reading somewhere that sometimes a bug causes it to hang for about 5 minutes at this point in booting.)

Does anyone have any thoughts on why this happens/how to get around it?


#2

If FreeBSD freezes, not much we wen do :frowning:

We used FreeBSD underneath it all


#3

I was kind of expecting that but I figured I’d ask anyways to see if maybe someone else had the issue and resolved it or I was doing something wrong and didn’t know it.

Thank you for the quick response. It’s probably just that the ryzen mobile processors being so new.


#4

neither here, nor on telegram


#5

As a “debugging” step, have you tried to load DragonflyBSD on it? I know Matt has come across a few things and has posted commits related to Ryzen.

There’s no ZFS in Dragonfly, but last I mucked with it, it’s a good alternative to base FreeBSD or TrueOS/Trident.


#6

I will give it a try. Thank you. I also came across an article about openBSD being able to run on it. I’ll give dragonfly a try first.


#7

If I didn’t have so much data invested in ZFS, I’d probably be running DragonFly with Hammer2. Lots of good performance stuff over there, some winds up back in the other BSDs, but it’s a good distribution.


#8

I didn’t get to try to install it yet but it does boot. Literally the only OS other than Windows that will. I’ve tried 3 different Linux distro, Projects Trident and pure FreeBSD


#9

I’ve heard good things about hammer but I’m pretty invested in ZFS also but I have to make due until FreeBSD supports my hardware.


#10

The bios on this laptops is full of bugs. Something with acpi tables is broken. Only windoze 10 is working. In linux there are some workarounds but I don’t know how to apply them on freebsd (for linux you have to add “ivrs_ioapic[4]=00:14.0 ivrs_ioapic[5]=00:00.2” as kernel parameters).


#11

Yup. I’ve tried pretty much everything I can think of. I’m returning the laptop to get something that will work.