Freeze while shutdown is in progress


#21

Ahh. If the machine is powering off when you do shutdown -p, then I’m guessing the system is not switching back to the text console correctly.


#22

Hm, I see the same messages with shutdown -p. And there is a frozen mouse pointer too. I think normally there is none.
edit: Tried again an shutdown -h to see if I can switch to the text console with Ctrl-Alt-F1: I can’t.
edit2: Thanks to all the people who made FreeBSD / ZFS as indestructible as it is. If not I would probably need the backup.


#23

Sorry, my previous reply was an incomplete thought.
Those messages on the screen are from OpenRC stopping things, there may be output in /var/log/rc.log (I think this is the name of the file).
The “switching to a text console” is something that should happen automatically when the pcdm service is stopped, the “stopping session on vt9” should be pcdm stopping.
All of what I’m saying is “I think it’s actually halting correctly, you’re just missing the output that tells you that”. The fact that shutdown -p actually powers it off is my reason for saying this.


#24

Sorry - should have been “shutdown -p now” (not -h now). That’s what I usually do.

As it doesn’t happen consistently and as I’m not aware of a pattern, I have to wait before I can take a picture.

Thanks jhz


#25

So it happened to me again yesterday. I made a note of it this time, and it does get stuck exactly at saving dependency cache …

I shutdown by clicking on “Leave” and then “power off.”

I will try with the command line at the end of the day, and see if I get the same result.


#26

@groot, thanks. the leave/power off should be doing “shutdown -p now”; if you enter that from the command line and the machine powers off, that’s a good data point.


#27

Will this command also fix the issue that it just goes to the login page instead of shutting down?


#28

I did Leave/Power Off (out of habit) and it got stuck at "Saving Dependency Cache … " Again. I had to poke the power button to turn it off, I turned it on again, and from Qterminal I did “sudo shutdown -p now” and it shutdown properly without incident.


#29

Happened again here, with “shutdown -p now”.

The last 3 lines are:

Syncing disks, vnodes remaining … 0000 done
All buffers synced.
Uptime: 11h23m12s

power is not turned off.


#30

Ok. That completely shutdown; the Uptime message is the last one you should see. Does the -p option ever make the machine power off? If not, then there may be something that it doesn’t like on that hardware.


#31

Leave/Poweroff worked for me today, it turned the machine off without any incident.


#32

It does, more often than not.

In addition, it doesn’t always stop at the same point, and it happens on two different computers.


#33

It happened again yesterday, this time with:

It’s probably related to Fatal Trap 12 booting TrueOS via iSCSI.
In fact, I saw this during startup too, some time ago, but didn’t report it.


#34

Are you booting via iSCSI?


#35

Sorry, don’t understand the question.


#36

You say “It’s probably related to Fatal Trap 12 booting TrueOS via iSCSI”.

I’m asking “are you booting TrueOS via iSCSI”. If not then, it’s not likely related. Your screen shows stopped in the uma process, in the function _sx_xlock_hard.

The link for booting via iSCSI is stopped in swapper process, in function isboot_handler.

They only thing they share is the type of problem: fatal page fault, basically the system is asking for a memory address and it isn’t mapped or can’t be mapped. Different virtual addresses.


#37

Are these problems “hard metal”-boot related or is this “Virtual Box”-booting?