[fixed] TrueOS hang at boot after install on Lenovo E480


#1

I’m trying to run TrueOS-Desktop-17.12-x64 on a brand new ThinkPad E480, unsuccessfully /o.

Installation from a USB stick was « successfull », according to the graphical installer.
When I reboot, after removing the USB stick, I get the reFind boot loader, then the TrueOS boot screen. After 1 second boot process starts :

  • I see few lines quickly printing on screen
  • then a black screen with « TrueOS » text and logo
  • then … nothing. It hangs forever.
    Booting in Single User with Verbose option output the same TrueOS screen.

I tried to reinstall TrueOS with reFind disabled but the reinstallation failed with the following output :

kern.geom.debugflags: 0 -> 16
kern.geom.label.disk_ident.enable: 0 -> 0
Deleting all gparts
Running: gpart destroy -F /dev/nvd0
gpart: Device busy
Running: zpool labelclear -f /dev/nvd0
failed to read label from /dev/nvd0
Running: gpart create -s gpt /dev/nvd0
gpart: geom 'nvd0': File exists
EXITERROR: Error 1: gpart create -s gpt /dev/nvd0
Unmounting: /mnt
Runnning: umount -f /mnt
unmount: /mnt: not a file system root directory

How could I have more information on what’s going wrong ? Which debug commands should I issue ?

Thanks for your help.


Stuck at Logo during boot
#2
[update]

It seems there is an issue with my SSD. To install TrueOS-Desktop-2018-03-17-UNSTABLE-x64-USB I needed to activate safe mode + ext install/console + failsafe VESA mode and the installation went well. When I reboot, boot process hangs after the boot menu, showing TrueOS logo forever… I can’t figure out what went wrong…

Is there a way to boot TrueOS in safe mode as well as the installer ?
Instead, can I set some safe mode configurations to the boot/loader.conf ? Which one ?


#3

Switch off ‘bitmap_load’:

https://www.freebsd.org/cgi/man.cgi?query=loader.conf&apropos=0&sektion=0&manpath=FreeBSD+11.1-RELEASE+and+Ports&arch=default&format=html

What does it show, afterwards?


#4

Unfortunately, setting bitmap_load="NO" in loader.conf does NOT prevent the black screen with TrueOS to show up just after the boot menu… preventing any debugging.

To fix startup freezing, I had to manualy setup a “safe mode” within boot/loader.conf (mimicking https://github.com/trueos/trueos-core/blob/580f95d42791fd5da17a74e973f75890aa4b95bd/overlays/install-overlay/boot/menu-commands.4th), then removing unnecessary setup.
I ended up with kern.smp.disabled="1" to boot properly.


#5

If you want to disable the boot logo:

HOWTO deactivate boot splash logo.

(The search on this forum really works quite nicely - unlike on some others.)


#6

neither boot_mute nor bitmap_load works for me :frowning: