[fix] [tutorial] Workaround for modern nvidia install failures


I’ve tested and reproduced this error on several systems using maxwell and pascal cards on the latest install image.

Everything runs fine, but upon rebooting into the fresh OS, the first boot dialog and login manager will fail to start and hang on the openrc checklist

the workaround is to either set iGPU to primary in bios, and install with modesetting/intel.

once you have a working desktop, create a new BE, and back up your current xorg.conf to something like:

% cp /etc/X11/xorg.conf /etc/X11/prev.xorg.conf

Activate the new BE and reboot. install nvidia drivers and utilities:

% sudo pkg install nvidia-driver nvidia-xconfig nvidia-settings

run nvidia-xconfig, reboot into bios, switch your monitor to the nvidia gpu, and change pcie to primary adapter. Boot into lumina.

At this juncture lumina may have lost all of your panels or be similarly screwed up. Not to worry: just right click, hit Preferences > All Desktop Settings > User Settings > General Options and click restore lumina and desktop defaults. Reboot and everything should be hunky-dory.

Hope this helps



Although this sounds like a good fix, (thanks!) what happens if you have a Xeon CPU without internal graphics?


simple answer.

pray you make the correct choice :wink:


Or you could seach some of the other nvidia threads; I’ve provided a bunch of information and steps that has helped at least one person through the process.


whacking in an old radeon or matrox device for install and swapping on modesetting or vesa may work


Or perhaps a more simple answer would be better quality control? I didn’t have a issue with my 1060 in prior versions of TrueOS. Perhaps it’s a upstream issue?

Thing is, I’d love to be running TrueOS all the time on my main desktop, but I need things to work… consistently. Meh, complaining certainly will not help. I’ll continue to test new images and hopefully at some point things will be sorted out.


video drivers are going to always be a work in progress. So yes, an upstream issue.

Since over 50% of TrueOS is FreeBSD underneath (no I don’t know actual percentage), yes most things are going to be an upstream issue :sunglasses:


if the latest driver was <371ish, that may have been the problem with the 1060. Pascal wasn’t fully supported till that version. The issue seems to be with PCDM or the first boot setup wizard atm and not with the nvidia driver.

have you tried installing in VESA mode/modesetting and then setting up nvidia manually once you’ve gotten past first boot?


Rumor mill.

within the next few release of the ISO/IMG, install will default to vesa/scfb to elminate the nvidia mashup on install

and let user pick on first reboot

again, rumor, nvidia has always been a problem on pcBSD/Trueos, and this is a way to get the install working quicker


And video in particular since you have the FreeBSD Desktop folks bringing things up to date with Linux side, then getting that merged into FreeBSD…

Part of the quality control circles back around to commodity PCs. One can’t have “one of every combination” to test against, and if they did, it would be obsolete by the time they finished testing. Laptops are a great example: a Lenovo XYZ today may not be the same internally as a Lenovo XYZ of 2 weeks from now because parts go EOL, someone finds a similar part cheaper.

Everyone has their own tolerance, but since ZFS and BE’s let your roll back quickly, take advantage of them. Take a snapshot of everything working, upgrade, find problems, report them as best you can with detail to help root cause the problem, roll back continue working.

@RodMyers that rumour is interesting. I can see it providing a path for checking the hardware and figuring out which nvidia-driver to install. Nontrivial, but it would be a path.

(my opinion)
With anything !windows && !mac sometimes it’s better to stay one generation back if you can. For 99% of the normal use one generation back on video and cpu with maxed RAM will work just as well as latest video and cpu. It’s the 1% that gets you (video/photo editing, large dataset manipulation, etc).


from the rumor I heard. The end user, should know his chipset, will then be able to AppCafe the correct drivers and install.

the simplest fix, and let’s the end user get what they need working


Actually vesa/scfb should always be used for an install and hardware specific drivers after install.

My opinion and I’m not calling the shots :slight_smile:


dang, the devs might be psychic? or pyscho (you call that one :wink: )


I prefer “telepathetic”


this is what the vast majority of linux distros do as well.

nvidia doesn’t seem to play well with unix installation in general


that’s what was discussed the other day, which lead to this probably happening


Just a FYI, but my 1060 under both PC-BSD and earlier versions of TrueOS worked just fine, while under Linux on almost all distributions I tried either wouldn’t work at all, or required a nomodeset vga=795 kernel option. Shrugs… the joy of hardware testing. :stuck_out_tongue_winking_eye: