First attempt to install Trident


#1

Hiya,

Still running this:

12.0-CURRENT FreeBSD 12.0-CURRENT #26 fa797a5a3(trueos-stable-18.03): Mon Mar 26 00:24:47 UTC 2018

So I decided to try to install Trident today. Downloaded Trident-18.12-PRERELEASE2-x64-20181219.iso and burned it to a DVD. Put in a blank SSD, had to switch to UEFI, booted and tried to install. Got to the point where it’s trying to launch X11 and I get an ever repeating series of:



Until it finally times out.

I’m running my Dell Latitude E6510 laptop. Been using it with PCBSD/TrueOS since 2009 or so.

Popped my old HD back in, switched back to legacy boot and all is right again, except I’m on an outdated version of TrueOS.


#2
First I would confirm that I have Dell's latest BIOS:
<URL:https://www.dell.com/support/home/us/en/04/product-support/product/latitude-e6510/drivers>

Then I would open an issue against trident-installer in GitHub with the 
output of pciconf(8) -lv and dmidecode(8).

John
groenveld@acm.org

#3

Maybe, try to write the installer .iso for an USB key (don’t worry,I know this is an .iso not an .img file :slight_smile: ) and try the install from this USB key in legacy BIOS mode, this woks for me!


#4

It works for me too.:hugs:
I had exactly the same symptoms


#5

:slight_smile:


#6

No luck. Someone have a link for the trident github page?


#7

see if this release will install

http://pkg.project-trident.org/iso/archive/RC2/


#8
<URL:https://github.com/project-trident/trident-installer/>

The /etc/X11/xorg.conf from your working TrueOS 18.03 
and the broken /tmp/xorg.conf from Trident installer would be helpful too.
You may be able to get to a shell prompt via CTRL-ALT-F1 when X11 hangs
to inspect the generated /tmp/xorg.conf.
John
groenveld@acm.org

#9

I submitted a bug report. If it’s not good enough, ie, need more info, please let me know.

Thanks for all you folks do.


#10
The broken /tmp/xorg.conf generated by Trident installer would be helpful.
A screenshot, if bringing up the network or using sneakernet via a USB stick 
is a PIA for you.
John
groenveld@acm.org

#11

I’ll see what I can do.


#12

Yep, that worked. Not sure it came up in the resolution I prefer as with TrueOS, but it installed and I was able to log into Trident and get a working desktop.


#13

RC2 can be upgraded to the latest


#14
As Rod recommends, a "trueos-update upgrade" will get you to the 
latest pre-release which will likely just work.
If not, we need to see the output of kldstat(8) and /etc/X11/xorg.conf.

I believe trident-installer still has issues with picking the correct VGA 
and  loading the right modesetting drivers.
John
groenveld@acm.org

#15

OK, finally got around to trying this last night. Got it installed and running, got wireless working.

Tried to launch control panel and app installer and I get a popup error “The local sysadm service does not appear to be running. Please start it then try again.”

So I drop to qterminal and “service sysadm restart”, then ps to verify that it’s running, and it’s definitely there.

So I figured maybe I need to to the “trueos-update upgrade” first. I get “ERROR: Failed upgrading package repo”

Ran “pkg update” to try to determine if I could get a better error and it appears to be looking for a repos:

http://pkg.project-trident.org/pkg/release/base/FreeBSD:12:amd64/latest/meta.txz

as well as packagesite.txz which fails.

I assume that the “12” should be “13”, but I wanted to ask before I go modifying anything in /var/db/pkg/

I also get the error:

access repo file(/var/db/pkg/repo-TrueOS-ports.sqlite) failed: No such file or directory

I assume this is spurious and will be created if the proper remote repos can be found.


#16

which ISO?

run it with the -f option

sudo pkg check -f

the sysadm error sounds like 2 or 3 releases ago


#17

RC2

You folks said it could be upgraded to the latest so I went with it.


#18

yeah, i think it can. let me as @beanpole135 to make sure.

Edit:

try this script --> https://pkg.project-trident.org/repo-config/install-trident-repo.sh


#19

Thanks man, I’ll try it at home as $work network fascism wont allow it.


#20

once RC2 is installed, do the following in a terminal

fetch https://pkg.project-trident.org/repo-config/install-trident-repo.sh

sudo trueos-update check -f

sudo trueos-check upgrade

doing this with virtualbox. appears to be doing the right thing

Edit:
this upgrade did work. My virtualbox session is at the latest release today.