[Finished] TrueOS Q&A with Kris & Ken Moore 6/16/17


When do you guys plan to move away from Fluxbox and make Lumina manage its own windows? Also, does iocage have a full functioning api for sysadm? What changes still need to be made to sysadm?


HAL was one of the services listed specifically as a vulnerable exploit within one of the recent WikiLeaks document dumps that allowed a remote user to gain root-level access to a system. It is strongly recommended that hald not be enabled for any internet-facing systems.


thank you beanpole 135.


Thanks Kris,

Let me know if you need me to test anything. Being a bad example and a crash test dummy seem to be what I do best. :smiley:

That log I included above is from my laptop, which is running a plain vanilla pool. It was working fine until the update after your office move.


The exact issue with the HAL exploit has not been fully discovered as the exact nature of the attack is not publicly known at this time. We do not ship HAL by default, but depending on what you install it may be pulled in as a dependency. There is a discussion in the FreeBSD bug to get HAL disbaled in GVFS (the reason it gets pulled in by so many packages. If interested you can read the short discussion here: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=217844


Both of these are in-progress.
I have about 50% of the iocage API for SysAdm finished, and once Lumina 1.3.0 is released I will be vanishing from the world for a little while so I can finish getting Lumina 2 (built-in WM) up and functional (most of the hard work is done - just need to dedicate some time to start assembling all the individually pre-assembled pieces)


@to-user asks (BTX loader read error):
When booting one of my systems I always get an error message:

BTX loader 1.00 BTX version is 1.02
Consoles: internal video/keyboard
BIOS drive A: is disk0
BIOS drive B: is disk1
read 1 from 0 to x7d8a6350, error: 0x40read 1 from 0 to 0x7d8a6350, error 0x40

That is relatively new and, I’m pretty sure, not really good.
Also all existing BEs didn’t properly boot. I was able to install the June 1st 2017 image into a new BE and working with it just fine.


I have tried to install virtual box from appcafe and from ports and in both situations i couldnt make it work.
I dont remember the exact errors but i will try again and post them and maybe you could help.
Also may i ask what is the best graphical virtualization to use and if you have a guide, i would really appreciate.

Thank you


That sure looks like a read error… Have you run SMART tools or other utilities to verify disk is OK?

BTX loader read error

We tend to use VirtualBox for our systems, and it works fine if you remember to add your user to the “vboxusers” group on the system and logout/login before you try to start up Virtualbox. This is just a requirement of the package and not really something we have found a way to simplify yet.


After you install VirtualBox, you need to make sure your user is added to the “vboxusers” group. But now that you mention it, we may need to just automate that :wink:


Is there a decent workaround for the annoying mouse issues in VirtualBox? I may be missing something basic but the scroll wheel randomly clicking things breaks my automatic piloting :stuck_out_tongue:


Hi Kris , i think i tried a few things including your advice. I will definitely try again and post the errors.
But apart from virtual box , what could i try?


Hello. My name is Lev Andropov from the Russian space station. We use TrueOS for long time but our hardware systems are always causing bad disaster for the space station! Can you recommend best hardware for use with TrueOS. The motherland thanks you.


If it helps, you can put a photo of me in your wallet, to remind you that you better get that done!


Make sure you have the “virtualbox-ose-additions” package installed and the driver loaded. That helps a lot when running TrueOS as a “guest” within a virtualbox VM.


This is running TrueOS from within VBox? That’s a good question, I don’t have an answer offhand, other than to suggest installing the vbox extensions if they are available or look into various xorg.conf mouse settings.


:slight_smile: What hardware is rated for space, does that need special shielding and whatnot? But for terrestrials I’d recommend Nvidia video, Intel on laptops (of course). Nothing wrong with AMD CPUs if thats your bag. More ram the better, and ZFS does allow disk mirroring / raidz setups, take advantage of those things!


I install TrueOS on my FreeNAS mini, great little unit, loads of ram, and plenty of disk space to expand into! it’s a nice little micro tower that fits under my desk that runs near silently.
Check it out : https://www.ixsystems.com/freenas-mini/


Just make sure you have ECC memory for the space station - cosmic particle hit counts are a lot higher up there than down here… :wink: