Finally got anydesk to work (kindof)


#1

So I’ve been trying to find a remote control application for BSD and it was super hard. I came across AnyDesk but it was two years ago and I was too new to Unix and those missing *.so messages scared me away. I decided that it was too hard to install for a novice like me and moved on. Now that I’m a little wiser, I decided to give it another shot. And if you find yourself in a similar situation to the one I was in, these are the steps that I took to get it to work.

AnyDesk now starts, but it hangs on “connected: waiting for image.” I thought lowering the resolution would eliminate that, but it did not work even with the lowest 640x480 resolution.
Any tips on this will be appreciated.

I was trying to do it from TrueOS to TrueOS machine. I’m going to try from Windows, to TrueOS tomorrow, and see if that makes a difference
Also I always have to do steps 11-13 is there any way I can have that done on startup?


The ONE application that you miss the MOST on TrueOS
#2

I actually got it to work a few month back - the same version I guess. I’m not sure if I did everything you listed, I’m quite sure I didn’t any ports.

It worked almost fine. I connected to a windows pc but in one direction the connection would not be established. As I was testing to find out if I could switch my mom’s laptop from linux to TrueOS and have a working remote access (or at least to be able to access her linux system from my TrueOS system - because teamviewer doesn’t work (for me anyways) on TrueOS) I guess it was the direction of accessing the TrueOS system from the windows one.

Somehow I got it to work a while later. I’ll check my TrueOS system because I made some notes of what I did or had to install to make it work.

[Edit:]

So, my notes are quite lean.

  1. install gtkglext (I did that via AppCafe, too)
  2. add

kldload_mqueuefs=“mqueuefs”

to /etc./rc.conf to have it be loaded at startup.

I’m not sure if I maybe forgot to write down something else but if there was a hard nut to crack (for me anyways) I’m pretty sure I would wrote it down because I certainly would have forgotten it by now.

As for the installation of anydesk, I’d say I used Lumina Archiver as sudo, exported the files to /usr/local/share/anydesk/ and made the program file executable using Thunar as sudo. Yep, I’m a Windows guy, so I’m a GUI and mouse guy… :slight_smile:

[/Edit]


#3

This might be coincidence, but (I doubt it) and suspect it’s related to my AnyDesk adventure yesterday.

I tried opening Firefox this morning, and it wouldn’t open. So I went to a terminal, and typed “firefox”

This is what I got

After duckduckgoing it on Qupzilla (since Qupzilla doesn’t seem to have a problem). I found several Linux forums that said to just install openssl. I went to SysAdm and installed it, and it’s still not opening. I would really like to have FireFox and AnyDesk if that’s a posibility. I really hope it’s not a binary choice where I could only have one or the other.


#4
$ pkg which libssl3.so 
/usr/local/lib/nss/libssl3.so was installed by package nss-3.33_1

The library is installed by nss. Try to reinstall it.


#5

I deleted and re-installed Firefox from within SysAdm. That did not work, I deleted Firefox from within SysAdm again, and this time I tried to reinstall from TrueOS ports. It kept telling me to uninstall different things because there was an older version already installed and it needed to install the newest package (nss) was one of those packages.

I now have AnyDesk, and Firefox, but now when I try to open LibreOffice, I get this.

I wonder how many other things are broken. I might just have to reinstall the O.S.


#6