Failed update from PCBSD 10.3


#1

Dear all,

I finally have decided to upgrade to Trueos from PCBSD 10.3. Following the instructions of the handbook, I have a ffew problems in the process:

1.- The USB stick at boot time complains with wrong partition table!. After pressing “enter” the installation goes on smoothly.

2.- When the installation finishes after the reboot, the new system is not in the boot menu.

3.- I log in my old pcbsd, and find with beadm that actually there is a boot image called 12.0 current. I reinstall GRUB.

4.- Now the new system appears in the boot menu, but if I choose to boot it, I get an error zpool.cache not found.

5.- This problem seems to be similar to Moving from GRUB to BSD Loader but the solution proposed there is not valid form me because I have MBR HDD (lecacy BIOS).

Now the system seems to be there but I am unable to finish the upgrade. Are there instructions available for this upgrade for legacy BIOS with an MBR HDD.

Many thanks,

A.


#2

when you boot up and use beadm, you see the 12 image, can you “activate” that image?


#3

Yes, I have done that. I have activated the image, put it by default. It boots, but complains with " zpool.cache not found".

If I understood the issue correctly I have to erase GRUB, and install the FreeBSD boot loader, but I do not know how to do this with legacy instaklled in the BIOS and a MBR hdd.


#4

look through discourse. i think there is a howto. if not here, try trueos.org and look at the blog


#5

Well, as I commented I have found this similar problem: Moving from GRUB to BSD Loader (in fact a post by yourself). These instructions do not work for me:

gpart modify -t freebsd-boot -i 1 ada0

gpart: Invalid argument

Geom name: ada0

modified: false
state: OK
fwheads: 16
fwsectors: 63
last: 500118191
first: 63
entries: 4
scheme: MBR
Providers:

  1. Name: ada0s1
    Mediasize: 256060417536 (238G)
    Sectorsize: 512
    Stripesize: 0
    Stripeoffset: 64512
    Mode: r2w2e4
    attrib: active
    rawtype: 165
    length: 256060417536
    offset: 64512
    type: freebsd
    index: 1
    end: 500118128
    start: 126
    Consumers:
  2. Name: ada0
    Mediasize: 256060514304 (238G)
    Sectorsize: 512
    Mode: r2w2e6

Geom name: ada0s1
modified: false
state: OK
fwheads: 16
fwsectors: 63
last: 500118002
first: 0
entries: 8
scheme: BSD
Providers:

  1. Name: ada0s1a
    Mediasize: 253902192640 (236G)
    Sectorsize: 512
    Stripesize: 0
    Stripeoffset: 64512
    Mode: r1w1e1
    rawtype: 27
    length: 253902192640
    offset: 0
    type: freebsd-zfs
    index: 1
    end: 495902719
    start: 0
  2. Name: ada0s1b
    Mediasize: 2147483648 (2.0G)
    Sectorsize: 512
    Stripesize: 0
    Stripeoffset: 499186688
    Mode: r1w1e1
    rawtype: 1
    length: 2147483648
    offset: 253902192640
    type: freebsd-swap
    index: 2
    end: 500097023
    start: 495902720
    Consumers:
  3. Name: ada0s1
    Mediasize: 256060417536 (238G)
    Sectorsize: 512
    Stripesize: 0
    Stripeoffset: 64512
    Mode: r2w2e4

So I am lost here…


#6

at best, withing beadm , remove the bad image, and try again?

No other ideas here


#7

I had that error message, too, back when… but my TrueOS BE booted anyway and never showed that error message again:

"After reboot the usual grub menu shows up, but interestingly enough the 10.3 BE is listed on the first screen, the 12 current BE of TrueOS is only on the BE selection screen. Even though it is marked as “default” BE (as I later saw).

Chosing the TrueOS BE I get the first error message: “zpool.cache not found” or something like that. But the boot process starts anyway. And any later (re-)boot does not show this error message again. Apparently the system “heals” itself and writes a new zpool.cache."

Source: https://forums.pcbsd.org/thread-21016.html

So, that error (message) isn’t that uncommon. But with my system there was no real problem. So, other than that info, I have nothing. Sorry.


#8

You can find more information here. I cannot say it will be helpful:


There’s clearly a bug in the upgrade from PCBSD 10.3 process.


#9

Do I have to understand from all this that the upgrade from PCBSD is broken in TrueOS? Is there any plan to repair this feature?


#10

according to the devs, the best way to accomplish this.

A fresh install into a new Boot Environment (BE)


#11

Be aware that probably you won’t be able to boot into PCBSD 10.3 anymore after that. No return.

Backups are welcome.


#12

So I get the same issue when issuing

gpart modify -t freebsd-boot -i 1 ada0
gpart: Invalid argument

the two following arguments also fail with an error message:

gpart: Device busy

How can I then activate my 12-Current BE now?

Any help is much appreciated. Many thanks!


#13

how about looking at the --> beadm <-- command?

to enable Boot Environments


#14

I thought that was already clarified in the previous poster’s request. It does not work!
The current BE is my 10.3, the active one is 12.0 and it simply does not do anything.
When I manually update grub, it shows the 12.0 one and THEN the issues why we’re here here for in the first place appear.

So I tried a few reinstalls and noticed there’s actually an error message showing up during install:

grub-mkconfig: file not found

or something along that line. So I looked at the install media and saw there’s actually no grub binary on the install media (I also tried the latest October build) but the script is executing it. Maybe that helps.


#15

I’ve made some screenshots of the error messages, in case it helps:

https://postimg.org/gallery/1eafhok6u/b65a079e/


#16