Facebook and logging into this forum [Facebook was not involved. Solved by reconfiguring NoScript]


#1

Is it true, that logging in to this forum becomes
impossible, if I’m blocking Facebook in my browser?

If it is true, will it be changed?

If it is true, and won’t be changed, would You please
delete my account and all my data You control
concerning me?


#2

no idea what you are talking about. No idea where you heard that

you do NOT give enough details on that situation


#3

Since first half of April, I can’t login any more. Only change I did was blocking facebook in browser.

I didn’t hear it, I’m seeing it myself.

Because there’s a Facebook-button within the login-input popup, I’ve no other explanation.

If You can tell me, my facebook-blocking is not the cause of
impossibility to log in, then fine. Must be something else, then.

But I can successfully login into other forums. Therefore,
it’s improbable, that I was doing something totally wrong myself. I suspect now, it’s Your forum’s web-programming,
which is causing this.


#4

how are you blocking facebook?


#5

One can also login with Github credentials.


#6

How I block Facebook:

  1. AdBlock Plus
  2. NoScript
  3. uBlock Origin

#7

check your uBlock blocking.


#8

OK. Will restart Firefox with PlugIns reenabled. Then I’ll post the details.

Edit:
First intermediary result:
NoScript alone seems responsible for impossibility to login, because login was still impossible after disabling Adblock Plus and uBlock Origin. Only after additionally disabling NoScript, login became possible again.

Next, I’ll post, which script-sources I did disable for this forum, and which I did keep enabled. Wait a momment…

2nd intermediary Edit:
After reenabling both, AdBlock Plus and uBlock Origin, while keeping NoScript disabled, login is possible. Therefore, only my NoScript configuration seems responsible. Next, I’ll post NoScript configuration… Wait a moment…

3rd Edit:
After changing the NoScript-Settings for
https://discourse.trueos.org”, login became possible, again.

Interestingly, I had to switch to CUSTOM and enable FETCH permissions.

This wasn’t neccessary before on the TrueOS WebSite, and isn’t necessary on other forums.


#9

Final Posting: Problem solved.

Solution: NoScript’s CUSTOM FETCH permission is needed for successfully logging in onto
https://discourse.trueos.org”.


#10

glad we could help :slight_smile:

seriously, glad you found the issue


#11

Thanks for motivating my search and rescue operation.

I really thought it was the facebook button.


#12

Congrats on blocking FB !! I kicked Uncle Zuck out of my computer not too long after the election.

Where I come from, the ultimate “Terms of Service” are the Constitution of the United States and not something FB cooks up.


#13

Congrats in return!


#14

We strongly believe this topic does not belong into the https://discourse.trueos.org/c/security category and should therefore be moved to Help and Support instead, since it has nothing to do with TrueOS security.


#15

And I strongly believe that scripting is a security and privacy risk, that should be minimized,

especially because this forum uses scripts from google-analytics and google-syndication. This should be blocked as strongly as possible.

Edit:
Remember Google’s unremoveable Super-Cookies in Apple’s Safari-browser. Already forgotten?


#16

That’s correct, you need fetch enabled for https://discourse.trueos.org, in current NoScript for Firefox (Quantum). Custom settings are not required. Check your Options in NoScript and go to tab General and section TRUSTED, then set fetch there. Also we allow ECMAScripts for https://discourse-cdn-sjc2.com (same settings).

Yes, we completely agree with that. However it is not a TrueOS security topic…


#17

This I will not do. Because:

Why always allowing anything by default, if it’s not nearly always needed or wanted?

That’s not my idea of how “secure by default” works.

But Thanks for Your thoughts.


#18