Evolution (Gnome mail client) does not work after last upgrading


#1

Hello.

The error is segmentation fault.


#2

A) This isn’t specific enough.
B) Find out, where exactly it seg-faults.
C) Then, file a bug-report with debugging output.


#3

Ok, dmesg says
pid 29949 (evolution), uid 1001: exited on signal 11

I have found something about this:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226460
but it is quite difficult for my understanding I see… Looks like I must find new mail client?

Best regards.


#4

If You have nothing better to do,
try:
gdb evolution
then: run
then: wait for segfault
then: bt
then: quit


#5

Thank you very much. That is what I have getting:

(gdb) run
Starting program: /usr/local/bin/evolution
[New LWP 100673 of process 76223]
[New LWP 100674 of process 76223]
[New LWP 100675 of process 76223]
[New LWP 100677 of process 76223]
[New LWP 100682 of process 76223]
[New LWP 100684 of process 76223]
[New LWP 100685 of process 76223]
[New LWP 100686 of process 76223]

Thread 1 received signal SIGSEGV, Segmentation fault.
0x0000000802bc394b in icaltzutil_fetch_timezone () from /usr/local/lib/libical.so.2
(gdb) bt
#0 0x0000000802bc394b in icaltzutil_fetch_timezone () from /usr/local/lib/libical.so.2
#1 0x0000000802bc52fd in ?? () from /usr/local/lib/libical.so.2
#2 0x0000000802bc5406 in icaltimezone_get_component () from /usr/local/lib/libical.so.2
#3 0x000000081f67a0d3 in ?? () from /usr/local/lib/evolution/modules/module-calendar.so
#4 0x0000000806a85386 in g_type_create_instance () from /usr/local/lib/libgobject-2.0.so.0
#5 0x0000000806a76f46 in ?? () from /usr/local/lib/libgobject-2.0.so.0
#6 0x0000000800665fe5 in ?? () from /usr/local/lib/evolution/libevolution-shell.so
#7 0x0000000806a73c42 in ?? () from /usr/local/lib/libgobject-2.0.so.0
#8 0x0000000806a73833 in g_object_new_valist () from /usr/local/lib/libgobject-2.0.so.0
#9 0x0000000806a731d4 in g_object_new () from /usr/local/lib/libgobject-2.0.so.0
#10 0x0000000803b145a9 in ?? () from /usr/local/lib/libedataserver-1.2.so.22
#11 0x0000000803b62d3c in e_type_traverse () from /usr/local/lib/libedataserver-1.2.so.22
#12 0x0000000803b62d22 in e_type_traverse () from /usr/local/lib/libedataserver-1.2.so.22
#13 0x0000000803b62d22 in e_type_traverse () from /usr/local/lib/libedataserver-1.2.so.22
#14 0x0000000803b14522 in e_extensible_load_extensions ()
from /usr/local/lib/libedataserver-1.2.so.22
#15 0x0000000803b146bf in e_extensible_list_extensions ()
from /usr/local/lib/libedataserver-1.2.so.22
#16 0x00000008006604d9 in e_shell_load_modules ()
from /usr/local/lib/evolution/libevolution-shell.so
#17 0x0000000000404290 in main ()
(gdb)


#6

Now, You know the culprit: “libical”.

A) You can now search for info more precisely.

B) You now know, what to write into your bug-report: Exactly, what You posted here.

C) That’s all, You/we can do.


#7

Many thanks).


#8

I have the same issue with evolution and tried a found workaround which fails, as well:

As a workaround, I run manually evolution-calendar-factory using the -w option to wait running until at least one client is connected.

% /usr/local/libexec/evolution-calendar-factory -w &

This link: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226460 shows the bug as closed/fixed, but re-installing libical and evolution still results in a segfault.


#9

when was it fixed/closed?


#10

I assume: Modified: 2018-03-20 02:59 UTC


#11

that makes sense.

The devs have been busy with “real work”, and will get synced with FreeBSD as soon as they can. I’m assuming this week or next.

Once they get in sync again, then they will ge back on some kind of schedule for UNSTABLE


#12