Error vboxdrv fail loading!


When I install virtualbox in TrueOS I run perfectly but now when I do it directly on FreeBSD 12-current, it does not allow me to load the vboxdrv module to the system kernel, this is the error according to dmesg: // KLD vboxdrv.ko: depends on kernel - not available or version mismatch - linker_load_file: Unsupported file type // I am currently using:
FreeBSD seven 12.0-CURRENT FreeBSD 12.0-CURRENT # 0 r323178: Tue Sep 5 14:20:40 UTC 2017 / usr / obj / usr / src / sys / GENERIC amd64
I think it’s about the same version based on TrueOS, I had read that recompiling the module virtualbox-ose-kmod could be solved but I left error 1 did not find the file or something like that.
Can anybody help me? Thank you!!


Probably you need to recompile the kernel module vboxdrv.ko or wait for the new module.
In FreeBSD CURRENT, sometimes, the ABI changes breaking the kernel modules.


I get the error as well, but when I fire up VMBox it runs fine.
Running latest version of TrueOS.


Thanks! i have installed freebsd 11-RELEASE now and its working fine!


freebsd12-CURRENT is dangerous jeje!