Error loading libfuse.so.2 for Krita 4.1.1


#1

When running a new appimage application I get the message
dlopen(): error loading libfuse.so.2

Pouring through all I could find on fuse says I got it installed right, kldstat says fuse.ko is loaded and since I’m on 12 it’ is built-in so I did not have to modify the kernel. I added it to loader.conf.

Seems I had it running before on the same system I recently did a clean install to. The application I’m trying to run is krita-4.1.1-x86_64.appimage. Which has huge improvements from 3.3.3 and even from 4.1 so running anything less is crippling after being on the latest. Reading up on appimage it looks like it should be very self contained besides needing support for the file system.

Latest Current TOS, lots of RAM and CPU.


#2

which version?

can you open a terminal and type -> about <- then post the results here


#3

===================
General information

boot environment now (N) … 12.0-CURRENT-up-20180813_091028 NR 2018-08-13
after restart ® … 12.0-CURRENT-up-20180813_091028 NR 2018-08-13
boot loader …………………………………… BSD
type ……………………… BIOS
CPU ………………………………………………………… Intel® Xeon® CPU E5-2650 0 @ 2.00GHz
number of cores ……………… 32
host ………………………………………………………
memory ………………………………………………… 49152 MB available, 45251 MB free
OS git branch ……………………………………………………………………………………… trueos-master
OS git revision ………………………………………………………………………………… fa797a5a3
OS kernel build time ………………………………………………………… Fri 2018 Mar 23 13:28:18 UTC
OS kernel identity …………………………………………… (uname -i) GENERIC
OS platform (architecture) ……………………… (uname -m) amd64
OS release level ………………………………………………… (uname -r) 12.0-CURRENT
OS version and patch level …… (freebsd-version) 12.0-CURRENT
TrueOS package set ………………… UNSTABLE
TrueOS version …………………………… TrueOS-Desktop-201803131015
uptime ………………………………………………… 7:15
user …………………………………………………… root

More (TrueOS Desktop):

desktop environment …… KDE4
sound card driver ………… pcm0: <Realtek ALC899 (Analog 5.1+HP/2.0)> (play/rec) default
wireless driver ……………… 
X11 drivers ………………………… nvidia_drv.so

#4

Did not know about that command - cool!


#5

Just installed krita on my laptop. Same distro date.

From the terminal, it loads just fine for me


#6

Hmm, thanks. I think. :slight_smile:
Obviously there’s something different between our systems. Not sure how we can compare. I’m thinking the DE should not have anything to do with it but I could try loading the default DE (can’t recall it’s name right now) and see if that works.

Edit.
Which as expected made no diff.


#7

I show libfuse.so.2 in these locations

/usr/local/lib/libfuse.so.2
/use/local/lib/libfuse.so.2.9.4


#8

Yep, same here. Symlinks.


#9

as root, do:
ldd “full path to the krita executable”
that will give you a list of the shared libraries it’s using and any that are missing, etc.
It may be that the krita4.1.1 is somehow built differently and not looking for libuse in the correct spot.

do ls -ltr /usr/local/lib/libfuse*

You typically have 3 items for the .so:
one would be the real file, say libfuse.so.2.9.4, then 2 symlinks both pointing to the real file:
libfuse.so
libfuse.so.2

EDIT:
the “ld” in the first command should have been “ldd”. It’s a useful command to know, man ldd.


#10

Yeah, the typical lib links, got the fuse ones in /usr/local/lib/.

ldd ~/bin/krita-4.1.1-x86_64.appimage

/usr/home/steve/bin/krita-4.1.1-x86_64.appimage:
linux_vdso.so.1 => (0x00007ffffffff000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x0000000800a00000)
libz.so.1 => /lib64/libz.so.1 (0x0000000800e00000)
libdl.so.2 => /lib64/libdl.so.2 (0x0000000801200000)
libc.so.6 => /lib64/libc.so.6 (0x0000000801600000)
/lib64/ld-linux-x86-64.so.2 (0x0000000800623000)

Appimage allows extraction which I ran but it did not extract. However I did get a source dl a couple of weeks ago which contains a whole usr structure. It does not however have a lib64 dir. That is a normal lib dir name on Linux for the lib/app to handle dynamic libs. Maybe I just need to compile it myself…

You indicate that you did not load 4.1.1, what version did you load?


#11

It seems you are running the Linux version of Krita (appimage is a Linux thing), not an actual FreeBSD package.

That may or may not work for you. The issue you are running into in the case above is that it is looking for the Linux version of libfuse, not the FreeBSD one. But even then, I would be surprised if everything worked.

You may want to try installing this through FreeBSD’s (or TrueOS I guess) pkg repository.

pkg install krita

Though the package repository may not be up to date (since it was last updated in March), and you probably need to update the ports tree. Given that we are at a “transition point” between TrueOS to Project Trident, that my be more of a problem than it is worth as the handbook that describes this has disappeared for the moment.

The best bet, if you are patient is to wait for a build of Project Trident to show up, that will probably have an updated version of everything and you can just install Krita from the App Cafe (or pkg as above).

If you are impatient, make a boot environment and start reading up on the FreeBSD ports tree.

Good luck, either way, you will learn some things :slight_smile:


#12

good catch


#13

@twschulz
Yeah, the difference between the pkg version v3.3.3 and 4.1 is HUGE which in turn has a big difference to 4.1.1 which has bug fixes and cleanups that makes it much better and faster to work in. V4 added svn support which today is critical.

Thanks, I realize appimage is a Linux version. Unless I’m willing to dualboot, which cuts me off from daily communications and having to switch between POP and IMAP which is not workable as I save all sent emails as well and becomes a bigger pain, I need to have it work here.

I’m reaching out at the Krita forum as well. FreeBSD users have used it for several years so someone is bound to know how.


#14

Thanks @twschulz; good eye.
@bsdisgood that is why the FreeBSD “Linuxulator” is a PITA sometimes. “it just run Linux executables natively”.

I’m guessing you may simply need to install the correct Linux infrastructure.


#15

@mer I’m a bit unsure, libfuse might require a Linux kernel module and that may not work. On the other hand, it might just only check if the library is there or not. It’s kind of a gamble. Either way, one would need to find the correct libfuse RPM and install it manually.

@bsdisgood According to Freshports, the latest version of Krita in the ports tree is 4.1.1. So, it should work to update the ports tree, but that requires some work too. I guess another option is to install FreeBSD 11.2, then you would likely have a recent version of Krita as well.

Good luck! I’m positive you can run Krita on your machine, it just might take a few more steps than you expect.


#16

@twschulz Ah, never thought to check the ports, figured it would be the same version. That would make life easier. As far as expecting a few steps - I was getting started with cmake to compile it… :slight_smile:
Thanks all for the heads up!


#17

Alright solved.

By using ports I got the latest version. All I had to do was to go into the work/.build/CMakeCache.txt file that listed python2.7 and change that to 3.4 and it compiled. (Plus I finally got to see something use all my cores which never happens.) :slight_smile:

This may very well apply to other applications needing a newer python version.

Unlike other reports I’ve read it starts up at a normal pace. It installed and was added to the menu by the install script. If you have used any earlier version the improvements are very noticeable and well worth the effort.

Thanks to all for helping!