Does Wine work in TrueOS?


I am testing TrueOS in two different VirtualBox installations (STABLE & UNSTABLE). Wine is installed in both of them but I cannot install ms-dos-executables. In PCBSD, when double-clicking an MS-exe file, Wine is automatically launched, everything just works. In TrueOS, nothing happens. When I select “open with” from the right-click menu I am presented with a choice of Wine operations (Wine application, Wine installer, Wine browser, Wine …) but I was not able to install an MS-exe with any of them.
What I forgot to say, after installation of Wine I ran winecfg from the CLI and installed Gecko and Mono.

What has changed with TrueOS?


other than moving from FreeBSD 10.3 to FreeBSD CURRENT, not much has changed

I would look at the FreeBSD mail lists to see what has changed. Or contact the FreeBSD maintainer

and I am using wine/PlayOnBSD myself


I’ve used wine in the last 2 weeks to run steam and it works great (playonbsd). I’ve only ever deployed it on hardware so I can’t speak much on how it works in VMs. There is an issue with certain types of icons, but if you browse to the item you want to launch you can still run it no problem.


Thanks all, I installed playonbsd just to be sure I am testing under the same conditions as both of you @RodMyers, @JoshDW19. But it still does not work. Maybe it is some VM thing then… I changed the topic, btw, it seemed unnecessarily definite. :wink:


That’s really odd. I’ll spin up a VM and see if I can help you out.


That is really nice but not necessary for my part. I was just playing around with TrueOS while waiting for another issue to be resolved so I can finally make the transition from PCBSD to TrueOS. As nobody else seems to be having issues with Wine I am quite optimistic now. Thanks a lot anyway!


Fresh install of TrueOS-2017-06-01-x64 STABLE on Lenovo Thinkpad T520, 8 GB RAM, using integrated graphics with intel driver.

Wine does not work. I started winecfg from the CLI before but when I double-click some *.exe file wine is supposed to automatically start. But nothing is happening. When using the “open with” dialogue I tried several wine binaries from /usr/local/bin but none worked so far.


STABLE or UNSTABLE? on UNSTABLE I have PlayOnBSD installed and working


It’s STABLE. Before installing on bare metal I tested TrueOS in two Virtuabox installations - STABLE and UNSTABLE. Both had the same problem.


i’m on UNSTABLE, and have PlayOnBSD installed. it relies on wine, and for me it’s working

very wierd


Wine works on STABLE, here.
I’m using i386-wine-staging.


Thanks, @Sergio. i386-wine-staging works. :raised_hands:


I am on UNSTABLE, and I have i386-wine-2.0.1,1 with playonbsd-4.2.10_1. I tried installing i386-wine-staging, and it wants to uninstall playonbsd.

I have had fits with the couple of apps I have tried to install. I tried to install the Kindle app, which seems to be broken (the latest version is listed as bronze on winehq). I tried installing this both in playonbsd and on straight wine. I would get the Kindle splash screen then nothing.

Note that I have had both Starcraft and Starcraft II WoL working on linux.
I then tried to install Starcraft II Wings of Liberty, and that failed as well. Again, it iinstalled, but the game crashes as soon as it starts.

Since part of my problem is the way FreeBSD mounts (or doesn’t mount) DVDs, I’m going to try the original Starcraft just as a point of comparison.


Am I the only one that thought “Red or White?”


Probably, yes …


Start Wine with the console. Maybe there’s a problem with 3D screen rendering, you can see on the console.
Wine works here, but I cannot run applications that require 3D rendering.
(If you need PlayOnBSD with wine-staging, you could rebuild PlayOnBSD in ports, changing manually its dependency on Wine.)