Distorted sound in headphones only


#1

I’m observing a serious sound distortion when played through headphones on my laptop. There is no issues when played through the built-in speakers. The laptop is dell inspiron 5749 with realtek ALC3234 sound card reported as Realtek ALC255 by cat /dev/sndstat.

I’m not sure whether it’s a driver issue or misconfiguration which can be corrected with device.hints etc.


#2

from a terminal, the mixer command will show current levels, it’s useful for quickly adjusting volume and a few other parameters. I’m assuming the headphones are analog headphones, plugged in to the headphone jack? I’d try using the mixer command to set the volume lower and see if that helps.
systcl -a | grep snd will show controls available that may help.


#3

Also, you can set the volume for each output device with the volume control widget - usually right in the taskbar.

For instance; mine is slightly louder for the external headphones than for the internal loudspeakers.


#4

You are correct, those are analog headphones plugged in to the headphone jack. I tried couple of them, but with the same results; and they seem to be working fine under windows on the same laptop. Also, I tried to tune up the mixer output from the pc-mixer UI before and that didn’t help, unfortunately. I’ll give it a try with the terminal when I get back home just in case. However, I’m afraid I should’ve described the “distortion” more. It sounds like if some frequencies are cut out from the output spectrum. For example, there is no speech in the output, but volume of other frequencies is high. I’d blame an equalizer if I had one set up, but I don’t. The system is on default settings. Besides, the equalizer would’ve affected the speakers output too I guess.


#5

That is odd. What application were you using? Sometimes picking the wrong device can have weird effects.


#6

With Chromium and Firefox playing youtube and some internet radios with both pulseaudio on and off if that matters. I haven’t tried local media yet, but i will… for the sake of getting the full picture.


#7

Same problem with VLC playing local media.
Adjusting volume with mixer from terminal has no positive effect either.
Also, I tried tweaking different options listed in man sound, e.g. equalizer and vchans-related with no positive result… or maybe I just don’t know how to “cook” them properly. The only option left there is FEEDER_EQ_PRESETS, which will probably require me to recompile the kernel and I’d like to avoid that.


#8

On my Intel NUC - which uses a Realtek ALC283 for the headphone jack - I also had distorted sound (there was a comb filter effect going on).
I had to open pavucontrol and klick on the “lock channels together” button but so that they are separated. Then I pulled down the volume of the right channel. Don’t ask me why but that got me clean sound in stereo.

After the latest stable update (03/18) pavucontrol was missing on the system but could be installed via App Cafe.


#9

That’s it! I didn’t even have to use pavucontrol. In mixer’s pcm settings, slight volume disbalance between L and R channels “fixes” the problem. Which keeps me wondering whether it’s a bug in the driver or in the mixer.

Thank you all for your help.


#10