Disk Wizard screen feedback


[Alt n] doesn’t seem to work in the Disk Wizard installation screen. And it seems there should be an option to skip installing a boot loader.


The option to skip installing rEFInd has already been added to the installer. The next images we push out will have that change… :wink:


That’s good. I assume I must wait for the next release for that installer.

Perhaps this should be posted as a different topic, but I’m confused about my options without the new installer. During booting should I be able to manually boot my Linux partition by:

  1. Escape to loader prompt

At that point, should ‘unload’ followed by “boot” followed by the location of my Linux kernel work? If so, I’m a touch hazy about the BSD partition scheme. My Linux kernel is in /boot of /dev/sda2. I believe I tried ‘boot ada0s2a/boot/vmlinuz’ without success. What am I doing wrong?

And assuming that’s possible, should I be able to boot BSD using grub? I’ve done so before using ‘set root=(0,3)’ and ‘chainloader +1’.

I’m a Linux user but would like to test BSD by dual booting.


I just installed the 06/01/17 image and saw no skip option. Did I misunderstand as shouldn’t that be the next image? And [Alt n] still doesn’t respond.


The option is there - it just got shuffled around a bit prior to the final version of the new STABLE release getting made public:

  1. rEFInd is not installed by default any more.
  2. In the disk wizard, on the page where you select which partition in which to install TrueOS, there is a checkbox called “install rEFInd” (unchecked by default). You need to check that option if you want to install rEFInd as the boot manager on the system.
  3. Note that rEFInd requires booting via UEFI. If you booted with the “legacy” option set in your bios, then the option to install rEFInd will not be visible/available in the TrueOS installer. (it also helps to disable the CSM module in your BIOS if that is available on your system).

As for the Alt+N keyboard shortcut, we can look into it some more, but it seemed to be working during our quick testing. Can you be a bit more specific about the issue? Does it work on some pages/dialogs but not on others? If it does not work for you anywhere, then I would hazard a guess that your keyboard layout/map might not be setup properly - so you should try going through the keymap setup option in the installer first.


I installed with the “legacy” option and the bootloader was installed. I saw no installation option either way.

If you’re saying the bootloader shouldn’t install with “legacy” I strongly support that. I reinstalled grub by jumping through some hoops and can boot BSD through grub but I’d prefer not having to jump through hoops.

[Alt n] works outside the Disk Wizard screen. It fails only on that screen.

I’m willing to test this again if requested. But bottom line, with the 06/01/17 image the BSD bootloader installed with the “legacy” option and [Alt n] didn’t work.


Hi - I would be interested in your hoops - how to. I am pretty much stuck…(have the multi boot setup from PCBSD times still working super with the latest TruOS on a little netbook- so it is obviously possible), but on the hp-laptop it doesn’t anymore… Had to make a new install which didn’t offer the rEFInd option, so no access to Linux anymore… Restamped GRUB, because I found several GRUB files on the system … Of course something is missing…doesnt boot at all anymore .
I would be OK with rEFInd if it would install. The only other option would be to install an earlier version of TrueOS and hope it keeps the settings after the updates…but the latest ISO would be better for a clean install now…except no option to access other systems except W7 (which I don’t use)…which is curious that this works out of the box
Hope there is a solution


Happy to help if I can. I had /grub on /dev/sda1 (legacy), which contains no OS. After installing TrueOS on /dev/sda3 I booted to a Mint live CD. You could probably use another but I had Mint lying about. After booting I performed the following steps:

1.) sudo -i
2.) cd /
3.) mv /boot /b00t
4.) mkdir /boot
5.) mount -t jfs /dev/sda1 /boot (I use the jfs file system)
6.) grub-install /dev/sda

To explain, grub-install overwrites the current boot loader and installs grub to /boot. As I renamed /boot and mounted /dev/sda1 as /boot, grub-install installs to /dev/sda1.

My old /sda1/grub/grub.cfg files were not overwritten and rebooting got me back to where I was before installing TrueOS. I added the following to grub.cfg and TrueOS boots.

menuentry “TrueOS” {
set root=(hd0,3)
chainloader +1

I hope TrueOS adds an option to omit installing its boot loader. I’ve no interest in starting a Linux/BSD war, but like to boot to both as a new user for comparison.

The above steps worked well for me and I hope it helps. I’ll watch the thread should you have questions or problems.


[quote=“rhubarbpie, post:8, topic:1344”]
I’ve no interest in starting a Linux/BSD war[…] [/quote]

You’d lose every time in a BSD forum, or in this case a FreeBSD(based) forum… Just like we lose every time BSD is mentioned in Linux forums.


Thanks for your detailed answer - I am still learning… Will see…it will take me a little while