Development with QTCreator


#1

Is anybody successfully using qtcreator for developing/debugging QT-Applications unter TrueOS/FreeBSD? I’ve some trouble to debug inside qtcreator:

If configure qtcreator to use lldb, nothing happens when i click debug. The debugger does not get startet at all. If the ports-gdb is used instead, debugging as such works; but the debugger does not stop anymore, even if i press the debug-stop-button or the application gets closed. I have to kill the debugger from a other terminal.

Any ideas?


#2

Have you downloaded the trueos-toolchain?
I don’t know if that will affect debugging, but it might. it’s a needed part of using the git repository for the QT5 applications used in trueos.


#3

pkg info | grep llvm

You may need to specify lldb37 or lldb39, not just lldb


#4

Thank you for your answers. mer’s answer led me to the fact, that i tried only the gdb-interfaces for lldb3x. Using the lldb38 binary solved this issue for TrueOS, thank you.
But I’m still wondering, why this only works on TrueOS. I do have another machine running FreeBSD CURRENT, which behaves for the gdb thing the same way TrueOS does (see start post of this topic). Trying the exact same thing which worked for TrueOS resulted on the FreeBSD machine in not recognizing the breakpoints at all! If i use the debugger (even the gdb) on the console, all works fine. Curious…

[EDIT]
For the records: it seems that qtcreator has some problems with symlinks. On my FreeBSD machine, the path to the qt-project contains a symlink, on TrueOS not. Providing a path without symlink in it, debugging works also on FreeBSD.