Dell Precision 7520 -- hw support?


#1

I have a recently-acquired, refurbished Dell Precision 7520; I have been able to install both FreeBSD and TrueOS on it, and the OSs run OK… but the mouse/cursor doesn’t move, and the wireless NiC:

none7@pci0:2:0:0: class=0x028000 card=0x03101028 chip=0x003e168c rev=0x32 hdr=0x00
vendor = ‘Qualcomm Atheros’
device = ‘QCA6174 802.11atc Wireless Network Adapter’
class = network

isn’t recognized (in either FreeBSD or TrueOS – above was from TrueOS).

What’s currently installed self-identifies as:
FreeBSD d179.catwhisker.org 12.0-CURRENT FreeBSD 12.0-CURRENT #0 7ad4fada6(HEAD): Thu Aug 2 11:37:15 EDT 2018 root@hydra:/usr/obj/root/jenkins/workspace/TrueOS_-Stable-_Complete/TrueOS_Stable/amd64.amd64/sys/GENERIC amd64 1200065 1200065

I believe Dell offers the 7520 running Linux.

[I have been running FreeBSD on a Dell Precision M4800 for about 3.5 years now; I’d like to migrate to a newer machine without losing screen real estate. I’m keeping the M4800 running by swapping parts…]

Any suggestions? Thanks!


#2

If FreeBSD does not find the WiFi, then trueos/Trident won’t find it :frowning:

Trueos/Trident track FreeBSD-CURRENT, aka 13


#3
Do you have a USB mouse to test?
Does not appear that athp has been pulled into FreeBSD yet.
<URL:https://github.com/erikarn/athp>

John
groenveld@acm.org

#5

I tried a USB mouse; it seems to have worked as expected. (Which is useful for diagnostic purposes, but for actual use, it’s not really feasible for me – I use a laptop so I don’t need to move my hands away from the keyboard to use the mouse… and it would be Yet Another Thing to carry on my back while cycling.)

I’m open to swapping the Atheros card for one that FreeBSD supports (and is of the same form factor).

Thanks!


#6
Test with NetBSD and OpenBSD.
The Intel's seem to have better FreeBSD support: iwn(4)/iwm(4).

John
groenveld@acm.org

#7

I grabbed a (compressed) USB image from https://cdn.netbsd.org/pub/NetBSD/NetBSD-8.0/images/NetBSD-8.0-amd64-install.img.gz, then used ‘gzcat /tmp/NetBSD-8.0-amd64-install.img.gz | dd of=/dev/da0 bs=“10240” conv=“sync”’ to copy that to a USB stick. “gpart show da0” then showed:

=>     63  7831489  da0  MBR  (3.7G)
       63     1985       - free -  (993K)
     2048  2865152    1  !169  [active]  (1.4G)
  2867200  4964352       - free -  (2.4G)

I then tried to boot the result on the 7520: I hit F12 while the POST screen was up, so I could select the USB device; for my trouble, I was informed:

NetBSD MBR boot
Error No operating system
Selected boot device failed.  Press any key to reboot the system.

Pressing F12 had no apparent effect. Enter seemed to work, so I tried again – after changing the boot mode from UEFI/unsecure to Legacy/unsecure; that attempt had identical behavior.

How did I err this time? Thanks…

Peace,
david