Current Update Hosed My System


Hey Guys,

I just performed the latest update and my system didn’t come back up. The X11 says something about “can’t find any screens (ee)”. Apparently the upgrade went really wrong because when I rebooted to try a different BE from the menu, there are none listed. :confused: :cry:

Not much else I can do tonight so I guess this is more of a warning than a plea for help. It will have to wait until the weekend before I’ll have time to go dig up some logs.




let me guess. you have an nvidia card in your computer. if so, search the threads. there are plenty of people in your situation, and resolutions


Thanks for your response Rod, you’re spot on. Do AMD cards work better? This has been an ongoing problem in my Debian systems too (the neavau driver or whatever it’s called has been a nightmare). If there is something better, I’d be more than happy to trash my current card and buy something more reliable for FreeBSD. (Just don’t tell my wife I bought computer hardware! lolz) :laughing:


Right now, the best option is Intel


Hmmm, that’s a bummer. Okay, thanks Rod.


Nvidia has their own issues right now


Saw your posts as per What about the NVIDIA driver?
I’ll watch that post for updates.


Yes AMD-cards usually work better than nvidia-cards but google up to which model before you get one.


So my card is an Nvidia GeForce GT635. According to the FreeBSD graphic wiki I’m on the “unsupported” side of things:

My /var/log/Xorg.0.log at

I think the pertinent portion is:
[ 739.726] (EE) open /dev/dri/card0: No such file or directory
[ 739.726] (WW) Falling back to old probe method for modesetting
[ 739.726] (EE) open /dev/dri/card0: No such file or directory
[ 739.726] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 739.726] (EE) Screen 0 deleted because of no matching config section.
[ 739.726] (II) UnloadModule: “modesetting”
[ 739.726] (EE) Device(s) detected, but none match those in the config file.

Here is my pc-updatemanager log:

If I use the installer/tools from usb, I can mount my tank zpool and asks me if I want to chroot into my boot environments (which I don’t see in my on-disk bootloader). That seems to work, however, when I run startx I get the same error. Any thoughts on a way forward?

On the Intel foot. I went looking at my PC specs:
(Brackets to keep the links from expanding into advertisments!)

And it seems my base hardware IS supported. As I don’t play games, I think this might just be good enough?

Is there a way to leave the NVIDIA card in my computer and disable it without rebuilding my kernel? Which I COULD do but I’m truely a lazy man, and that’s why I use PC-BSD…er… TrueOS. :wink:

(boo. your markdown doesn’t seem to support strike through with ~~)


(not teasing you @nielsk just a general poke at my favorite OS)
The graphics page says no hardware assisted video decoding and no audio over HDMI. That doesn’t fill me with great gobs of confidence. I also use HDMI for audio right now. Isn’t hardware assisted video decoding like, what a video card is supposed to do? lolz

It’s moments like these that make me truly amazed at the driver library that Microsoft has been able to amass over the years. For all the things people don’t like about it, at least it works reliably. Owe! Stop throwing things at me! :smile_cat:


Why should I being feel teased? I use TrueOS because I want Skylake-support and not the hassle of running Current and getting drm-next into the kernel myself. It is more of a convenience thing


That’s cool. Just didn’t want to offend. :slight_smile:


This looks good. Thanks Guys!


Turns out something messed my/etc/X11/xorg.conf file.
pkg install nvidia-xconfig nvidia-xconfig

and everything flashed up. I had a quick peak at the conf file before and after and the broken version had
Device modestsetting (or something to that effect). Afterwards it was correctly configured to nvidia.

Anyway, I downgraded my nvidia driver before I found that little tibit, but I think I’ll just leave it at the nvidia-driver-340 level unless someone know a reason not too?

On another note: I rebooted and I’m not seeing any boot environments listed when I press 2 at the boot prompt? For another night I suppose… :sleeping:



beadm list from a terminal after you login. If you have not gone through an update yet, there may not be any listed at bootloader.