Cups printing problem


#1

Hi, I have been tearing my hair out trying to solve a printer problem.
I have a shared network printer… ipps settings are correct and work on my
linux box sitting next to my trueos box…
When I go to print I continually get the following error
Can’t open /private/var/spool/cups/tmp/…
It get’s to 81% then throws the error.
I look in the var/spool/cups directory and I see the job just fine look in the file and it is correct. however the tmp directory contains 3 files with names different than listed in the error.
also /private does not exist anywhere… So I added a symbolic link to it
in root…
Also checked groups and permissions and all are correct…
Help?


#2

can you use the web interface of localhost:631 and see what’s going on?

double check question. is the printer set up the same was as the linux box?


#3

yup.
exactly same.
The error is Can’t open “/private/var/spool/cups/tmp/008esxz7dd"
this is what shows in the cups interface


#4

Have you tried to print different kinds of files? PDF’s, ODT’s, XLS or have you only tried it with one kind of file?..

You mentioned that you checked the permission and they are all correct, but you did not mention what your permissions are set at.

You mentioned that your settings that are the same in Linux and work in Linux (which is irrelevant in this case), but not what kind of driver you are using, or even what kind of printer you are using or what kind of configuration you are using is it shared trough a CUPS server? Is it directly connected to the PC? Is the PC the CUPS server, is the Linux computer acting as the CUPS server? Are you running out of space? Have you done a sudo du -h /var/spool/cups?


#5

have you done a web search for that particular error?


#6

yup

It’s just a default trueos install…
does anyone here have a network printer installed and working with trueos?

help?

Steve


#7

@Groot has a couple of good questions there about the network printer: Is it a standalone network printer, is it served off a Windows PC, served off a Linux PC?
standard CUPS install should have /var/spool/cups permissions as root:cups.


#8

My HP printer is a stand alone printer. I’ve installed all of the cups drivers… It’s a shotgun affect, but everything gets installed


#9

Hi,

It’s an ipps printer shared off of a osx machine. an HP photosmart.
I’m using a cups photosmart + gutenberg driver.
the var/spool/cups permissions are all fine.

I know the printer and ipps settings are correct because those identical
settings work in cups on my linux box.
It writes a spool file just fine. It creates two files one in the
/var/spool/cups directory and one in the
/var./spool/cups/tmp directory both with correct permissions. I’ve
looked inside them all is well.
Then after about 80% it says can’t access
/private/var/spool/cups/tmp/xxxxxxx file and stops.
That file is not actually there. and of course there is no ?private
directory. However I have created a symbolic link in root for it
but it doesn’t matter because that file is NOT in the tmp directory.
It’s there but under a different name.

S.