Chromium 56.0 - buggy?


#1

I tried to use Chromium 56 a few times since the update. It seems buggy to me.

I have gone back to Firefox.

Anybody else notice anything wrong with Chromium 56.0


#2

Can you give an example of what behaviors you experienced? That’ll help everyone verify if they’ve seen them as well.


#3

56.0.2924.87 (64-bit)

$ pkg info chromium | grep -i version
Version        : 56.0.2924.87_1
$ 

Buggy? Yes. A random test:

The funnygov.com page appeared to stop loading, I got nothing from the two tabs that followed, whilst typing this post in Firefox I got a Chromium dialogue offering to kill all three.


@dlocklear01 I have always found Chromium on PC-BSD and on TrueOS Desktop to be far less reliable than Firefox. YMMV.

Chromium compared to Google Chrome

From past experience with various versions of Chromium on Mac OS X – with increased risk of bugs/instability, compared to Chrome – I imagined that the situation with Chromium would be similar on other platforms.

Today I learnt, that’s not necessarily true. In Ask Ubuntu, the accepted answer to What’s the difference between Google Chrome and/or Chromium? What are the advantages/disadvantages to each? refers to:

In particular:

… Google finally offered a (non trivial) way to locate what branch/tag of Chromium was used to produce Chrome. …

The two most recent updates to Chromium at http://www.freshports.org/www/chromium/ are:

  • 55.0.2883.87
  • 56.0.2924.87

The first version is not (or no longer) tabled at http://omahaproxy.appspot.com/ – the ‘closest’ I can find are previously stable 55.0.2883.79 for iOS and previously stable 55.0.2883.91 for Android.

55.0.2883.87 can be found with a tool beneath the table but I don’t know how to tell, from that result, whether it was stable on any of the operating systems that are listed at the Google Chrome OmahaProxy.

The most recent version is stable for Linux and five other types of operating system.

Additional observations

I have no reason to doubt the stability of 56.0.2924.87 on those six OSes (I have not tested that version on any of the six) but on a FreeBSD-based system, for me, Chromium is ridiculously poor. Shortly after editing this post with Firefox, I had just one tab open in Chromium. Not a page that should be troublesome –

– but much of the content failed to appear and the page stopped responding:

I chose to wait, the dialogue reappeared so I killed it.

Only one extension is enabled, LastPass. Average rating 4.65 stars (“loved”) with more than twenty thousand ratings, so doubt that this extension is amongst the root causes of problems here.

Just observing. (I don’t seek help with Chromium, prefer Firefox on TrueOS Desktop.)


#4

It is my novice observation that on 03-02-2017, Chromium 56 performs poorly when
compared to FireFox 51. I am going to uninstall Chromium.


#5

I noticed strange behavior in Version 60.0.3112.113 (Developer Build) (64-bit)
After several tabs opened, Chromium displays new tab in this fashion:

This weird display is not related to opened url, because it happens randomly on different pages. It even borked sometimes when opening it’s own settings page.

At first I thought it is maybe related to some installed extension, but then I noticed in Settings - Advanced several options and setting them like this solved my problem:

Edit:
I was too fast in claiming it solved problem. I did manage to open about dozen of tabs, but it happened again. So I have unchecked all those “Privacy and security” knobs to see if that will help.


#6