Can't launch 3DPong


#1

Running TrueOS Desktop 18.03 x64 in VirtualBox on a PowerSpec G418 PC, running Windows 10 Pro x64.

In TrueOS, I downloaded the game, 3DPong from the app cafe. The installation succeeded and the app shortcut is on my desktop. When I double click it, nothing happens at all. If I right click and click Launch 3DPong, still nothing happens. All other app shortcuts launch when double clicked. I rebooted TrueOS and still no change.

What am I doing incorrectly?


#2

Just installed it on TrueOS 18.03 Lumina desktop environment. A double click or right click and launch doesn’t do the trick. I started the program via the command % 3dpong $DISPLAY . I didn’t use it but the game is displayed:
3dpong2018-08-01-17-36-47
Unfortunately I am not familiar with virtual environments but on the plain TrueOS it seems to work.

Edit: To get some information about the different options you can read the man page % man 3dpong.


#3

When I typed the terminal command from your post, it simply said “Display: Undefined variable”. I tried some others in the box below, with different results, but still no game. trueos%203dpong%20term

Thanks again.


#4

did you try 3dpong with nothing after it?.. Just 3dpong?


#5

Yes. It just gives me the options shown in the screencap: display1, display2 | --computer, gravity value, etc. Controls V, change view, etc. The game still doesn’t launch.


#6

I think you are missing a dollar sign in front of display, and – in front of computer


#7

I get “Display: Undefined variable” when I type it with the $.


#8

That might just be a problem with the virtualized envirnoment then.


#9

Ah. Not much to do about it then.

Thank you.


#10

Is your TrueOS installing running graphical or just console? $DISPLAY is an “X” Windows thing. As @Groot points out could be the virtual environment.


#11

It’s graphical. That’s why I was stunned when I couldn’t double click the icon.


#12

Ok. Interesting. You say that if you open a term window in that virtual desktop, type in “echo $DISPLAY” you get Undefined Variable?

That is interesting.
What happens if you enter “3dpong :0


#13

I feel like a real dumbo. I was typing display in lowercase. Didn’t realize it had to be in caps. Sorry. :frowning:


#14

Just tried it on plain TrueOS 18.03 and it’s working like using $DISPLAY. % echo $DISPLAY is returning :0, so it’s not that surprising.


#15

We’ve all done that. @RJules3 thanks :slight_smile: