Can't Get Install DVD to Boot


#1

So, my old mother board died, chipset? I installed an Intel DH55TC, 4GB of DDR3 RAM, i5 CPU with 4 cores, and a 120GB SSD. GhostBSD with MATE on a DVD installs and runs perfectly, and a Manjaro Linux DVD boots into the installer, so the hardware is fine. TrueOS 18.03 Desktop will not boot. The system goes through the BIOS notifications, the DVD drive blinks while checking the medium, and then stops. I’ve tried two different DVDs, burned on two different systems. No difference. I remember from earlier discussions before the mother board died that dd’ng to a USB drive won’t work either. Does any one have a suggestion on how to boot and install?
Thanks in advance.


#2

1803 is old

From the trueos telegram channel

The TrueOS “desktop” edition has been discontinued and TrueOS is now a distribution platform (with it’s own server-focused release images as well).

For desktop alternatives we recommend:


#3

So…if I go to TrueOS Downloads, I see 18.06, which is server only, and 18.03 Desktop, which is now replaced by Trident. I installed Telegram, and found al long set of messages about Trident development topics, but no download. Is there a download for Trident?


#4

damn, I just pulled the pinned message down for RC2

Try this link --> http://pkg.cloudbsd.org/iso/release/Trident-RC1-x64-20181008.iso

normally it would be here --> http://www.project-trident.org/download/

RC2 has some major issues. The first link “should” still have RC1


#5

Rod, thanks, but the first link gives me a 404. If I back up to http://pkg.cloudbsd.or/iso/release, I see only RC2, and that is also the only release available on the second link. I’ll wait until things settle down a bit on RC2.


#6

I have my own backup of RC1 on this link, unfortunately no sha files, but it is just re-upload from official Trident site.


#7

@samob, thank you.


#8

samob: Thanks! That DVD/iso boots into the installer. My new problem is that the installer doesn’t see the SSD at the point where the installer asks where to put the system. The BIOS sees it, and I was easily able to format the drive to FAT32 on a Puppy Linux USB key. GhostBSD running on a USB key sees it in the MATE file manager, just not the Trident installer. So I tried to reformat the drive from Ghost on the USB key, and got:

root@ghostbsd:/home/ghostbsd # gpart show -p
=> 63 234441585 ada0 MBR (112G)
63 1985 - free - (993K)
2048 234438656 ada0s1 fat32 [active] (112G)
234440704 944 - free - (472K)

root@ghostbsd:/home/ghostbsd # gpart create -s GPT da0
gpart: geom ‘da0’: File exists
root@ghostbsd:/home/ghostbsd # newfs -U /dev/da0s1
newfs: /dev/da0s1: could not find special device
root@ghostbsd:/home/ghostbsd # gpart destroy -F da0
gpart: geom ‘da0’: Operation not permitted

What am I doing wrong? Or is this another hardware problem?
Thanks in advance.


#9

Looks to me like you are trying to operate on the wrong device.

This is probably the drive (ada0) you should be using in your below commands.
da0 is usually the usb stick you are working from.
Run gpart show with no flags.

hth


#10

Ouch! thanks, harv, now I get:

root@ghostmate:/home/mikeb # gpart destroy -F ada1
gpart: Device busy
root@ghostmate:/home/mikeb # umount /dev/ada1
umount: /dev/ada1: unknown file system


#11

Do you have 2 or more internal drives?
I ask because the “ada1” in your command would point to a second drive in your machine
“ada0” is the first drive and “ada0s1” is the first partion on the first drive.
Again, run gpart show with no flags to see how your devices are laid out.

Also, gpart destroy destroys the partiton table which in your case would be on ada0(disk) not ada0s1(partition).
If you just want to delete a partition(ada0s1) use the gpart delete command.
Please reread the man page-especially the examples at the end- otherwise you could really do some damage.


#12

Harv: I do indeed have two drives, this is my “BSD machine”, and I have Ghost running quite happily on the first drive. I have explored this topic at some length on both the FreeBSD manual and on the net. I did originally post my “gpart show”; it looks like this:

gpart show -p

=> 40 234441568 ada0 GPT (112G)
40 512 ada0p1 freebsd-boot (256K)
552 226396160 ada0p2 freebsd-zfs (108G)
226396712 8038400 ada0p3 freebsd-swap (3.8G)
234435112 6496 - free - (3.2M)

=> 63 234441585 ada1 MBR (112G)
63 1985 - free - (993K)
2048 234438656 ada1s1 fat32 [active] (112G)
234440704 944 - free - (472K)

So, when I try to format the first partition, I get:

newfs -U /dev/ada1s1

newfs: /dev/ada1s1: failed to open disk for writing#

mount ada1s1 /dev/ada1s1

mount: /dev/ada1s1: Not a directory

(Sound of head beating table)

What I’m trying to do is to set up the disk so that I can successfully install RC1. The SSD was formatted to FAT32 on Linux GParted just to clear everything. That didn’t work, so now I’m trying to clear everything on BSD and install a BSD file system that the installer can detect. There’s lots of documentation on how to
install and format a new, clean disk, but almost nothing on how to clear a partition,other than the “newfs” command. The man pages include flags and terms that are not defined, like -i “index”. I’m reasonably fluent with Linux command line, but have not found the extent of basic knowledge of FreeBSD that I need, despite many hours of searching and reading several paper books which have become obsolete. Please, can you suggest how I might redo this disk’s partition table and first partition so that the RC1 installer will detect it? Thanks again for your time.


#13

First I should mention RC-1 didn’t work for me.
USB image wouldn’t boot and DVD image wouldn’t let me past install location page.
See here:

I generally use gparted liveUSB and haven’t had trouble installing any of the bsd’s I’ve tried- except RC-1 so don’t think partition program is the issue.

Not sure about newfs command- don’t use it much.

The examples at the end of the gpart man page helped me understand it better. For example ‘-i index’ is just the spot where info about partition is found in partition table. So ‘-i 1’ refers to first partition and ‘-i 3’ refers to third partion on a disk.

But anyway,
Lets start off with the easy stuff- your mount command.
mount [-t type] device mountpoint
so
mount /dev/ada1s1 /mnt( or other existing directory of your choice)
or
mount -t msdosfs /devada1s1 /mnt (’-t mdsdos’ due to FAT32 filesystem)

From gpart man page:

Deleting partitions and partitioning scheme
If you get a Device busy error when trying to destroy a partition table,
remember that you must delete all its partitions first with the delete
action. In this example, assume we have da0 with three partitions:

       /sbin/gpart delete -i 3 da0
       /sbin/gpart delete -i 2 da0
       /sbin/gpart delete -i 1 da0
       /sbin/gpart destroy da0

 Alternatively, you can invoke the destroy action with the -F flag.

So,

‘gpart destroy -F ada1’ should destroy the partition table on ada1.
Alternately
‘gpart delete -i 1 ada1’ deletes first partition
‘gpart destroy ada1’ destroys the partition table

Either should give the same result.

Then the first example shown in the man page should work for creating new partition table and partitions.

hth


#14

harv: thank you! What happened this time was:

#gpart show -p
=> 40 234441568 ada0 GPT (112G)
40 512 ada0p1 freebsd-boot (256K)
552 226396160 ada0p2 freebsd-zfs (108G)
226396712 8038400 ada0p3 freebsd-swap (3.8G)
234435112 6496 - free - (3.2M)

=> 63 234441585 ada1 MBR (112G)
63 1985 - free - (993K)
2048 234438656 ada1s1 fat32 [active] (112G)
234440704 944 - free - (472K)

gpart destroy ada1

ada1 destroyed

gpart create -s gpt ada1

ada1 created

gpart show ada1

=> 40 234441568 ada1 GPT (112G)
40 234441568 - free - (112G)

I then booted the RC1 disk, and as before, it would not find the SSD. I then threw in a Ghost BSD disk, and that found the SSD and installed flawlessly. So the problem is not hardware, but RC1. I’ll wait until things settle down before trying again.
Thank you so much for your patience helping me through the details of this operation. You’ve helped me a lot!


#15

No problem
Knowledge is only useful if it shared
Good luck


#16

Only trough failing, try/error can we learn new things. I had some similar “almost catastrophic” event while playing with ad & da named devices and almost destroyed SSD disk with data instead of USB key that I would use for booting next release. Since then I use “with caution” these these two steps (before using dd). These commands worked flawlessly for me in preparing the boot media since PC-BSD times:

fdisk -BI /dev/da0
newfs_msdos /dev/da0
dd if=TrueOS-Stable-x64-18.06.iso of=/dev/da0 bs=1M

#17

Your first 2 commands are unnecessary when writing an image to a usb stick.
dd does a raw bit for bit copy of iso image to- in case you mention- of=/dev/da0 starting at beginning of da0 thus overwriting anything fdisk and newfs did.

What I do to avoid catastrophe is:
ls /dev
plug in usb stick
ls /dev to see what changed- in my case could be da0-da5- and thus know for sure which device I want to write to.


#18

Yet again, sometimes on my path of testing different Linux/BSD distros, I observed that dd-ing PC-BSD over some xubuntu for example would prompt me with old linux distro. These two commands saved me from that particular problem, and never had any issues since I use them as first steps before writing iso to USB.


#19

Nope, not possible.
I obviously can’t argue with your observation but I can and will take issue with your conclusion based on that observation.

A bootable iso must by definition have a bootloader. That bootloader must have code imbedded in the first sector of the device else the bios won’t see it as a bootable device.
When dd writes the image to the device it overwrites everything in the first sector with the mbr of the new image.
So no way can you get a prompt for a prior image if dd wrote a new iso to that device.

Now lets look at what your commands do.

First, you didn’t use those flags in linux implementations of fdisk because they don’t use those flags.
However, from FreeBSD manpage
‘-B’ Reinitialize the boot code contained in sector 0 of the disk.
Useless unless you already have or are putting freeBSD bootcode in mbr.

‘-I’ Initialize sector 0 slice table for one FreeBSD slice covering the entire disk.
Why?

Neither unix nor linux use fat filesystems natively and it will get overwritten by dd copy of iso image so again useless.

Hope I didn’t offend- it was not my intent.
And by all means if your way works for you go for it.

Good luck