Can you please add a game to repository?


#1

There is an old game called “Puzzle Moppet.” My kid loves to play it. It is in the Mageia repository. If you never
played it, I think there is a demo on YouTube.


New game suggestion
#2

I just did a search on freshports.org, and there is no “puzzle moppet” listed


#3

http://garnetgames.com/puzzlemoppet/

Note that it says the download is free. Development stopped years ago. Lots of fun to play
but only has 23 levels and an expert gamer could probably get there in a couple of days.


#4

grab the linux edition, and try to install and see what happens


#5

Can we add “The Eight Pages” game while we’re at it?.. :wink:


#6

go for it :sweat:

whatever you can get accomplished


#7

They only seem to provide a binary and this is what I get:

[russellh@Prescott] ~/PuzzleMoppetFullVersion/bin> ./PuzzleGame
ELF interpreter /lib/ld-linux.so.2 not found, error 2
Abort

[russellh@Prescott] ~/PuzzleMoppetFullVersion/bin> kldstat | grep linux
7 1 0xffffffff82b11000 3ecc6 linux.ko
8 4 0xffffffff82b50000 7830 linux_common.ko
9 1 0xffffffff82b58000 3a90f linux64.ko
22 1 0xffffffff82c3a000 316c1 linuxkpi.ko

[russellh@Prescott] ~/PuzzleMoppetFullVersion/bin> uname -a
FreeBSD Prescott.highfell.local 12.0-CURRENT FreeBSD 12.0-CURRENT #14 f92c24b(drm-next-4.7): Fri Jan 6 19:28:21 UTC 2017 root@gauntlet:/usr/obj/usr/src/sys/GENERIC amd64


#8

Thank you very much for trying.

I do not yet know what a binary is, but I am going to try to study such
things in my spare time. I just do not have any spare time any more.


#9

I have three kids so I sympathize. I don’t have spare time either, I just forgo this thing people call ‘sleep’… :sleeping:


#10

I talked with one of the contributors over at Mageia Linux and he says the
reason it is in their repository is they use non-free
software. I have a fuzzy video of the game “Puzzle Moppet” on
YouTube. It is super fun, but only has 23 levels and then you
are like craving for more, saying WTF, like one of those old Batman tv
episodes, except there are no more.


#11

Here is a bizarre story for you all.

My computer has been working great for months, but I had bricked it several times tinkering with development versions of Linux distros ( dependency hell, etc. ) and so I installed
TrueOS. I was having fun with TrueOS, but I messed up my install. For a brief 24 hour period, my computer was barely usable. During that brief time, I found my 12 year old daughter in grave danger and had to give CPR to her. Paramedics saved her life. She had never been sick before, so it caught us off guard, and we still do not know what happened. Anyways, I needed to send out a quick email to friends and family to let them know
my daughter was on route to the hospital. I almost broke out my dusty Window 8.0 machine and I did turn it on for the first time in 7 months. But I finally decided to just log into KDE in TrueOS, and send out the email.
About 2 days later, after everything was returning to normal, I reinstalled TrueOS and everything is working
fine now. However, this time, I only have Lumina running. I guess I am saying I wish, I had reinstalled it the day before ( in hindsight ), but I was actually tinkering with it ( breaking it more ) when the wife came in subtly suggestion our daughter was not breathing right. She wasn’t breathing at all.


#12

You’d need to compile it on FreeBSD for it to run natively. You may be able to run the Linux version once the Linux Compat layer is in a better state, but for now your only chance is going to be to compile it natively on FreeBSD.


#13

That appears to be a closed source game for windows/mac. So… No.


#14

Wow, that’s a scary story. If anybody needs me I’ll be watching my children sleep. Until their 18.

:stuck_out_tongue_winking_eye:


#15

Does anybody know of any kids games in the repo that work well? I tried a couple a little while ago and didn’t get very far (don’t remember which ones).


#16

That’s what I figured. I don’t think there are sources provided. Thanks for the confirmation. :unamused:


#17

Puzzle Moppet does have available sources, but reading the compile notes are quite funny. The dev states something along the lines of 'i forgot the patches needed to make it compile. in the readme file. So you’d have to wrestle with it to get it to work. Also you’d need to install cmake to compile it.


#18

lolz. I got caught being lazy (in my defense it was late and I was on my way to bed!). I didn’t see any link on their website so I made an assumption. I see the source on bitbucket. I’ll look at this on the weekend hopefully.

Thanks!
dinsdale


#19

:cry:

Just kidding, I just wanted an excuse to say “The eight pages.” It sounds cool, and I just learned about it, so I wanted an excuse to mention Slenderman “The eight pages.” I haven’t watched “The Bye Bye Man” yet, but hee looks eerily similar to Slenderman, I wonder if the Bye Bye man also has eight pages.

:grin:


#20

Okay, so far so good. I’ve got cmake and clang 3.9 installed. I downloaded the puzzlemoppet source from https://bitbucket.org/Knitter/puzzlemoppet and have started following the readme then looked for the dependencies.

#you may need to sign up?
mkdir -p ~/Git && cd ~/Git
git clone https://bitbucket.org/Knitter/puzzlemoppet.git

OpenAL is in the pkg repository:

sudo pkg install openal

ODE and Irrlicht are tarballs. I downloaded both of them from the websites provided in the readme.

#how did this event work? but it did!
tar xjf irrlicht-1.8.4.zip -C ~/Git/puzzlemoppet/

tar xjf ode-0.13.tar.bz2 -C ~/Git/puzzlemoppet/

I had to make one modification to a file in ODE:

/usr/home/russellh/Git/puzzlemoppet/ode-0.13/ou/src/ou/malloc.cpp

I commented out lines 37-42 accordingly from the compiler error that malloc.h is no longer supported.

./configure
make
sudo make install

Irrlicht needs gmake (did I install that? can’t remember to late at night)
It built fine and then stopped at:

e
c++ -I../../include -Izlib -Ijpeglib -Ilibpng -DIRRLICHT_EXPORTS=1 -MM -MF Irrlicht.d Irrlicht.cpp
In file included from Irrlicht.cpp:30:
./CIrrDeviceLinux.h:21:10: fatal error: 'GL/gl.h' file not found
#include <GL/gl.h>
         ^
1 error generated.                                                                                                      
c++ -I../../include -Izlib -Ijpeglib -Ilibpng -DIRRLICHT_EXPORTS=1 -MM -MF COSOperator.d COSOperator.cpp
In file included from COSOperator.cpp:21:
./CIrrDeviceLinux.h:21:10: fatal error: 'GL/gl.h' file not found
#include <GL/gl.h>
         ^
1 error generated.                                                                                                      
c++ -I../../include -Izlib -Ijpeglib -Ilibpng -DIRRLICHT_EXPORTS=1 -MM -MF CIrrDeviceLinux.d CIrrDeviceLinux.cpp
In file included from CIrrDeviceLinux.cpp:5:
./CIrrDeviceLinux.h:21:10: fatal error: 'GL/gl.h' file not found
#include <GL/gl.h>
         ^
1 error generated.                                                                                                      
c++ -I../../include -Izlib -Ijpeglib -Ilibpng -DIRRLICHT_EXPORTS=1 -MM -MF COpenGLExtensionHandler.d COpenGLExtensionHandler.cpp
In file included from COpenGLExtensionHandler.cpp:9:
./COpenGLExtensionHandler.h:60:11: fatal error: 'GL/gl.h' file not found
        #include <GL/gl.h>
                 ^
1 error generated.                                                                                                      
c++ -I../../include -Izlib -Ijpeglib -Ilibpng -DIRRLICHT_EXPORTS=1 -MM -MF COpenGLSLMaterialRenderer.d COpenGLSLMaterialRenderer.cpp
In file included from COpenGLSLMaterialRenderer.cpp:16:
./COpenGLSLMaterialRenderer.h:25:11: fatal error: 'GL/gl.h' file not found
        #include <GL/gl.h>
                 ^
1 error generated.                                                                                                      
c++ -I../../include -Izlib -Ijpeglib -Ilibpng -DIRRLICHT_EXPORTS=1 -MM -MF COpenGLTexture.d COpenGLTexture.cpp
In file included from COpenGLTexture.cpp:10:
./COpenGLTexture.h:37:12: fatal error: 'GL/gl.h' file not found
                #include <GL/gl.h>
                         ^
1 error generated.                                                                                                      
c++ -I../../include -Izlib -Ijpeglib -Ilibpng -DIRRLICHT_EXPORTS=1 -MM -MF COpenGLShaderMaterialRenderer.d COpenGLShaderMaterialRenderer.cpp
In file included from COpenGLShaderMaterialRenderer.cpp:8:
./COpenGLShaderMaterialRenderer.h:27:11: fatal error: 'GL/gl.h' file not found
        #include <GL/gl.h>
                 ^
1 error generated.                                                                                                      
c++ -I../../include -Izlib -Ijpeglib -Ilibpng -DIRRLICHT_EXPORTS=1 -MM -MF COpenGLParallaxMapRenderer.d COpenGLParallaxMapRenderer.cpp
In file included from COpenGLParallaxMapRenderer.cpp:8:
In file included from ./COpenGLParallaxMapRenderer.h:11:
./COpenGLShaderMaterialRenderer.h:27:11: fatal error: 'GL/gl.h' file not found
        #include <GL/gl.h>
                 ^
1 error generated.                                                                                                      
c++ -I../../include -Izlib -Ijpeglib -Ilibpng -DIRRLICHT_EXPORTS=1 -MM -MF COpenGLNormalMapRenderer.d COpenGLNormalMapRenderer.cpp
In file included from COpenGLNormalMapRenderer.cpp:8:
In file included from ./COpenGLNormalMapRenderer.h:11:
./COpenGLShaderMaterialRenderer.h:27:11: fatal error: 'GL/gl.h' file not found
        #include <GL/gl.h>
                 ^
1 error generated.                                                                                                      
c++ -I../../include -Izlib -Ijpeglib -Ilibpng -DIRRLICHT_EXPORTS=1 -MM -MF COpenGLDriver.d COpenGLDriver.cpp
In file included from COpenGLDriver.cpp:5:
In file included from ./COpenGLDriver.h:25:
./COpenGLExtensionHandler.h:60:11: fatal error: 'GL/gl.h' file not found
        #include <GL/gl.h>
                 ^
1 error generated.                                                                                                      
c++ -Wall -pipe -fno-exceptions -fno-rtti -fstrict-aliasing -g -D_DEBUG -I../../include -Izlib -Ijpeglib -Ilibpng -I/usr/X11R6/include -DIRRLICHT_EXPORTS=1  -c -o COpenGLDriver.o COpenGLDriver.cpp
In file included from COpenGLDriver.cpp:5:
In file included from ./COpenGLDriver.h:25:
./COpenGLExtensionHandler.h:60:11: fatal error: 'GL/gl.h' file not found
        #include <GL/gl.h>
                 ^
1 error generated.                                                                                                      
gmake: *** [<builtin>: COpenGLDriver.o] Error 1

And there it sits. I tried looking for opengl in pkg but did find anything. Any input would be grand! I had to hand modify some of the commands in the post so let me know if it’s not quite correct. or I missed a step. Or I’m full of you know what.

I’m going to bed. zzzzzz :sleeping: