Can You Offer a Boot Solution For Latest TrueOS


#1

I used TrueOS .img to set-up a ‘live’ usb in order to install the latest TrueOS.

I DD’d it to a usb drive and ran it on my Lenova Thinkcentre and it was a success…tried the live usb on a small eeepc and it booted to the point of rejection because the eeePC is only 32bit…at least an indication of its ability to boot.

When I tried it on an Acer Aspire 5315 the ‘live’ usb failed to boot so I was unable to install to the HD on the Acer Laptop? I manipulated the BIOS to select the boot order but it just doesn’t want to boot up.

FreeBSD worked and is installed where I want to put TrueOS.

I’m hoping that someone has the answer for me to get TrueOS installed…without mechanically moving the drive back and forth


#2

trueos, the desktop is dead.

the next gen desktops are;

Project Trident www.Project-Trident.org
or
GhostBSD - www…ghostbsd.org


#3

Whut? …I went to Trueos when I experienced this and other problems with Ghost!

Thanks for the heads-up …I’ll try Trident…never heard of it but should be interesting.

…and are you serious with your dead reference?


#4

Project Trident sez 4gb…


#5

it does fit on a DVD. though most of us use flash drives


#6

Thanks RM will give it a try


#7

My question is still valid…I have downloaded Trident and I have the same problem in that I can’t get the installer to boot on the laptop I want to use it on …

The live USB boots on 2 other PCs …

So, I’m still looking for suggestions


#8

Providing a bit more details would be better.
Maybe disable secure boot for starter.


#9

Thanks Vit,
I have ‘Quick Boot’…has been disabled to no effect. This is an older unit running only linux and now FreeBSD on sda, 1 of 2 drives. FreeBSD presents no problems but Trueos and GhostBSD ‘live’ USBs refuse to boot making it impossible to install to the hard drives…so I continue with FreeBSD!

I can install Trident,True & Ghost to USB drives on another PC but they won’t boot either on my Laptop. I have been able to run older versions of Ghost but they are dated.

I was hoping that I wasn’t alone with this problem and that someone might have an answer.

…to me a ‘live’ USB is a USB with the installer DD’d


#10

“quick boot” is different from the “secure boot”. The latter requires for boot loader to be digitally signed etc., which is not the case with trident/trueos. If there is no such option in your BIOS settings, look for the “legacy” or “mixed” mode and try enable it. Different manufacturers have different settings or may call these settings differently. Actually, I’m not even sure trident/trueos supports non-UEFI mode for USB-images. Also, here in parallel threads, others report they had better luck with dd’ing downloaded iso-image to usb stick. You might wanna try that.
Does the usb stick actually get detected by BIOS and shown in boot menu?


#11

In my case i burned an iso on a usb stick and the install runs fine in legacy mode (non UEFI). If this can help.


#12

I download to my desktop then DD the iso image to a USB ‘stick’ all on the desktop.
I do it this way because of my experience with GhostBSD and Trueos.
I usually test the result first on the desktop to confirm it works…and Trident works as installer on my desktop but not the laptop.

I don’t have legacy or mixed modes to enable/disable and, yes, the stick is detected but when selected just passes off and boots the hard drive.

…and thanks Chris but I don;t have legacy mode.


#13

Try the plop boot manager:

https://www.plop.at/en/bootmanager/download.html

install it for your HDD or SSD, after with it you will be able to install and start the installed system. But before make the install, firstly I can offer you to clean your HDD with a slow format not with wipe.


#14

Which doesn’t guarantee it’ll boot on other machine, as it depends on the bios/UEFI settings of that machine.
Anyways, acer may have this option hidden. To make available, you might need to “set superviser password” in your bios first. Check out the following link


#15

Thanks again for some very interesting info…but I have to point out that my laptop boots USBs regularly without intervention. I can’t remember ever having to do anything to get all sorts of things to boot, Linux,Win10, Haiku and most telling, FreeBSD12.0RELEASE !

This says to me that the problem lies with the software/OS not with my laptop…this may even be a bug.

…and thanks Zoltan but my HD boots everything but Trueos based OSs, such as, Ghost,TrueOS desktop and, now, Trident, so plop is not the answer for me.

I’ll content myself with having a play with Trident & Lumina on my desktop and install FreeBSD with XFCE on the Laptop.

Thanks for all the help:)


#16

Does that mean TrueOS is finished?
I tried Ghost this afternoon and found it to be unstable. TrueOS is much more polished and smooth to use.
Trident?
Better to wait till the final release version I think.


#17

The way I understand it, yes… TrueOS Destktop is dead… TrueOS is now a server O.S. only. Trident is the new desktop O.S.


#18

If you’re not even willing to try, it’s your choice :slight_smile: besides windows obviosly, most linuxes have been supporting secure boot for ages, especially ubuntu and fedora derivatives. FreeBSD is known to be working on that as well. Maybe it’s finally made its way into 12 release. Just remember that Trident is not FreeBSD. I’m not discarding a possibility of a bug in the trident installer/image tho.


#19

@vit…my laptop clearly doesn’t have secure boot so there’s nuthin to try in that area…

if you have any more suggestions I’m always happy to try it out…but i’m pretty sure the problem is soft especially when FreeBSD goes ok

I’m very anxious to get on and see how Trident runs on my desktop so I’m not giving up on anything…the drive is fitted to the optical bay and can be moved to the desktop for the install, then refitted…which I had to do with Ghost…


#20

to be honest. in many ways, Project Trident is ahead of trueos. same developer is doing desktop, and a few more behind the scenes changes