Can’t browse network mounts


Whenever I try to browse the network mounts in any file manager application, I get an error window saying “Invalid UTF-8”. If I manually enter a server address by name I get “Failed to retrieve share list from server:” Only if I manually enter the IP-address of a server I can authenticate and mount volumes. Also mounting network volumes from the CLI using eg. gvfs-mount works.

Got any ideas on what is amiss here?


How are you even browsing for network devices? I’m trying to figure out how to get my ppd file over from my Macbook to TrueOS right now and it looks like I can’t do that over my file server.


You open Thunar (or similar file manager application that can browse networks) and click on the network icon in the left sidebar. Then you double-click on the ‘Windows Network’ icon in the right sidebar.




Invalid UTF-8

I see that error with Thunar and with Files. Re: you might contact the port maintainer.


No mention of UTF-8:


  • GNOME Files is better than Dolphin for some SMB use cases.

Zero-configuration networking (zeroconf)

Re: the second screenshot, man mdnsd presents the manual page for mDNSResponder(8).

Pc-sysconfig et al

I hadn’t tried Dolphin. BTW the same error is also in PCManFM. Leads me to believe that the issue is not with the file managers rather something deeper in the system.


Can you compare with an installation of FreeBSD-CURRENT? In VirtualBox, maybe.


In GhostBSD

… in VirtualBox on KDE on TrueOS Desktop UNSTABLE

On KDE on TrueOS Desktop UNSTABLE

… 201701060022


I solved it! What was needed was Avahi running.

Init the daemons using OpenRC:
sudo rc-update add avahi-daemon default
sudo rc-update add avahi-dnsconfd default

Edit /etc/nsswitch.conf:
hosts: files dns mdns

Reboot, and now the network neighbourhood shows up in the file managers.


Just to confirm. You have this working in Gnome/Dolphin/KDE on TrueOS?


Thank you @goal for this solution. I’m wondering if there is a way to browse samba shares with Lumina-FM ? I had to install Caja and it did not work until I ran those commands.


Trying to mount samba share on Nas4free in local network. I do not need permanent share, just to quick connect to shared folder that is password protected.
I basically followed this guide, but got:

sudo mount_smbfs: can't get server address: syserr = Operation timed out

Google found solution to add ip/hostname.local to /etc/hosts and then mount with:

sudo mount_smbfs -I //USERNAME@WINDOWS_HOSTNAME/share /mnt/pnt

This worked for me.


I use Thunar file manager to connect to my Mac.

Enter afp://x.x.x.x

On Mac Side, activate file sharing and don’t forget to click on the “Option” button and put a check in the AFP box or it won’t work.

A popup appears asking for the mac user name and password and then after that you double click on the mac hd icon and it asks again for the mac password. Then you’re good to go. See your /usr/username.gvfs folder for a local link to the mac