Can’t boot after finish install


I have finished install TrueOS to my external HDD, but i can’t boot it , is there any missing file ? I usually could boot OS on my external hdd
But trueOs cant


Bios or UEFI
Video card?



Bios , iso dvd ,
Intel i5-2xxx , nvidia optimus gt 540,
I saw the partition is there but i can’t boot, i also add swap file during installion on trueOS
I cant boot after finish installing it
Nothing show up the grub to boot true os
I tried to option boot press f12 to booth usba storage but still cant


tried LiveCD , i am on GPT not MBR, and there are just 2 partition for bsd
They are FreeBSD-zhs and FreeBSD-swap
After finish installion, i got text that missing boot loader ,
My partiion is /dev/da3 and da4

This is the pic of the partiion!AsmKoEPFnjbNc840w0Nysu5TBvQ

I tried ti find freebsd-boot
But cant find it by gpart


line 2 says it all

you need to try and disable 2nd video card. dual video card is a pain in FreeBSD.


How todo that? I am on Bios legacy and my nvdia is optimus


somewhere, bios or card setup, one of the video cards needs to be disabled.

Read through the search --> “

this may help you gather information and/or find an answer


I have tried another installion by Usb IMG , and when i boot, it said missing boot loader, do you know why?
I am installing the TrueOS kn my external HDD


are the checksums matching the IMG download? server or desktop IMG?

I’ll assume you are using GRUB, since you have a BIOS computer?

in the BIOS settings, can you point the computer to look at the external drive to boot off of?

Not sure at this point, if none of these work.


I have finished installion but when i boot missing boot loader , this js twice times happened to me when i want to install bsd to my external HDD,
Forst time I was tying install from iso file to bootably by dvd ,
And this is the second was trying install from IMG to my pen drive
When i have finish to install, it said missing boot loader
Then I tried to run gpart show
I saw on my usb pen drive for boot
Has 3 partitions including Freebsd-boot
And when i installing to my external hdd
, it was only 2 parition installed and no freebsd-boot
When i install on dvd iso , this is happened as well

You can take a look of the pic


no idea at the moment, maybe someone else can jump in here


It seems my boot not installed on my external hdd , how can i add/install freebsd-boot to my external hdd? Can i do that ?


Are you using grub? If so, search discourse.

I don’t use grub anymore, so not sure


I am not using grup but it is strange that i cant boot my trueos
I dont know what’s wrong on it
It has been twice times i install and always like that :frowning:


There is a how to boot FreeBSD from zfs by grub2.
This page is wrote in japanese. good luck !