Can I use `xf86-input-libinput` to handle touchpad?


#1

The touchpad of my Thinkpad x230 is very sensitive to any events and behaves very erratically under TrueOS and Linux. When I was using Linux, I used xf86-input-libinput to manage my touchpad. It’s supposed to be a drop in replacement for xf86-input-synaptics. On Antergos linux (which is basically Arch linux), I would install the xf86-input-libinput package and remove xf86-input-synaptics and reboot and my touchpad would work smoothly and predictably. I wanted to do the same on TrueOS, but when I tried to remove xf86-input-synaptics, pkg said that it would also remove xorg-drivers and trueos-desktop!! What do I need to do to use xf86-input-libinput to manage my touchpad on TrueOS?


#2

Ok since I cannot remove xf86-input-synaptics, I tried to get TrueOS to use xf86-input-libinput by creating the following symlink:

$ ls -l /usr/local/etc/X11/xorg.conf.d
total 3
lrwxr-xr-x  1 root  wheel    49B Jul  6 19:11 40-libinput.conf -> /usr/local/share/X11/xorg.conf.d/40-libinput.conf
-rw-r--r--  1 root  wheel   823B May 20 01:23 wacom.conf.sample

It still doesn’t seem to be using libinput.

$ grep "Using input driver" /var/log/Xorg.0.log*
/var/log/Xorg.0.log:[    39.879] (II) Using input driver 'kbd' for 'kbdmux'
/var/log/Xorg.0.log:[    39.884] (II) Using input driver 'mouse' for 'sysmouse'
/var/log/Xorg.0.log.old:[    40.179] (II) Using input driver 'kbd' for 'kbdmux'
/var/log/Xorg.0.log.old:[    40.184] (II) Using input driver 'mouse' for 'sysmouse'

Now I’m confused. Which is this driver mouse that it is using? Shouldn’t that be synaptics by default?