BTX loader read error


I’m not sure if the title is correct, i.e. if it has something to do with the BTX loader. But for now I chose that title because it indicates when during the booting process the problem occurs.

When booting one of my systems I always get an error message:

BTX loader 1.00 BTX version is 1.02
Consoles: internal video/keyboard
BIOS drive A: is disk0
BIOS drive B: is disk1
read 1 from 0 to x7d8a6350, error: 0x40read 1 from 0 to 0x7d8a6350, error 0x40

That is relatively new and, I’m pretty sure, not really good.
Also all existing BEs didn’t properly boot. I was able to install the June 1st 2017 image into a new BE and working with it just fine.

But I still would like to fix this problem.

Is it possible to fix it or is this partition ruined “forever”?

Thanks for helpful hints.

Lost access to TrueOS -none of all BE work either - after update in May
[Finished] TrueOS Q&A with Kris & Ken Moore 6/16/17


Sorry for the delay.

Thanks @q5sys for introducing the question into the Q&A and pasting the result back here and thanks to @kris for addressing the question.

I did some smart check a few days back but the only error the windows smart tool brought up was a interface crc error count of 2. If that was the problem the counter should go up with every boot - at least every boot of TrueOS because the BTX loader (or whatever it is that’s between the BTX loader and the BSD bootloader) still gives me that error. Also, changing the sata cable or switching from jmicron to intel sata plug on the mainboard didn’t change anything. So, that error most probably was a one time thing in/of the past.
The smart tool I installed on TrueOS gave me the same error message as the “native” error message I presented in the opening post. So, no help.

As chkdsk doesn’t “see” the bsd partition I had to “learn” how to do something similar on bsd. I ran zpool scrub but no errors were found. I’m not sure but as far as I understand it, the scrub command only repairs file system errors. The man didn’t say that it would also detect bad sectors and mark them as such.

Anyway, today I ran some ubcd tools. Both, the Samsung hdd test tool as well as another one that was specifically to check the whole disk surface and remap damaged sectors ran through without any errors. So nothing I can see or do right now.

For now, I decided to wait for the next stable update and this time run it normally. Due to the annoying server problems that lead to several “connection reset by peer” errors the last few times I just updated “in place”, i.e. pkg-static, because then the update wouldn’t download all the packages that are current again…

This problem cost me about 6 hours on my other system! Only to let me find out that (most probably) the system had not enough disk space left to update (into a new BE), because the system didn’t update during reboot (several times / tries) without telling me anything. That’s when I decided to go directly for the “static” root on the other system, too.

But maybe by letting the update process install into a new BE the boot entries get fixed / renewed and that annoying error message (that at the moment doesn’t seem to affect me / my system) goes away.

I’ll report back.


Just a heads up - beware of BTX errors caused by USB card reader adapters. I’m not sure its applicable here but I have had BTX / boot errors that went away when I unplugged my cases card reader from the mobo.


Thanks for the input.

I just checked. I don’t have any usb card reader but there is some usb stuff connected to that pc. Unplugging all of it except for the keyboard doesn’t change anything.

Also, I’m pretty sure that this is relatively new, i.e. hasn’t always been there (that error message) but the pc’s setup hasn’t been changed since years because it’s a backup pc I rarely use at all - just to test things, 2-3 times a year. Well, up until now that I upgraded the old pc-bsd and wanted to keep TrueOS fairly up to date.

But, as I said, after the next stable update, I’ll know. I’m just thinking: If the grub setup writes it’s stuff into my MBR etc. with every update (= new BE), maybe the freebsd bootloader does something similar and by this repairs whatever is wrong (which in my case can’t be that bad as the system starts and runs without me noticing any differences).


As I noticed (though I only cought it briefly out of the corner of my eye) an error message (most probably also this read error message) on my other TrueOS system while a thumb drive was inserted during boot-up which wasn’t there during the next boot-up when the thumb drive was removed, I guess, on the other system it’s most probably also some usb device.

And the only usb device that was present the last time I run that other system was the kvm switch. So, I guess, whatever part of the freebsd boot stuff it is (freebsd bootloader, btx bootloader, …?) it has some problems if it can’t handle plugged-in usb devices without spewing out “false” error messages.


Well, “normal” update (i.e. with new BE creation - and presumably re-“installing” freebsd bootloader etc.) didn’t change anything.

So, it’s either a “real” error or just some hypersensitivity to probably usb stuff plugged-in at boot-time (either recently “acquired” or “always” been there).

I’ll keep an eye on that.

At least the update went fine - no “reset by peer” disruptions this time - apparently I was late enough after the last update server syncing and early enough before the next… :slight_smile: