Boot problem on Lenovo


#21

Sounds as if you used the usb image to burn a dvd. I wouldn’t expect that to work either, if there are explicitly two seperate images for dvd and usb. You might wanna try the dvd image to burn a dvd.

Otherwise you just use the term “burned” a bit loosely. :slight_smile:


#22

Thanks for the replies, guys!

@to-user, I did use the term loosely… my apologies. I actually did use the “dd” command place the image (.img) to the flash drive.

And @lotech, I’m also equally frustrated… this takes me back years when I had to ensure that every major computer component was compatible - when playing with early Linux distros. Nowadays, almost every one installs without a glitch.

To answer your questions, @jgroenveld, my UEFI BIOS Version is HEET35WW (1.16). Lenovo states that they’re on 1.33 at the moment. I thought about upgrading it, before posting, but I was hoping to find resolution without having to.

Also, I did try your suggestion and booted FreeBSD 12.0 image (and installed it)… SUCCESSFULLY! I installed it more as a proof of concept. I really want to try TrueOS, however. I don’t know enough to understand why the FreeBSD bootloader installation program works, but not the one for TrueOS. Are there any tweaks that can be done at the bootloader command line?

While I wait for further suggestions, I’ll try one last time to load the TrueOS Server version on two, recently “burned” :slight_smile: USB drives.

Thanks to all for your help so far!


#23
If the latest FreeBSD 12 snapshot works, then I think likely the upcoming TrueOS-Trident will work for you.

Testing TrueOS-Desktop-18.03-x64-USB.img against your laptop once you apply Lenovo's firmware patch would be interesting.
John
groenveld@acm.org

#24

Hey, @jgroenveld. Well… after major hassle I finally got the BIOS updated to the shiny, latest version. I tried reinstalling TrueOS (Server version) - thinking that if it had trouble with it, then the Desktop version had no chance either. Unfortunately, it was yet again a failure:

https://drive.google.com/file/d/1yxTMzJzPYi9E0Y3VWSYsihbYuRZeDiP_/view?usp=sharing

As one last comparison, I downloaded and installed GhostBSD without a single issue, just like FreeBSD. I really don’t know why TrueOS has given me such trouble. I realize that my cheap, old Lenovo laptop (used for testing purposes) isn’t great… but I don’t understand why TrueOS won’t boot (while FreeBSD and GhostBSD do).

Sadly, I think I’ll stop trying for now. After hours of unsuccessful attempts, I may just wait to try TrueOS-Trident, as you suggested. :frowning:

Thanks for your suggestions and patience.


#25

2 reasons.

1: trueos is using FreeBSD 12.* CURRENT

2: ghostBSD is using FreeBSD 11.*

something in the 12.* codebase must not your hardware


#26

That’s good to know, @RodMyers. I did install FreeBSD 11.2 RELEASE… and now know the code base for GhostBSD. Thanks. Do you think that going from 11 to 12, they stopped supporting some hardware component this laptop has? I would’ve thought they’d keep existing support and add to it in version 12. This cheesy laptop is about 5 years old… old, yes… not truly ancient, though. I’m just thinking that TrueOS-Trident may not help me, if this is the case.


#27

Be aware, ghostBSD is working toward moving to trueos sometime in the near future.

Stop supporting hardware. I doubt it , unless it’s really old, ie ancient.

If you are really adventurous, you could try and install FreeBSD 12.0 on the laptop


#28

You know, @RodMyers? I’ll give it one last shot. At least I know that FreeBSD and GhostBSD work, so I can use one of those to learn more about BSD. I’ll let you know how it goes. I had always been intrigued by FreeBSD but never transitioned to it from Linux. I learned about TrueOS after installing FreeNAS (BSD-powered) - not that it matters at all. :slight_smile: Thanks for advice.


#29

remember, ghostBSD is freebsd 11.*

trueos is freebsd 12.*

different bot code in 12.*


#30

This is bizarre, @RodMyers… Just ‘burnt’ FreeBSD-12.0-CURRENT-amd64-20180628-r335760-memstick.img onto a USB drive. It’s the latest available right now. Well… it passes through the bootloader phase without a glitch! I didn’t go through the installation, just through the Live CD option.

I’m downloading the latest, unstable TrueOS Desktop and will ‘burn’ it in the exact same way, and try again. I’ll then do the same with the Server version. I swear that I’ve done this multiple times already, but I’m stubborn and intrigued.


#31

small steps are a very good thing


#32

Ok, @RodMyers… I’m officially stumped. NEITHER of the following got beyond the “BTX Halted”, after which the computer simply froze:

TrueOS-Desktop-2018-03-25-UNSTABLE-x64-USB.img
TrueOS-Server-2018-03-25-UNSTABLE-x64-USB.img

So FreeBSD 11.2 and 12.0, and GhostBSD 11.1 all pass through the bootloader phase… but not TrueOS. A sad day for me. :frowning:

For my last attempt, the Server version, I even used the same USB drive, same MSDOS partition table (formatted as FAT32), and same computer and software to burn it onto the USB drive as I used for the FreeBSD 12.0 successful boot.

I think I’ll just wait a little longer (maybe until Trident releases, as @jgroenveld suggested). Based on what I’ve seen, TrueOS seems to be doing something unique, which in my case totally prevents the install.

Thanks for your suggestions and your time.


#33

no idea why it failed.

most of are very much waiting for the debut of Project Trident


#34

Any idea of the time frame for its release? Just to set a reminder for myself to check…


#35

www.project-trident.org scroll down to the bottom and look for the build button


#36

Nice, Ill take a look. Thanks, again. This was my very first post and found it a pleasant experience. :slight_smile:


#37

There are drawbacks of tracking CURRENT. CURRENT is a development branch. Things might stop working and get fixed from time to time there. Vanilla FBSD you tried is ~4 mo newer than TOS installer.

On the other hand, TOS rebuilds packages with different settings and uses its own installer afaik. So, you never know what causes the problem, but chances are high for newer TOS build to work for you if FBSD-CURRENT does.