Boot problem on Lenovo


#1

Hi there,

I am new here, I came from Debian and interested to try the TrueOS, I download the USB image to install, but unfortunately the install didn’t even boot up properly on various ThinkCenter and ThinkPad, it halt at the “booting…”, tried many times and different download the same problem, any suggestion ?


#2

not much info as to what you are experiencing,


#3

Look in your BIOS and make sure secure boot ( or anything similarly named) is turned off.


#4

It already off, or I’ll have problem with Debian too.
I tried to install on different computers, some halt right after the first boot up screen, some halt in the middle of installation, the best I can get to is just before X started, it said ‘no screen found’, that reminds me long time ago I test Linux, I need to tweak the X conf in order to make it work. This time I tried safe mode, use VESA driver, also enable text install mode but none work, it still struggle to get the GUI I don’t know why. I tested FreeBSD before and got the same problem, but at least it allowed me to install in text mode, but this one not possible.


#5

Are you trying to dual or triple boot?


#6

It is the only OS on the computer


#7

Try server image. It’s installer is said to be terminal based. If saccessful, you can install Lumina from the desktop meta package after. Sorry, never tried it myself.

Another option is to wait until new release comes out. You might have better luck with it. It should be out soon.


#8

Maybe I give the unstable a try then, tnx !


#9

I tried the server version to install in text mode and it completed, but I’ve problem make the networking works, then I install the desktop on a Dell and it worked without problem, the only issue is the display as always. The system first boot up with VESA display, and suggested to use Intel instead, I tried but the testing halt, I’ve to force reboot and select VESA as default and it worked. It seems to me TrueOS still has a long way to go before it can coexist with windows, mainly due to the display driver support, and the installer needs some polishing.


#10

first off, you installed the server version. which has NO video stuff installed, so VESA is the only option.

second, the BSD community strives NOT to be like windos.

“IF” you wanted a Desktop, then the server version was the INCORRECT version to install


#11

I suggested to try server as a workaround to the original problem, which is the desktop GUI

Once installed, updating the system to the latest version might help solve the problem or at the very least let you tweak system configs easily.

Surely, there should be a way to get all the desktop stuff on the server. Are you suggesting there is no way to install drm-next-kmod (or whatever driver that is) and then configure X on server?


#12

I also think forum member vit’s approach is most promising.

  1. pkg install <intel-graphics>
  2. startx
  3. Check /var/log/Xorg.0.log

Edit: Probably:
$ pkg search intel | grep video
xf86-video-intel-2.99.917.20180111 Driver for Intel integrated graphics chipsets

Edit:
Package examples from:
$ about | grep ^T
TrueOS package set ………………… UNSTABLE
TrueOS version …………………………… TrueOS-Desktop-201803131015


#13
IIRC from a server install with working networking:

# pkg install trueos-desktop

John
groenveld@acm.org

#14

Thank guys, I tried with no less than 3 ThinkCenter/Pad and 2 Dell of different ages with Intel display, all Lenovo failed to get to the GUI only a Dell worked out of the box, it seems Lenovo is particular trouble with Xorg, and now I got a basic setup running with GUI I can do some digging. I remember long time ago I started with Linux I also have this problem, but now none of the distro give me this trouble, so I said TrueOS need some polishing to make it more easy to deal with, like Linux spent long time to get a place in the desktop that microsoft started to worry. I do dualboot Linux with windows, but due to the secure boot problem, I select boot in the BIOS instead, this worked great so far, I believe I can do it with TrueOS as well.


#15

Hi @lotech.

I ran into considerable trouble trying to install TrueOS (Stable and Unstable) on my Lenovo Edge E431 (ThinkPad), then found this post! I’m preparing to install the Server (Unstable) version and plan to install trueos-desktop. What’s unclear is if that is all that is required to get the GUI or if I still need to do the Intel graphics chipset drivers. Sorry to resurrect this conversation, but it’s my last hope, as I don’t want to give up on TrueOS… Thanks!


#16
The trueos-desktop package will bring in the X11 drivers as well as Intel DRM:
<URL:https://github.com/trueos/trueos-core/blob/b814979c207f4e5e538f877f9a86d56819fadcf3/port-files/trueos-desktop/Makefile>

John
groenveld@acm.org

#17

Thanks for the quick response, @jgroenveld.

Unfortunately, I just burned TrueOS-Server-2018-03-25-UNSTABLE-x64-USB.img (after confirming a good checksum) and I am STILL unable to get out of the rebooting cycle. Same problem as before: the TrueOS bootloader starts up, begins loading files (zfs.ko, geom_eli.ko, tmpfs.ko, aesni.ko)… then says “Booting…” - THEN the laptop does a reboot. I tried all alternate settings too, but with no luck (Safe mode, VESA, Text install, etc.).

Tried changing BIOS to UEFI boot, and it’s even worse.

Is there another way? It sounds like I’m doing what @lotech and others suggested. :frowning:


#18
Next I would try booting a more recent FreeBSD 12.0 image.
<URL:https://download.freebsd.org/ftp/snapshots/ISO-IMAGES/12.0/>
John
groenveld@acm.org

#19
What's your BIOS version?
John
groenveld@acm.org

#20

I don’t know much sorry can’t answer that question, and I don’t know why even the basic VESA/VGA didn’t work out of the box. I remember my first ever successful boot with FreeBSD on the same notebook was couple years back with a KDE Live image but I forgot the source, TrueOS is the only one left for us now.