Boot fails mounting ZFS after a clean install


#1

I downloaded this ISO and booted it under VirtualBox, set up per the handbook.


http://download.trueos.org/master/amd64/TrueOS-Desktop-2017-02-09-x64-DVD.iso.torrent

The install was to a new disk using the default partitioning and Grub. There were no errors shown.

On reboot, the following appears and the system goes to a mountroot > prompt.

Trying to mount root from zfs:tank1/ROOT/initial [ ]…

Mounting from zfs:tank/ROOT/initial failed with error 2:unknown file system

Again, this is a clean install to a virgin disk. Fails the same using BSD loader.

Any help would be appreciated.


#2

I use within virtualbox: TrueOS-Desktop-2017-02-09-x64-DVD.iso
from: http://download.trueos.org/master/amd64/


#3

the only thing I can think of, drop grub and use BSD bootloader


#4

Sorry, but I’m on the same situation… I have installed BSD bootloader first and even it could not boot; I reinstalled TrueOS, this second time with grub, the system booted, but it fails as drummerdp says. What happens? I’m willing to install and use TrueOS!!!
Thank you in adavance!


#5

Is your pool really named “tank1”? On a clean disk the pool should get named “tank” by the installer. The suffix indicates there was an (old) pool present, which gets imported automatically at boot, sometimes resulting in failed or garbled pool/dataset creation by the installer. Normally the installation should abort with an error, but during my testing with automated installations i’ve seen the strangest things happen on unclean disks…
Although the installer on the latest images is pretty good at detecting present pools and asks if you want to install into a new BE.

To install onto a clean disk do the following:
At the very beginning of the installer, drop to a console (utilities -> terminal) and check for any pools present on the disk which are most likely already imported.
“zpool list” may give you tank and tank1 on this system/VM. export and destroy both pools, delete all partitions and destroy the geom-device.
Return to the installer (exit) and proceed with this clean disk.

If you don’t have any urgent need for using grub, then don’t. The BSD bootloader is much more reliable and less fragile.


#6

I’ve tried at least 10 times to install this using Grub with different partition options

. I need Grub for multiboot.

Whether I install to a clean disk or one where a previous attempt has been made. I always get the same “unknown file system” error. It just doesn’t work!!

Trying the same thing with the BSD loader, the boot proceeds a bit further, but then hangs with a login: prompt.

Was this install process even tested?

I’m sorry, but this is very frustrating. I’m seeing a number of other people with the same problems.

Help would be greatly appreciated.


#7

If you get a login prompt, the system has fully booted :wink:
If you installed TrueOS Desktop there might be a problem with the video driver (IIRC there were some issues with Virtualbox), but as there are no error messages about graphics in the snippet you posted i’d say the system booted up correctly.

GRUB falls apart on every change to the disks or their layout. There’s no reason to support multiboot within a VM, so just avoid GRUB like the plague it is and go with the much more reliable BSD loader.


#8

Hello!

I got same error message as on your first picture when I tried to install PCBSD 10,3 for an old hardware, and the installer couldn’t boot because the memory hole (15-16MB) I used the EasyBCD boot loader and the installer ISO was on the target HDD’s other volume.

When I see your second picture, for me similar when I made the installer with some bootable media bilder application like: Rufus, Power Iso, Rosa Imige writer, Universal USB Installer,Lili, Win32 Disk Imiger etc.
Are you checked the checksums of the downloaded ISO?
How you made the installer? I can offer the DD command usage, the other applications are sometimes goods sometimes wrongs!
If you got the login prompt (second picture) try to login (name,pass) and after try the startx command and after check the log file in the /etc/X11/ map
But first I think check your installers (checksums) make again the installers with “DD” command (!) and made a slow format on the target volume and install the system again :slight_smile: