Black screen after installing U5, old Intel graphic


#21

Where do I read dmesg?
Is there a way to slow down the running terminals at the beginning so I can get a better look at things?


#22

open a terminal and type

sudo dmesg | less


#23

I just remade trident u5 on a brand new usb stick and reinstalled my computer again, but I still get the same result. Black screen. xorg.conf is still missing in /etc.

so I executed this command in tty, but tty says read-only file system.

I read the dmesg, and it seems to talk about stuff from the most recent boot, which is the single user mode I just ran.
I can’t see the dmesg from regular boot where the display blacks out.

Is there a way to run tty during normal boot like linux does with ctrl alt f1?


#24

Not sure at what point you are getting the black screen but ctrl-alt-f1 shout take you to the first terminal where you should be able to see some of the messages produced during boot. ctrl-alt-f9 is the terminal where the GUI is once it’s up and running. At least that is how it is on my machine.

@RodMyers I thought the system used the auto generated xorg.conf in /usr/local/etc/X11 and /etc/X11/Xorg.conf is used for when you need to manually configure X?

From my /var/log/Xorg.0.log file:
[ 42.999] (==) Using config file: “/usr/local/etc/X11/xorg.conf”
[ 42.999] (==) Using config directory: “/usr/local/etc/X11/xorg.conf.d”


#26

try possibly:

# mount -o update /
or
# mount -o -u /


#27

When I run these commands on tty
mount -o update
or
mount -o -u

I get the following message
trident/ROOT/initial on / (zfs, local, noatime, read-only, nfsv4acls)
devfs on /dev (devfs, local, multilabel)

then I try to run the copy command and I still get read-only file system.

I think the reason this command doesn’t work might be because Trident is trying to use the current video driver to display the terminal.


#29

I found out that the reason everything is read-only is because of zfs file system.
I managed to mount the file system with this command

zfs set readonly=off trident/ROOT
zfs mount -a

Then I did the copy command

cp /usr/local/etc/X11/xorg.fallback.conf /etc/X11/xorg.conf

then I am able to boot into the desktop with low resolution.

But Vesa driver can’t wake up my display from suspension properly, my screen will only show random colors. It’s useless on a laptop if it can’t do suspension.

I downloaded the 2.99 intel xf86 driver from appcafe and then edited xorg to use intel driver, but I still only get black screen. How come intel drivers worked fine in the last TrueOS but not this one?

Do you guys know where I can report this problem to the trident developers so they can look into this? Thanks.


#30

It might help if you could post the content of your

/etc/X11/xorg.conf
and
/etc/rc.conf

files.

Did you try setting the driver in /etc/X11/xorg.conf to “modesetting” or “intel”, respectively?
I guess you tried “intel”, but it’s not clear what you did when you “edited xorg to use intel driver”.
you might need to edit /etc/rc.conf to load the driver you want/need during boot.


#31

The driver section of my xorg.conf looks like this
Section “Device”
Identifier “Card0”
Driver “vesa”
EndSection

I tried changing the driver part to “intel” after installing xf86 intel driver, didn’t work.
I will try modesetting tonight.

My rc.conf only has configurations on ntp and ethernet.


#32

My rc.conf has this. Maybe it helps:

 kld_list="/boot/modules/i915kms.ko"

I think this post is its reference:

Maybe you need this for older intel drivers:


#33

I’m not sure if my setting help because I have different intel graphics, but I have - similar to what @Sergio suggested - the following line in my rc.conf

kldload_i915=""

But seeing @Sergio’s line I’m not sure if mine makes even sense. I just took it from my TrueOS /etc/rc.conf.
But other than with my TrueOS BE my Trident BE would not boot “into x server” (= GUI) if in /etc/X11/xorg.conf the driver is set to “intel”. It only works with “modesetting”. And that might make the mentioned line in rc.conf useless because the loaded driver isn’t used by xorg - I’m not sure.


#34

Nice info and find! I’ll have to try that myself, too!

[Update]
I edited my /etc/rc.conf of my TrueOS and Trident BE, respectively by replacing the line mentioned in my post just above this one with @Sergio’s line

kld_list="/boot/modules/i915kms.ko"

Now I get the small characters during the boot screen as soon as the module is loaded. That mean, the line I had before does not work… :slight_smile:

It didn’t change the “allowed lines” in /etc/X11/xorg.conf in my Trident BE, meaning that I can’t use the same xorg.conf as in my TrueOS BE.
So, no “intel” as driver, no two devices, monitors, screens. Therefore I (still) have to commend out those and some other lines for my Trident BE compared to my TrueOS BE.
Also, I guess my previous line in rc.conf should have read

kldload_i915=“YES”

to have any effect. I guess, I have to check this theory some day.
[/Udpate]


#35

I tried something similar to this, before I tried the thing about installing the xf86 intel driver, and I got black screen.

This used to work for me in TrueOS 18.03, but it just doesn’t seem to work with Trident, and I don’t know what’s changed.

It seems there’s a lot of manual work required to get trident working. Is this only because my device is too old? I have no problem running other operating systems on it most of the time.


#36

Just finished trying what Sergio suggested

“modesetting” in xorg.conf
no changes in rc.conf
gives me black screen

“intel” in xorg.conf
adding kld_list="/boot/modules/i915kms.ko" in rc.conf
also gives me black screen


#37

I’ve just got this message on updating. Maybe it helps somehow…

Message from drm-current-kmod-4.16.g20190213:
The experimental drm-current-kmod port can be enabled for amdgpu (for AMD
GPUs starting with the HD7000 series / Tahiti) or i915kms (for Intel
APUs starting with HD3000 / Sandy Bridge) through kld_list in
/etc/rc.conf. radeonkms for older AMD GPUs can be loaded and there are
some positive reports if EFI boot is NOT enabled (similar to amdgpu).
For amdgpu: kld_list="amdgpu"
For Intel: kld_list="/boot/modules/i915kms.ko"
For radeonkms: kld_list="/boot/modules/radeonkms.ko"
Please ensure that all users requiring graphics are members of the
"video" group.
Older generations are supported by the legacy kms modules (radeonkms /
i915kms) in base or by installing graphics/drm-legacy-kmod.

#38

bios or efi? if efi, have you updated to latest version?


#39

My machine uses bios. It’s dated at a time when efi hasn’t existed yet. I tried this before updating to latest version. Will try this again after updating.

It just sucks that I can’t use text editors in single user so if I black screen, I can only do rm and then touch rc.conf in single user mode, and then reboot into desktop, then apply more edits, then black screen again, then single user mode. It takes me a long time just to experiment when I can’t edit rc.conf while in single user mode.

Do I need to uninstall xf86 from the appcafe for this to work?


#40

fall back video driver for intel

bios = vesa
efi = scfb

in my BIOS /etc/rc.conf

kldload_i915=""
kld_list=""

part of my /etc/X11/xorg.conf

Section “Screen”
Identifier “Screen0”
Device “Card0”
Monitor “Monitor0”
EndSection

Section “Device”
Identifier “Card0”
Driver “intel”
BusID “0:2:0”
EndSection


#41

Just did a system update, so I should be on U6 now right?

Still getting black screen.

then I changed my configurations to be like yours

still got black screen…
I wonder if I should just wipe and blank install again, or if I should just wait for a year and then come back and try this.


#42

Ok, let’s say we ignore the intel driver issue for now, is there a way to make vesa driver restore my display after waking up? as long as the machine can suspend and wake up properly, I can put this to work now.