BITCH about Trident-Beta HERE


#41

:crazy_face::thinking::open_mouth::rofl::speak_no_evil::rofl::rofl::rofl:


#42

Ah, its not a biggie - there are computer users, and there are computer users.

99% of the content on the internet talking about computer hardware assumes that processors are only ever used to run boring shoot-em-up windows games at 4K. For some reason, the masses have convinced themselves that bulldozer/excavator/piledriver CPU architecture was “rubbish”, and not even up for playing minesweeper, let alone running as a multicore BSD workstation.

Ive not had that problem myself. I also like the engineering on the last round of motherboards for the AM3+ … decent robust components, and the ability to run ECC DDR3, still plentiful, and can be had for cheap.

In fact, when I read any computer related articles on the net these days - most of the time, I get the feeling that Im living in some weird alternate universe … the kind of place where people dont even think about Unix. Imagine that !


#43

I installed Beta2 in VBox on Sabayon Linux.

Davide


#44

Yesterday afternoon I installed the Trident Beta 2 for my two Acer notebook (Trawel Mate 12 years old-this is not perfect yet and Aspire E17 1,5 years old).
I would like to help and above I collected my first experiences:

  • every start (install or already installed system start) before the BSD boot menu is an message: “Purpose not found”

  • only at the system install after the BSD boot menu is two error message:
    "ERROR: apm failed to start "
    "/libexec/rc/sh/open rc-run.sh: hw.machine_arch:not found

  • at system install I couldn’t choose keyboard layout, but I can do it later when the install is ready

  • at system install when I have to choose the place for the new system “Select Installation locaion” the field is empty (on both machine):

    https://imgur.com/a/CR7fZHu

    therefore I can’t move further for the step three only after a trick. If I click on the “Go to Terminal” option than after few seconds the same screen will come back (not the terminal) with the “place(s)”:

    https://imgur.com/a/6Fno9UU

    and I can continue the install with the third step.

  • after the system install and before the first reboot the machines are freeze, therefore must to switch off with the power button and restart manually

  • every system start and shutdown is an message:
    “start-stop daemon error:no matching process found”

  • the automount services does not work (I chosen the drivers at the install procedure FAT,WinNTFS and started the automount services in the Services Manager)but the other partitions and the connected USB devices are invisible

  • at the install I choosed Intel video driver or/and NVIDIA driver but the system using everytime the vesa driver (so far I have not time to try to change for the others, this was yesterdaynight :slight_smile: )

  • I couldn’t wake up the suspended system normaly, only switch off with the power button and restart manually

  • I couldn’t stop the automatic wallpaper changer and the other wallpaper’s field is empty

  • the .log files of the dmesg are missing ( /var/log/ )

  • in the Insight File Manager if I renaming a file that will be missing and the renamed file will be visible again only after the restart of the Insight

  • I’m missing the “Root login” option and the driver changer option (bottom-right) from the login screen ( but I think these will come back later :slight_smile: )

Sorry because the automount problem I can’t copy here the .log files. I hope that I could help!
For first sight the system is amazing!!! Congratulations!!! :+1:
Thank’s for the devs!!! Nice work!!! :+1:

Sorry,because my bad english!!! :slight_smile:


#45

I can confirm. I can see the option on both of my systems but can’t select it on one of my systems.

  • On my Intel T7200 Core 2 Duo system with onboard Intel i945 “install into new BE” is selectable.
  • On my Intel i3 Sandy Bridge system with onboard Intel HD3000 “install into new BE” is right there but greyed out and not selectable.

Graphics seem to work fine on both though I didn’t install on the i3 system.

Unfortunately I wasn’t able to change the (keyboard) language. Selecting the desired language didn’t change the keyboard type / keys.


#46

there are 2 buttons next to the BE option


#47

I tried TrueOS 18.03 and ti worked fine on my laptop and that is an achievement. My laptop has defeated all Linux distribution and BSD (graphical). All failed to install or boot.

My laptop is ASUS ROG Strix GL753VD.

TrueOS 18.03 installed just fine, great.

Tried Trident Beta2, installed fine (except keyboard. I could nto configure anything so i used the default. Also, no drives were visible to install. I told it to switch terminal which it failed but when it came back all drives were visible). The graphical installer took 20 minutes to start.

After successful installation it failed to boot into desktop afterwards (i waited for half an hour). they must have changed something from TrueOS.


#48
Looks like ASUStek is still supporting your model laptop. 
You might try upgrading the firmware.
Good luck,
John
groenveld@acm.org

#49

So I thought I’d give the beta 2 iso a spin and tell you guys how it went.

The installer worked almost flawlessly. The only real problem I had was with the time zone setting in the first step, which asked for my local time but then applied the timezone shift to it, which means it was no longer my local time. Another less important thing I wanted to mention was that in the step where you select which disk you want to install to, you should probably have a clearer indication of which drive is selected - right now it’s just highlighted in the list and that’s it. Adding a checkbox or a message that tells you which drive is currently selected would be good UX design.
Everything else about the installer was pretty much perfect. I looked at the keyboard layouts, locales, etc and everything was working.

Installation went fine and the system booted as expected. Internet connection was working, graphical UI was working, audio was working (except on falkon and firefox - couldn’t hear any audio from youtube or other sites). Performance was pretty bad, it felt like it was using software rendering, I didn’t look into it but that is likely considering that my GPU (radeon r7 360) was unsupported the last time I ran trueos. I had the same problem with AppCafe as other users on this thread, where it only had the “local” repository available. Updating from the terminal resulted in the same large update (freebsd 12, apparently?) that RJules3 got.

Also, lumina needs a lot of work, but you already knew that.


#50

it makes no difference mate.

Scores:

Laptop

Kills 11 graphical distro Death 1 (Almost 99% slaughtered by TrueOS) .


#51
I would play with firmware options before sending the laptop to the scrapheap.
Try toggling the legacy BIOS vs UEFI boot option (assuming there is one).
Along with any options that are labeled "optimal".

Also, I would try the very latest 12.0 alpha in case Trident is lagging or introduced
a regression.
<URL:https://download.freebsd.org/ftp/snapshots/amd64/>
John
groenveld@acm.org

#52

I have always liked the BSD concept but never had the patients to continue. I am pretty much a Manjaro, and Xubuntu user. I have tried True os in the past and always had difficulty with ports especially wine and steam. On my laptop which uses open source drivers ZaReason Linux Laptop it cannot detect wireless and had difficulty with the laptops monitor driver. Anyway it sounds like the project is moving ahead maybe I will try again first in virtual box.


#53

i suggest before throwing comments like these, you carefully read the posts and most crucially understand it, otherwise don’t bother if you have nothing to say or contribute.


#54

Just installed Trident BETA3 into a boot environment:

[rudy@trident-1126 ~]% about
zsh: command not found: about
[rudy@trident-1126 ~]% uname -a
FreeBSD trident-1126 12.0-CURRENT FreeBSD 12.0-CURRENT #0: Mon Sep 24 21:00:29 UTC 2018     root@poseidon:/usr/obj/usr/src_tmp/amd64.amd64/sys/GENERIC  amd64
[rudy@trident-1126 ~]% beadm list
BE                              Active Mountpoint  Space Created
initial                         -      -            2.5G 2018-05-01 15:06
12.0-CURRENT-up-20180501_155633 -      -            7.5G 2018-05-01 15:54
CustomBE-201809091457           -      -            1.0M 2018-09-09 14:57
12.0-CURRENT-201809091507       -      -            6.1G 2018-09-09 17:07
12.0-CURRENT-up-20180910_062826 -      -           13.7G 2018-09-10 06:23
12.0-CURRENT-201809251303       NR     /            5.8G 2018-09-25 15:03

I am writing this post on Trident BETA3.
Installing BETA3 was boring in the best sense. Nothing unexpected happened and using a USB 3.0 thumb drive made it fast.
Using Falkon my experience on TrueOS 18.03 STABLE (Lumina) was bad since the tabs always got frozen but on Trident BETA2 (Lumina) this issue was gone. My browser start up is opening the last session but on Trident BETA2 it opens with one session from the past but not the last one and it is always the same. On TrueOS this was working fine, now on Trident BETA3 (Lumina) unfortunately it is still opening this same old session.


#55

Just Keeping track of these.


#56


Hey man, I wanted to know how is this fork differnet to TrueOS I wanted to know the differneces?


#57

Think of TrueOS as being more server oriented, so the default install doesn’t do a desktop environment by default. Trident is by default “TrueOS plus a Lumina Desktop environment by the default install” so it’s more user-desktop oriented. Trident is not a “fork” of TrueOS, it’s TrueOS plus other stuff by default.


#58

Oh I see. I have some suggestions for you in terms of UI, are you interested?


#59

I’m a user of the project, not one of the team. I just happen to have been using FreeBSD as my home desktop for a long time (conservatively 20 yrs or better).
Feel free to list your suggestions, I’m not one to take any action on them, but others reading may be interested.


#60

Cool thanks mate.

I wanted to suggest using XFCE, OpenBox and polybar, something that ArchLabs uses. It looks very cool and interesting and I approx 240 MB of RAM is consumed when it starts up. This OS does not feel very stable though (in my opinion buggier than Windows 7) but I was hoping if ArchLabs’s desktop environment and its aesthetics and its UI can be implemented into Trident OS.

All though one suggestion I may want to add is to make the taskbar at the bottom of the screen (you can actually do that via polybar settings).

PNG ArchLabs ![PNG|690x194]Spacemoon