BITCH about Trident-Beta HERE


#1

Hello everyone, I wanted to start this thread to bitch, and, whine, and rant, and sometimes even rave about the BETA version of Trident. What our experiences have been with it so far, what we are having trouble with, what we find frustrating etc…

I hope the developers don’t take offense to this thread as it is intended in a good spirit.

IF YOU FIND SOMETHING WRONG WITH THE BETA VERSION OF TRIDENT PLEASE DO NOT OPEN A NEW THREAD JUST POST IT HERE
This will allow me/anyone to have a single source to refer to before opening a bug report on GitHub as to make sure I’m not duplicating them.


Missing boot loader
#2

I know that the devs are already aware of this problem, but I will mention it anyway.

The BETA-01 of trident works perfectly on VirtualBox if you accept all the defaults. If you choose Encryption, or a different shell other than the default. It will fail (at least in Virtual Box)


#3

BETA-02 on the way…


#4

“It won’t install on my Vax PDP11/45”


#5

I’m downloading BETA-02 right now.


#6

There’s a new build running right now. I think I’ll wait a little bit longer. :slight_smile:


#7

If you are sitting there scratching your head over this, “you’re not old enough to understand” :speak_no_evil:


#8

I’m old enough to understand that I’m yet not old enough to understand. :thinking:


#9

:rofl::joy::crazy_face::crazy_face::crazy_face:


#10

Just want to keep track of these. I think this post refers to BETA-02


#11

The “crashes the system when usb is inserted…”
That is crashing Windows? :thinking: :rofl: :speak_no_evil: (sorry, couldn’t resist)
Do you have any automatic actions set on Windows when USB devices are installed?

I can believe that whatever formatting is on the USB media causes problems with Windows. If it’s not FAT or NTFS and partitioned correctly, Windows doesn’t know what to do with it.


#12

Yeah, I don’t see how inserting a USB and having Windows crash is somehow Trident’s fault.


#13

I have issues with installer failing when doing uefi install on desktop system.
Just in case I selected non uefi install and all works well now:


#14

This is an updated user experience from previous post. (See above)


#15

Thanks @mer. I almost spit a mouthful of coffee into my keyboard because of this comment… :joy: :sunglasses:

Remember the old adage:

“Running VMS is like driving a nail with your forehead. Eventually you will get somewhere, but not without some blood loss and a headache.”


#16

When in 2017 I tried to install TrueOS, it didn’t work on my AMD A4-3300 CPU (GPU device: Sumo Radeon HD6410D). Now with Trident Beta2 I tried first on Intel Core i5-3470 CPU (GPU device: Xeon E3-1200 v2/3rd Gen Coreprocessor Graphics Controller) but there the installer never allowed the “install into a boot environment” option and installing to a thumb drive didn’t result in a bootable system. Trident Beta2 on the amd64 architecture desktop containing the AMD CPU was installable into a boot environment and seems to be working. This was the first display after logging in:
FirstScreenTrident2018-09-09-15-14-49
Falkon seems to be working since this post is written in that browser. :+1:

These are the results of the about and uname -a command:

[rudy@trident-2548 ~]% about
zsh: command not found: about

[rudy@trident-2548 ~]% uname -a
FreeBSD trident-2548 12.0-CURRENT FreeBSD 12.0-CURRENT #0: Thu Sep 6 13:31:01 UTC 2018 root@poseidon:/usr/obj/usr/src_tmp/amd64.amd64/sys/GENERIC amd64

AppCafe is not empty:
AppCafeTrident2018-09-09-17-53-52
but my favourite application “deadbeef” isn’t available at the moment. :wink: —Okay, a lot of other applications are missing as well. There seems to be no option to change the “local” choice.
Sound is working well out of the box. The Lumina Media Player is doing its thing.


#17

Installing via “pkg install …” is working. So I can listen to music with “deadbeef” again. :slightly_smiling_face:

A flashing system controller icon on the system tray alerted me to an ongoing update. Since this is Trident Beta2 I didn’t want to update anything but the “Stop Updates” button on this window
TridentUpdate2018-09-10-06-16-37
didn’t do anything and in the middle of this post the system automatically rebooted to update 424 packages.
During this process a lot of packages were skipped and after a second automatic reboot the system booted automatically into a brand new boot environment:

[rudy@trident-2548 ~]% beadm list
BE                              Active Mountpoint  Space Created
initial                         -      -            2.5G 2018-05-01 15:06
12.0-CURRENT-up-20180501_155633 -      -            7.5G 2018-05-01 15:54
CustomBE-201809091457           -      -            1.0M 2018-09-09 14:57
12.0-CURRENT-201809091507       -      -            6.1G 2018-09-09 17:07
12.0-CURRENT-up-20180910_062826 NR     /           13.6G 2018-09-10 06:23 

This new boot environment so far seems to be working like the one from the day before.
There is still no Update Manager within the control panel:
TridentControlPanel2018-09-10-06-53-50


#18

I cannot install Trident BETA-2 into a new Boot Environment. That option is disabled.

It displays correctly all partitions.

My machine has UEFI bootloader with Linux Mint’s Grub.

What is possibly wrong?


#19

First thing that comes to mind. Grub.

Did trueos ever create a boot environment?


#20

I’m not sure which of the things I did ultimately was responsible for AppCafe to connect to anything else than “local”. But if “local” is the only option you can choose from AppCafe will always only show the packages that are already installed (= local)… So you will never be able to install anything (new / that isn’t installed already (and in that case you can only uninstall it)).