Beta03 is out, so have at it


#21

I’m writing this from Falkon under Trident right now :grinning:


#22

So right now, I have to do:

  1. Configure re0 manually using 192.168.0.X, X<>1
  2. And after reboot
    route add default 192.168.0.1

So there is an issue with the DHCP IPv4 address config.

And I’m writing this from Firefox 62 right now, which I prefer much from Falkon :grinning:


#23

The permanent solution is quite simple: start dhcpcd and dhcpcd.re0 on boot :wink: Now the default route gets added correctly.


#24

Simple and uneventful fresh install - no problems :slight_smile:
then "trueos-update upgrade, and all got done with help of AI :))

FreeBSD trident-4986 12.0-CURRENT FreeBSD 12.0-CURRENT #0: Mon Sep 24 21:00:29 UTC 2018

glxinfo | grep NVIDIA

name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4

server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation
OpenGL core profile version string: 4.5.0 NVIDIA 390.77
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL version string: 4.5.0 NVIDIA 390.77
OpenGL shading language version string: 4.50 NVIDIA
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.77

I’ve made extra effort and I installed mesa-demos to play glxgears - lol
More later,

Edit1: more

pkg install phototonic for thumbs, preview and simple editing is a must, in this beta.

Edit2: more

I noticed that xorg is not part of the default installation in Beta 3, I guess because is not needed in X with Official NVIDIA driver that I use. Though , I did install xorg with pkg anyway to see how and what’s inside. After looking into xorg, I decided that I didn’t really needed at this stage, so I deleted xorg with AppCafe and cleaned its orphans. That exercise went well. AppCafe did a good job deleting and cleaning orphans after xorg.

Next, I did pkg install LibreOffice and I noticed that en-hunspell was not installed by default.
Did pkg install en-hunspell in so I can correct my spelling in LibreOffice Writer.

Whatever is in Beta 3 now seems to work OK for me, including Firefox with my fav plugins :slight_smile:

Edit3: img below

trident

GJ “Project Trident” team!

Edit 4: Comments

I won’t be able to upgrade my TureOS 18.03 machine with Legacy BIOS to Project Trident, due to UEFI boot requirements in Project Trident :frowning:

Edit 5: Update with reference to Edit 4 above - Second machine (Dell Precision T5500) fresh install, from USB dongle, and after trueos-update upgrade

Many issues.
Analog or USB sound doesn’t work
Sysadm icon disappears from task bar
AppCafe crashes
uname -a doesn’t indicate trident tag, just FreeBSD-12.
pkg install py36-iocage doesn’t bring required py dependencies, so it’s not installed correctly

Not sure what’s going on. This machine ran TruesOS 18.03 without issues.
Now, after fresh Project Trident installation, I’m struggling :frowning:
Changing BEs and doing trueos-update upgrade again doesn’t help.
I need my jails back in there! Still working on it … /var/log/messages do show issues :frowning:

Maybe, later I’ll create new tread related to issues with upgrades or fresh installs of Project Trident with legacy BIOS.

That’s why I did fresh install on clean, but old, NTFS formatted HD inside my other old PC with EVGA P67 motherboard and Nvidia GTX960 GPU, in this test of Project Trident Beta 3.

While playing with Trident Project Beta 3, I noticed that there weren’t as many meta packages, utilities and system configuration scripts in fresh Beta 3 installation, compared with TrueOS stable-18.03,


#25

Finally I solved my issues and got things fixed and running as good as possible in this Beta 3 on my Dell T5500

uname -a
FreeBSD trident-1496 12.0-CURRENT FreeBSD 12.0-CURRENT #0: Mon Sep 24 21:00:29 UTC 2018

My initial issues had something do to with gparted, during first attempt of Full Disk/Beta 3 installation over existing TruesOS-18.03., I guess. After wiping my HD clean of all partitions and re-doing Full Disk installation, Beta 3 behaves much better. Though, there are still few minor issues that I can live with for now, like the disappearing SySadm icon from the bottom panel and crashing Falkon.

And, I think that I had issues installing py36-iocage from pkg in TureOS too and had to make it from ports. So, I’m going to bring ports in to Beta 3 and try py36-iocage install from there.

Me happy now :slight_smile:


RC1 has been unleashed
#26

Don’t know if this is the right thread for this question, but I’ll try :innocent:

I have an issue that I can’t get the mic to work on my laptop with TrueOS 18.03 (same with earlier versions).
It has Intel Motherboard and Pentium SU4100 CPU. Audio Driver for Windows is Realtek 6.0.1.5901
Product info: https://www.acer.com/ac/sv/SE/content/support-product/1289

Is this fixed/will this be fixed in Trident?

Note. My desktop computer with AMD Motherboard and Audio Realtek ALC887-VD 8-Channel High Definition Audio CODEC *2 has no problem at all https://www.asus.com/Motherboards/A85XMA/specifications


#27

not sure. Project Trident has trueos 1806.

Something to try, install another program, pavucontrol

sudo pkg install pavucontrol

and see if the mic works. you can change inputs and outputs


#28

I got pissed off, so I’ve made official complaint! - lol


#29

Project Trident getti’n me confused :slight_smile:
I’ve made iocage from ports:

git clone --depth=1 https://github.com/trueos/trueos-ports.git /usr/ports

It makes it but with warnings, and iocage still doesn’t work.

root@trident-1496:/usr/ports/sysutils/iocage # make install clean
/!\ WARNING /!\

You have security/openssl installed but do not have
DEFAULT_VERSIONS+=ssl=openssl set in your make.conf

===>  License BSD2CLAUSE accepted by the user
=> iocage-iocage-20180329-19d8eb7f4272dac7e206b4f827732f46177439c8_GH0.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://codeload.github.com/iocage/iocage/tar.gz/19d8eb7f4272dac7e206b4f827732f46177439c8?dummy=/iocage-iocage-20180329-19d8eb7f4272dac7e206b4f827732f46177439c8_GH0.tar.gz
fetch: https://codeload.github.com/iocage/iocage/tar.gz/19d8eb7f4272dac7e206b4f827732f46177439c8?dummy=/iocage-iocage-20180329-19d8eb7f4272dac7e206b4f827732f46177439c8_GH0.tar.gz: size unknown
fetch: https://codeload.github.com/iocage/iocage/tar.gz/19d8eb7f4272dac7e206b4f827732f46177439c8?dummy=/iocage-iocage-20180329-19d8eb7f4272dac7e206b4f827732f46177439c8_GH0.tar.gz: size of remote file is not known
iocage-iocage-20180329-19d8eb7f4272dac7e206b4f         338 kB 3134 kBps 00m00s
===> Fetching all distfiles required by py36-iocage-20180329 for building
===>  Extracting for py36-iocage-20180329
=> SHA256 Checksum OK for iocage-iocage-20180329-19d8eb7f4272dac7e206b4f827732f46177439c8_GH0.tar.gz.
===>  Patching for py36-iocage-20180329
===>   py36-iocage-20180329 depends on package: py36-pytest-runner>=2.0.0 - found
===>   py36-iocage-20180329 depends on package: py36-setuptools>0 - found
===>   py36-iocage-20180329 depends on file: /usr/local/bin/python3.6 - found
===>  Configuring for py36-iocage-20180329
fastentrypoints
/usr/local/lib/python3.6/site-packages/setuptools/dist.py:398: UserWarning: Normalizing '1.0a' to '1.0a0'
  normalized_version,
running config
===>  Building for py36-iocage-20180329
fastentrypoints
/usr/local/lib/python3.6/site-packages/setuptools/dist.py:398: UserWarning: Normalizing '1.0a' to '1.0a0'

openssl is in , but the wrong one, I guess :frowning:

openssl version
LibreSSL 2.7.4

I’m done, because i’m too dumb. I’ll wait for experts to figure out what’s going on :blush:


#30

Already done that, didn’t help.
The option Mic in Recording Unit drop down menu at Mixer => System Configuration, is simply not there.
Also tried an external mic, no change.

Maybe could check with the dev’s if that’s something that can be fixed for this kind of Audio Card. I’m in great need of the mic function :worried:


#31

#32