BETA-02 is out now


#1

For the first BETA-02 of Project-Trident

this is the link —> http://pkg.project-trident.org/iso/release/

WiFi should be working at the moment.

Installing into a Boot Environment, HAS been tested. It appears to work properly.

Full Disk Encryption has been temporarily disabled, ongoing issues has made the feature unreliable at the moment

If you have a Lenovo, or if you have weird graphics, read the lnk below. YOUR hardware issue. we will not fix

read this article on where and how to report bugs, Bugs reports are only for the RELEASE directory, please include your ISO image name within bug report. If you use ANY OTHER release, you are on your own, and bugs tickets will be closed

http://www.project-trident.org/information/opensource/


BITCH about Trident-Beta HERE
#2

In short:

  1. Boots just fine (as beta 01 did)
  2. Mouse now works -> installable
  3. Installable into new BE - confirmed
  4. Looks nice and no major problems. But AppCafe only connects to local (-> can’t install anything new from internet) and no updatemanager in sysadm present (haven’t checked cli yet, though). Not sure if it’s just my system or current state of trident development.

Used another system to create usb installxfce medium this time.
Different hardware, same windows.
Also crashes the system when resulting usb install medium is inserted while windows is running. Some ntoskrnl.exe BSOD.
Well. Maybe I really should wait for the (internal) upgrade path for TrueOS 18.03 to come out… :slight_smile:

[Edit]
Just checked cli: pc-updatemanager not present.
Pkg works. Installing some packages including xfce - no problem.
Even p-updatemanager can be installed via pkg.
Pkg and pc-updatemanager both finde some pgk-updates/-upgrades (both cli).
But pc-updatemanager is now also available via sysadm.
And: Now AppCafe is connected to trueos major (not just “local” available anymore). Not sure if that was just the installation of the pc-upatemanager package or some update later on.

So glad my internet is now approx. 14x faster than back in march… :slight_smile:
At least now I’m not the bottleneck if update downloads are slow.

Trident, Baby!

[/Edit]

[Edit 2]

The updates that pc-updatemanger found are not being applied. No new BE created, after countless reboots no efforts of updating anything but always reminding me to reboot to apply updates. Deleting /tmp content doesn’t change that. Pkg clean neither.
Will have to delete pkg-cache content and retry.

Btw: Lousy boot logo! :slight_smile:

[/Edit 2]


BITCH about Trident-Beta HERE
BITCH about Trident-Beta HERE
#3

“Well. Maybe I really should wait for the (internal) upgrade path for TrueOS 18.03 to come out… :slight_smile:

The problem with that is, what if the upgrade attempt doesn’t work, and bricks your 18.02 in the process? I’m waiting until folks are reporting successful upgrades. Althought if you make an image you should be ok.


#4

upgrade path is installing into a new Boot Environment


#5

Very encouraging! I’m sure I’ll get bored/anxious enough soon to give it a try. As long as there’s a reasonable chance of success, I’m willing to give it a go.


#6

Enter the magic of BEs… part of the TrueOS experience since inception…


#7

Enter the magic of BEs

Sry for the newbie question but what is BE? Tx


#8

Boot environments
https://sysadm.us/handbook/client/sysadmclient.html#boot-environment-manager

TrueOS® supports a feature of ZFS known as multiple boot environments (BEs). With multiple BEs, the process of updating software becomes a low-risk operation as the updates are applied to a different boot environment. If needed, there is an option to reboot into a backup boot environment.


#9

Ah, now I remember. I did use that feature successfully once when True would no longer boot. So now I can go forth boldly into the new frontier.


#10

True, ZFS is one of the reasons why I want to make BSD my daily workhorse. It’s funny imagining a multi-boot environment. I guess that’s why other OSs try to snapshoot their latest stable boot up. It never worked that well for me in general on all OSs. I like how BSD is rock solid proof.


#11

Note that this is more a ZFS feature than an OS feature. I’m pretty certain I could do something similar with my Linux rigs that use a ZFS root. Just create a new (recursive) snapshot in the root dataset before applying the upgrade. Rewinding will be a bit less straightforward … but you keep a backup bootable medium that can mount your main disk anyway, don’t you :wink:


#12

After Dupe left me cold with months worth of unusable bckps, I switched to Back In Time. Nice eye candy :blush: and it works.


#13

Update on the updates that Trident finds after installing pc-updatemanager.

Before at the end of last week (I guess it was Sept 8th) I cleared out the pkg-cache folder (and of course the /tmp folder again). Then the update (via sysadm -> pc-updatemanager, i.e. gui) went finally through, i.e. a updatestage folder was created and a new BE as well. After the necessary reboot the final install workings were done, but the system always end booting at cli level. A second and third try of the whole update process from zero (! = see above folder clearing) brought about the same result.
So, I guess, for now the update channel that trident is dipping into is the TrueOS new (= server edition) update channel.
Startx is failing. Some previously installed packages (because they are needed for a gui DE to work) were not installed anymore. I was unsuccessful to get my DE or xorg to work properly again. Installing xorg and xfce apparently aren’t enough.

So, for now, I just went back to the trident beta install BE and just wait and let the devs do their magic with all the time they need to get trident train on the rails completely. Especially as I’m still not using a non-windows os as my primary system, i.e. I have “all the time in the world” to wait - but trueos (core/base) is the only os I’m waiting for, at the moment. I don’t see any other os making me quit winos. :slight_smile:


#14

pc-updatemanager has been depreciated for trueos-update.

Updates are NOT working


#15

I guess, what you mean by “Updates are NOT working” is “Updates are NOT working properly yet”.

Because, on my system, I can get trident beta 2 to (further) update of some kind, but not resulting in a properly working, further updated trident beta 2.

So, I also guess, what you also mean by “Updates are NOT working” is: Even if you can get trident beta 2 to update (note the difference: it does not say: update TO trident beta 2, but: update (a) trident beta 2 (BE / system)), don’t do it, because it doesn’t result in a properly working, further updated, BE / trident system.


#16

This is a beta. We’re Trying to get a functional install. In full disk, and boot environment.

Updating is NOT a priority until that happens .

So, no updates working, meaning NO updates working. PERIOD


#17

Alright, trying to do an install using beta2 but it fails on locating any (Xorg) screens. With TrueOS install it takes two tries I think before it detects the screens connected to the nvidia card. I think the issue is there is a vesa card on the m/b which it tries before moving on to nvidia. I cannot disable it only tell BIOS the external card has priority.

Not sure if it’s possible to say no use the built-in and once installed change it to the external and have that work?


BITCH about Trident-Beta HERE
#18

dual video or single nvidia?

on telegram, it appears nvidia has issues.

try scfb for uefi boot to install , then install nvidia drivers


#19

Eh, single card triple monitors. OK, testing internal card right now. That’s failing as well.
OK, I’ll try your suggestion. SCFB how do I select or install that?


#20

that “should” be the default, until it asks for video card info