Autologin not working?


Hi guys,

Just wanting to know has anyone else got autologin working well with the latest stable?

Mine just flashes a couple times then presents me back to a login screen. No dice. :frowning:

Thank you


Same here. I opened a bug report on GH a week or two ago but no response yet.

It fails to autologin both lumina and MATE.



As of the most recent update (TrueOS-Desktop-201706210948), autologin to Lumina doesn’t work for me.


Has anyone got autologin working with any display managers besides KDM and GDM? GDM requires you install most of GNOME and KDM is the same but with KDE. lightdm depends upon greeters that are missing from ports and slim isn’t working for me, it fails to start via openrc or rc.conf whilst autologin is still non-functional under pcdm.

There are a few different ways to get X to start automatically without any DM but I like using a minmal DM over rc.conf commands etc personally.


have you tried using the latest ISO/IMG?

Otherwise, looks like I’ll need to setup a VirtualBox session and look


Yes - ISOs since May/June have failed to install for me but I am up-to-date according to the update manager.

I opened a ticket for autologin being broke a month or so back and it was closed as being fixed. After the next update I tried again with no luck.


I have another issue with PCDM too in that it works fine on first login but after logging out once, there is a delay of a minute or two when logging back in.


installed in Virtualbox last night.

Where is the autologin located?


I don’t have a TrueOS install to hand but its something like Control Panel -> Login Settings (or Display Manager Settings). I found it quite easy to find.


Close :wink:

Left Mouse -> Preferences -> All Desktop settings

thanks, I 'll look in a few on the Virtualbox


turned it on, rebooted 3 times, and turned off VB twice. At this point, it’s auto-logged in each and every time