AppCafe and Update Manager extremely slow


#1

Today I have installed TrueOS on a new computer build, and I find that the (post installation) application install process, and Update Manager are excruciatingly slow. I havent used this OS since the early days of PC-BSD. I am somewhat familiar with the CLI. Are there any settings I might want to take a look at. Is this a common issue with the TrueOS repository?

I was using FreeBSD on another computer in a VM, and updating it over my cell phone hot spot seemed faster than this (broadband at home).

Thank you for your time and assistance.


#2

Real hardware or Virtual?
Bios or UEFI
Video card

If you have TrueOS installed, can you type about and post here

Have you run a speed test on you ip address

also look through the handbook --> https://www.trueos.org/handbook/trueos.html


#3

Sorry, I didn’t think about posting particulars. Please don’t think I’m made of money here, saved up for a bit… my last box was a Sempron.

Real hardware, UEFI, with 1070ti, running latest nvidia drivers (not sure which, that is what I selected on installation)

Speed test ~155Mbps down/~16.9Mbps (80 miles from D.C. on Speakeasy online test) (not using wifi that is another problem I have --no carrier) using igb0.

===================
General information

boot environment now (N) … initial NR 2018-03-17
after restart ® … initial NR 2018-03-17
boot loader …………………………………… BSD
type ……………………… EFI
CPU ………………………………………………………… Intel® Core™ i9-7900X CPU @ 3.30GHz
number of cores ……………… 20
host ……………………………………………………… ahmanet.local
memory ………………………………………………… 32768 MB available, 29166 MB free
OS git branch ……………………………………………………………………………………… trueos-stable-17.12
OS git revision ………………………………………………………………………………… d26791952
OS kernel build time ………………………………………………………… Sat 2017 Dec 9 18:10:09 UTC
OS kernel identity …………………………………………… (uname -i) GENERIC
OS platform (architecture) ……………………… (uname -m) amd64
OS release level ………………………………………………… (uname -r) 12.0-CURRENT
OS version and patch level …… (freebsd-version) 12.0-CURRENT
TrueOS package set ………………… STABLE
TrueOS version …………………………… TrueOS-Desktop-201712111405
uptime ………………………………………………… 2:58
user …………………………………………………… webbro

More (TrueOS Desktop):

desktop environment …… Lumina
sound card driver ………… pcm0: <Realtek ALC1220 (Rear Analog 5.1/2.0)> (play/rec) default
wireless driver ……………… iwm0
X11 drivers ………………………… nvidia_drv.so

#4

you’re using STABLE, you “should” be up to date.

personally, I use the terminal to update my system

the commands I use;

sudo pc-updatemanager pkgcheck
sudo pc-updatemanager pkgupdate
sudo pc-updatemanager startupdate

those may be what you are looking for


#5

I thought that may be the case as well, using the “app” store, it took forever to install calibre.

Wen to the cli, to pkg install xfce, and it has been going for two hours… and I’m on 44/48 I wonder if it has anything to do with ZFS?

[1/88] Fetching xfce-4.12_1.txz: 100% 832 B 0.8kB/s 00:01
[2/88] Fetching xfce4-terminal-0.8.6.txz: 100% 377 KiB 385.5kB/s 00:01
[3/88] Fetching xfce4-conf-4.12.1.txz: 100% 118 KiB 120.7kB/s 00:01
[4/88] Fetching libxfce4util-4.12.1.txz: 100% 76 KiB 77.7kB/s 00:01
[5/88] Fetching libxfce4menu-4.12.1_1.txz: 100% 215 KiB 220.4kB/s 00:01
[6/88] Fetching vte3-0.48.3_1.txz: 100% 237 KiB 242.5kB/s 00:01
[7/88] Fetching pcre2-10.21_1.txz: 100% 1 MiB 1.1MB/s 00:01
[8/88] Fetching xfce4-wm-4.12.4.txz: 100% 469 KiB 480.6kB/s 00:01
[9/88] Fetching libwnck-2.30.7_1.txz: 100% 376 KiB 385.1kB/s 00:01
[10/88] Fetching libXres-1.0.7_3.txz: 100% 8 KiB 8.0kB/s 00:01
[11/88] Fetching xfce4-session-4.12.1_4.txz: 100% 600 KiB 614.1kB/s 00:01
[12/88] Fetching iceauth-1.0.7.txz: 100% 13 KiB 13.2kB/s 00:01
[13/88] Fetching upower-0.99.4.txz: 100% 149 KiB 152.5kB/s 00:01
[14/88] Fetching xfce4-panel-4.12.1.txz: 100% 569 KiB 582.6kB/s 00:01
[15/88] Fetching libexo-0.10.7.txz: 100% 392 KiB 401.2kB/s 00:01
[16/88] Fetching garcon-0.6.1.txz: 100% 101 KiB 103.4kB/s 00:01
[17/88] Fetching xfce4-desktop-4.12.4.txz: 100% 732 KiB 750.0kB/s 00:01
[18/88] Fetching Thunar-1.6.13.txz: 100% 906 KiB 928.2kB/s 00:01
[19/88] Fetching libexif-0.6.21_4.txz: 100% 449 KiB 460.2kB/s 00:01
[20/88] Fetching libnotify-0.7.7.txz: 100% 46 KiB 47.2kB/s 00:01
[21/88] Fetching gvfs-1.26.3_6.txz: 100% 1 MiB 1.0MB/s 00:01
[22/88] Fetching libcdio-paranoia-10.2+0.94+1.txz: 100% 84 KiB 85.9kB/s 00:01
[23/88] Fetching libcdio-0.94.txz: 100% 304 KiB 311.3kB/s 00:01
[24/88] Fetching hal-0.5.14_32.txz: 100% 258 KiB 264.0kB/s 00:01
[25/88] Fetching policykit-0.9_10.txz: 100% 142 KiB 145.5kB/s 00:01
[26/88] Fetching dmidecode-3.1_1.txz: 100% 70 KiB 71.5kB/s 00:01
[27/88] Fetching libvolume_id-0.81.1.txz: 100% 32 KiB 32.4kB/s 00:01
[28/88] Fetching gnome-mount-0.8_13.txz: 100% 87 KiB 88.9kB/s 00:01
[29/88] Fetching policykit-gnome-0.9.2_8.txz: 100% 110 KiB 112.8kB/s 00:01
[30/88] Fetching gnome-doc-utils-0.20.10_4.txz: 100% 310 KiB 317.9kB/s 00:01
[31/88] Fetching rarian-0.8.1_4.txz: 100% 115 KiB 117.9kB/s 00:01
[32/88] Fetching docbook-xsl-1.76.1_3.txz: 100% 4 MiB 1.3MB/s 00:03
[33/88] Fetching docbook-1.5.txz: 100% 544 B 0.5kB/s 00:01
[34/88] Fetching sdocbook-xml-1.1_2,2.txz: 100% 15 KiB 15.1kB/s 00:01
[35/88] Fetching docbook-xml-5.0_3.txz: 100% 540 KiB 553.3kB/s 00:01
[36/88] Fetching xmlcharent-0.3_2.txz: 100% 12 KiB 12.3kB/s 00:01
[37/88] Fetching docbook-sgml-4.5_1.txz: 100% 136 KiB 138.8kB/s 00:01
[38/88] Fetching iso8879-1986_3.txz: 100% 13 KiB 13.0kB/s 00:01
[39/88] Fetching bash-4.4.12_3.txz: 100% 1 MiB 1.5MB/s 00:01
[40/88] Fetching getopt-1.1.6.txz: 100% 40 KiB 41.1kB/s 00:01
[41/88] Fetching py27-libxml2-2.9.4.txz: 100% 161 KiB 164.7kB/s 00:01
[42/88] Fetching libgnome-keyring-3.12.0_2.txz: 100% 117 KiB 119.8kB/s 00:01
[43/88] Fetching libsecret-0.18.5.txz: 100% 256 KiB 262.6kB/s 00:01
[44/88] Fetching gcr-3.18.0.txz: 100% 799 KiB 817.8kB/s 00:01


#6

ZFS won’t affect downloads.

Either, your connection or CDN network


#7

I’m having the same issue. I’ve been running TrueOS UNSTABLE on the desktop for a while. When I update that system, it takes a very long time (usually more than just overnight). This has an i7, 16 GB ram, and SSD, so I don’t think the machine itself is a problem. My internet connection is 150mbps fiber up and down.

I installed TrueOS server UNSTABLE last night in a bhyve VM on FreeNAS. This has 4 GB ram and 2 CPUs allocated to it. The FreeNAS pool has an NVMe log on it. It’s still updating (over 17 hours now). top shows 100% idle cpu, 3 GB ram free.

Each individual fetch seems to go fast (under a second). After each fetch, the update has no output for at least a minute.

Rod, I only used pc-updatemanager pkgupdate. Could not running the pkgcheck beforehand be an issue?


#8

are you running in a terminal?

if so, watch the downloads

can you you post the output of -> about <- here?


#9

Try to disable ipv6. When running TrueOS in VirtualBox on windows, I noticed the network (well, the updates at least) gets extremely slow with ipv6 enabled. I’m sorry, I didn’t have time to investigate why.


#10

On the server, yes. On my desktop, no. I use the Update Manager gui.

Rod, I’m not sure what you mean by this. Glad to post some output though.


#11

In a terminal, type about then press Enter.


#12

Tried that, but looks like that command isn’t installed on the server. I’ll try to install that (will be slow of course) and run it.
Here’s the info from the desktop:

===================
General information
===================

boot environment now (N) … 12.0-CURRENT-up-20180327_162510 NR 2018-03-27
       after restart (R) … 12.0-CURRENT-up-20180327_162510 NR 2018-03-27
boot loader …………………………………… BSD
            type ……………………… BIOS
CPU ………………………………………………………… Intel(R) Xeon(R) CPU E3-1231 v3 @ 3.40GHz
    number of cores ……………… 8
host ……………………………………………………… workstation0
memory ………………………………………………… 16384 MB available, 13969 MB free
OS git branch ……………………………………………………………………………………… trueos-master
OS git revision ………………………………………………………………………………… fa797a5a3
OS kernel build time ………………………………………………………… Fri 2018 Mar 23 13:28:18 UTC
OS kernel identity …………………………………………… (uname -i) GENERIC
OS platform (architecture) ……………………… (uname -m) amd64
OS release level ………………………………………………… (uname -r) 12.0-CURRENT
OS version and patch level …… (freebsd-version) 12.0-CURRENT
TrueOS package set ………………… UNSTABLE
TrueOS version …………………………… TrueOS-Desktop-201803131015
uptime ………………………………………………… 25 mins
user  …………………………………………………… jeff

More (TrueOS Desktop):

    desktop environment …… Lumina
    sound card driver ………… pcm0: <NVIDIA (0x0060) (HDMI/DP 8ch)> (play) default
    wireless driver ……………… 
    X11 drivers ………………………… nvidia_drv.so

#13

I’ve added ipv6_activate_all_interfaces=“NO” to me rc.conf. Will that disable it?

On the server, I’m trying pkg with the -4 option, but it’s still real slow.


#14

I don’t think that’s enough. From the /etc/defaults/rc.conf:

ipv6_activate_all_interfaces="NO"       # If NO, interfaces which have no
                                        # corresponding $ifconfig_IF_ipv6 is
                                        # marked as IFDISABLED for security
                                        # reason.

I had to remove the following line from the /etc/rc.conf (replace em0 with your network name):
#ifconfig_em0_ipv6="inet6 accept_rtadv"

After that, iconfig stopped reporting ipv6 address assigned to the interface.
If the above doesn’t work, try:

# /etc/rc.conf
ipv6_network_interfaces="none"
# or:
ifconfig_em0_ipv6="IFDISABLED"  # replace with your network name

Don’t forget to restart.


#15

I’ve got all the following on the desktop, but still getting an ipv6 address in ifconfig.

ipv6_network_interfaces="none"
ipv6_activate_all_interfaces="NO"
ip6addrctl_enable="NO"
ifconfig_igb0_ipv6="IFDISABLED"
ifconfig_igb1_ipv6="IFDISABLED"
ip6addrctl_policy="ipv4_prefer"

#16

weird…
just in case, did you restart your machine after modifying /etc/rc.conf?
what’s the output of ifconfig?
and maybe complete content of your /etc/rc.conf?


#17

when adding that the /etc/rc.conf a reboot is probably a good thing


#18

Yea, I restarted the machine after modifying /etc/rc.conf.
ifconfig:
[jeff@workstation0] ~% ifconfig
igb0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=e525bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,LRO,WOL_MAGIC,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
ether d0:50:99:47:8b:a6
inet6 fe80::d250:99ff:fe47:8ba6%igb0 prefixlen 64 scopeid 0x1
inet 192.168.1.102 netmask 0xffffff00 broadcast 192.168.1.255
nd6 options=1
media: Ethernet autoselect (1000baseT )
status: active
igb1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=e525bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,LRO,WOL_MAGIC,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
ether d0:50:99:47:8b:a7
inet6 fe80::d250:99ff:fe47:8ba7%igb1 prefixlen 64 scopeid 0x2
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: Ethernet autoselect
status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
groups: lo

/etc/rc.conf
[jeff@workstation0] ~% cat /etc/rc.conf
webcamd_enable=“YES”
kldload_i915=""
kldload_nvidia=“nvidia-modeset nvidia”
# Auto-Enabled NICs from pc-sysinstall
ifconfig_igb0=“ALL”
ifconfig_igb1=“ALL”
hostname=“workstation0”
zfs_enable=“YES”
kld_list=""
kldload_vbox=“vboxdrv”
vboxnet_enable=“YES”
ipv6_network_interfaces=“none”
ipv6_activate_all_interfaces=“NO”
ip6addrctl_enable=“NO”
ifconfig_igb0_ipv6=“IFDISABLED”
ifconfig_igb1_ipv6=“IFDISABLED”
ip6addrctl_policy=“ipv4_prefer” # Use IPv4 instead of IPv6


#19

my /etc/rc.conf

cat /etc/rc.conf
webcamd_enable=“YES”
kldload_i915=""

Auto-Enabled NICs from pc-sysinstall

ifconfig_em0=“ALL”
ifconfig_wlan0=“WPA 192.168.0.8 netmask 255.255.255.0”
wlans_iwn0=“wlan0”
hostname=“nuna.business.org
zfs_enable=“YES”
ipv6_activate_all_interfaces=“NO”
kld_list=""
kldload_vbox=“vboxdrv”
vboxnet_enable=“YES”


#20

Running out of ideas.

Is there a chance you have /etc/rc.conf.local?
See: Disabeling ipv6

To temporary disable ipv6 and test the updates, try (replace with real ipv6 address; you seem to have only igb0 active):
sudo ifconfig igb0 inet6 fe80::d250:99ff:fe47:8ba6 delete