AMDGPU, radeon and ati drivers all fail


#21

If FreeBSD 12.0-Current does not support it, then TrueOS won’t support it :frowning:


#22

thx Rod , I understand, I read something about re-compiling updated freebsd-base-graphics , but i don’t think its good idea to mix fBSD kernel on TrueOS… I hope things will be improved on the next (early 2019?) release


#23

Welcome

it’s possible, but. unless you know FreeBSD & TrueOS, not a very good idea.

Keep watching the FreeBSD 12.0-current list for their develpoment


#24

I had/have AMD/ATI-RADEON driver issues in my DELL Precision M4600 laptop with AMD/ATI FirePro-5950/RADEON HD 6730M/6770M/7690XT (Whistler/TURKS architectures) GPU since the video adapter quit for some reason after one of Windows 10 update. I don’t know if it was a coincidence that after the update the GPU has failed, or if the Windows update had broken the video adapter. After that incident, I tried Windows 7 with so called official AMD/ATI drivers and Linux with generic RADEON drivers. But, other than ugly VESA mode, nothing else worked in neither of those Operating Systems.

Then, last summer I tried TrueOS/Desktop with July’s STABLE release, and BOOM, the high resolution video came alive; not with GPU acceleration, but at least with software and CPU high res. rendering of 1920x1080 which is the default display in this laptop’s screen. Now comes the bad part. After the December release of TrueOS-Desktop/STABLE, I cannot get the video adapter to do anything but ugly VESA again.

I know that this GPU is not listed as supported in FreeBSD, but it worked once with radeon driver when loaded in rc.conf and in xorg.config. I tried all that I know to make the video high res. display work as before, but no luck.

So, I wonder what has changed in the kernel or the radeon driver in TrueOS-Desktop/December STABLE release that prevents me from configuring the driver and display, as before. I just can’t figure out when, where and how, during hardware probing, does the kernel load the driver?

EDIT:
I got sick and tired of single user mode and trying, trying, trying and… So, I just gave up on TrueOS-Desktop with this laptop, for now - heh

Despite the video issues, the laptop is still a useful puter, so no big loss. TrueOS-Server likes it without the high res. video in console mode :slight_smile:

Though, it bugs me why and what’s happening with the video driver.


#25

@ichibiri

mate what was the Linux distro that you tested?
OpenSuse Tumbleweed is running on kernel 4.14 , full support for current AMD GPUs, really kick a** … just take a look on my tests (R7 Kaveri GPU) (glmark2) (higher nr the better)

Ubuntu 17.10 : 941
DragonFly BSD (the only BSD now that support my GPU) : 1588
(some gfx were broken on DragonFly)
OpenSuse Tumbleweed: 1773
TrueOS/FreeBSD 11 : 116 (GPU supported only on the man pages)


#26

Don’t know what Tumbleweed knows that Leap-42.3 doesn’t regarding AMD/Radeon drivers. The AMD/Radeon/*? driver may work with your GPU, but it doesn’t work with mine, as intended:

But, if the AMD/Radeon GPU driver “kicks_GPU_arse”, in your system and OS, why don’t you drop here some live output of your driver conf, settings or test results.

And here is a hint:
If Windows 7 with all possible OFFICIAL AMD/Catalyst drivers won’t make my GPU work as it should, why would any other driver in any other OS, Windows 10, FreeBSD, OpenSUSE, Fedora, Debian, etc make it work.
All I know that while testing the video adapter with Dell’s M4600 built-in , pre-boot util. the adapter passes the test.

Edit:
At this point and time, it rly doesn’t matter if any AMD/Radeon driver works directly and correctly in TrueOS/FreeBSD with this laptop. It’s utilized now as “a kick_arse” TrueOS server. And, if I need to see things in nice GUI to see what’s going on inside my super server, I use RDP and connect to Lumina :slight_smile:


#27

Tumbleweed uses 4.14 kernel, whereas Leap (42.3) the 4.4.x one! The issue with the Tumbleweed is that is rolling distro anyway.


#28

Sorry I don’t have this OS installed on the hdd anymore.
I like the OpenSuse, but I wont use it as the Leap (normal version) still has an outdated kernel and the Tumbeweed is rolling, not my cup of tea.


#29

@ctosian

Just for your info, because this thread is getting off and away from TureOS/FreeBSD-12 topics. I did try Tumbleweed and rest of the latest Linux based distros, based on rolling releases, that I’m familiar with. None of them provides AMD/Radeon GPU driver module that can set or help me configure properly my FirePro-5950/POS video adapter. Moreover, AMD is known for offering rly crappy, half-ass drivers, including their latest GPUs with drivers for MSO$.- read about it.