After i install boot loader


#1

After i install i only see F1 linux f2 freebsd f3 linux

what i should do nothing happens


#2

We’re going to need a bit more information. Type of hardware, type of boot (UEFI, bios, etc).
Was this a TrueOS install or a FreeBSD install?
What was installed first, Linux or FreeBSD/TrueOS?
Can you boot into any of them?


#3

Before install trueos i was working on debian 9 with 2 partitions sda1 for home and sda3 for the system my system it was working with grub into mbr.
My specs are
Motherboard pcchips p29g+ ati 4650 video card+core 2 duo 4400
The chips on the motheboard are:
Via p4m890 and vt8237r
Thanks so much


#4

i change my hard disk to another pc and try to boot in the new pc i have installed windows so another option appear f4 disk and when i press f4 the operating system boot that thing does not happen when i press f2 to boot trueos :frowning:


#5

That is the FreeBSD bootloader that you are seeing, and that should not be used if you installed TrueOS to a UEFI system (we prefer rEFInd instead - for this exact reason).
It is possible that you de-selected the option to install rEFInd from the advanced disk options, or you are not using a UEFI system boot (so multi-booting with TrueOS is not technically supported by the team - although it is technically still possible with manual tweaks like installing GRUB[2] into the MBR).

The FreeBSD bootloader has a long history of only being able to boot FreeBSD and Windows - most Linux distros were not supported unless they were installed in such a way that they could be “chainloaded” (which lots of them are not).


#6

TrueOS’s GRUB works in my BIOS machine.

The install option “restamp GRUB” is gone - I suppose. Is there an easy way to do it if needed - yet? Perhaps a handbook entry? It could help people with BIOS machines.


#7

GRUB no longer exists on the TrueOS install media since it is not officially supported anymore - you must have one of the really old ISO’s if you still have that option…
You can theoretically install the “grub2-pcbsd” package on TrueOS post-install, and then run some CLI commands to restamp GRUB onto the MBR (similar to what the old ISO’s used to do), but that is outside my area of expertise so I can’t really offer any examples on how exactly to do that.


Boot loader install to partion
Trouble dual booting TrueBSD and linux
#8

I just installed TrueOS and as pictured above no mater what I press on my keyboard it prints a #, If i just let it boot up and touch nothing, it slowly keeps typing #. This is a multi-boot box, “bios”, “Intel dg965WH”. Keyboard does not have a stuck key, TrueOS was installed and working on this box (changed hard drive to SSD and it is smaller so I could not shrink my partion so fresh installed it) It is ti-boot 2003r2, Kali, and TrueOS (as stated earlier setup worked just fine on the spinning rust drive). I’m going to try installing again with a older version of the install media. Am I the only one with this issue??


#9

i have the same issue i dont know why but i guess is because i have debian
installed i think trueos needs to be installed alone


#10

BIOS or UEFI?

STABLE or UNSTABLE?

How did you previously install your Linux install?


#11

It is an older board “Intel dg965WH” bios only. it is the stable version. The only differences (that I recall) between my old install and this one is I switched to the SSD and switched from legacy to native in the bios for the sata ports.I installed 2003r2 first, then linux and finally TrueOS.


#12

trueos told me that trueos does not support multiboot, linux and bsd in the
same hard disk


#13

Thanks for the help.


#14

not true, bios/grub depreciated

UEFI simpler to setup and run


#15

I have multiboot: Windows 7, Linux Mint and TrueOS in the same hard disk.

Intel notebook, BIOS + GRUB.

Deprecated, though it works. :slight_smile:

It seems that fresh installs don’t allow this anymore. :frowning:


#16

Correct.the devs depreciated grub/BIOS a few months ago.

If you know how how to edit grub, you should be able to get it working


#17

I am curios why the TrueOS (freeBSD) boot loader works in the way I described above. No mater what you press a “#” is displayed if you do not press anything it will slowly print “#”, fills the screen and keeps on going. I tried multiple keyboards, same result.


#18

@sc2vladi did you figure this out?