Adventures in TrueOSing with HP 15 Laptop - Ext Display Synch?


#1

OK, right now I’m trying out TrueOS on a HP 15 Laptop and use a HDMI cable
to connect to a bigger screen external Display.

The external display resolution is 1920 x 1080.

The laptop display resolution os 1366 x 768

But the two screens are showing two different views. Both show the TrueOS logo in the center of the screen, but in order to see, for example, a terminal window, on the hi res external display, wshich opens near the center of the lap top screen, I have to move the window way off to the right, nearly off the laptop screen and then it shows on the hi-res screen. The Lumina icons, nicely arranged in a column on the left side of laptop screen, are not seen at all on hi res screen.

Is there way to get them in synch ? Do I select hi - res screen as “Primary” or something ?

Thanks
J.


#2

have you searched through discourse?

There are a couple of threads concerning multiple monitors


#3

Good idea. I was a little distracted, since TrueOS did not see the wireless and defaulted to 10bT ethernet and I had a WNC 1100 Netgear USB wirless which dmesg does recognize so I got distracted on that, not to mention the …

Oh wait, I’ll search out both of them

Thanks
J.


#4

Ha ha ha !!! Got it ! You oppen monitor configuration (right button click anywhere on the desktop) and move the little screen showing the laptop resolution on top of the bigger screen showing the hi res display resolution.
Adjust accordingly.

Oh gott this is so cute ! A kind of metaphorical doppleganger meta adjustment.

Gee, good old Minsky could have had a field day with this.

OK, thanks again !

J.


#5

Command Line Solution:

xrandr --output HDMI-1 --same-as LVDS-1

#6

I’ll try it because I can never seem to adjust the goofy little meta windows just right. And on reboot they’re slightly off again, Half icons showing too foar off to the left on the hi res screen…

Wait11 Breaking News (unrelated issue): I just did an TrueOS update, it seems to have started automatically (caught me by surprise) when rebooting . After a long series of waits, uninstalls, reinstalls, at one point it appeard stuck on whatever the hell “dalp” is but I just waited (about 5-8 minutes) and finally everything was done and anyway, they’ve added a .bashrc and it’s working !

I’m on the laptop for now until I either get a new motherboard for the desktop or a new computer. But I still have the i-Mac running High Garbagerra. If only Apple had gone ZFS. They’re going to regret that decision, soon.

Thanks for the tip.

J.


#7

Thanks bsdtester 1!

It worked perfectly with slight change:
LVDS-1 gave “cannot find output LVDS-1”

But run just xrandr shows it (Laptop screen) called eDP
so I try
xrandr --output HDMI-1 --same-as eDP-1

This works great so now bigger high res creen synched perfectly with Laptop screen.

Thank !!
J.


#8

EEeeeeeek !!! I have to run the xrandr command every time I reboot.

How does this make permanent so that it does it automatically every time ?

Thanks again !


#9

On OpenBSD, I insert it here:

$ cat /etc/X11/xenodm/Xsetup_0 | grep same
    xrandr --output HDMI-1 --same-as LVDS-1

This already activates it right at the beginning, when/before the graphical login comes up.

In OpenBSD, this is xenodm.
In TrueOS, this is PCDM.

Edit:
I can’t give another tested example, because my one and only laptop is OpenBSD-only, and I intend to never change this.

FreeBSD and TrueOS are on my desktop, where I don’t use dual-display.

2nd Edit:
If You can live with a non-mirrored login-screen, then insert it into Your ~/.bash_profile

Conceptually, like this:
If DISPLAY is set, then: xrandr …

I believe, You are using bash (as Your previous postings seem to imply it).


#10

Yes I can do the login from non-mirrored screen.

I tried doing it in /etc/X11/PCDM/Xsetup_0 but nothing happened on restart.

Will try it in bash_profile (not .bashrc ??)

Again, thanks !!

J.


#11

I don’t remember, where PCDM’s settings are. But they are totally elsewhere. OpenBSD and FreeBSD/TrueOS store their settings in different directories and differently named files. Can’t be transferred directly.

Edit:
I made a typing-error, above:

Has to be:
~/.bash_profile

You could add it into the set of Lumina’s autostart-programs, too.

Or into ~/.xsession.

Or Xsetup. Or Xstartup. Or Xsession.

There are several possible locations.


#12

OK I put xrandr line in .bash_profile but nothing happen after logout and then login.

Also tried restart, same thing xrandr no happen.

Put in .bashrc ??

Thanks
J.


#13

Wait !! .bashrc not working either.

I had an alias in there and its not working either.

Before update I know .bashrc was working.

Now it’s not.

What did they change ??

J.


#14

I automatically start a terminal during login. Therefore, it would have worked for me. I forgot, that You don’t.

Read my additions above. I have no TrueOS available, right now.


#15

No, I mean even after I open a terminal, the .bashrc is NOT working !!

Nothing is happening. Let me double check this.

Thanks, will get back later.

J.


#16

You should check Your GUI-terminal, which contains and starts Your bash-shell. In its settings, You my have a setting available, where Your shell is started as login-shell (then ~/.bash_profile) or not (then ~/.bashrc).

Edit:
Maybe, You copied and pasted, and forgot to replace my LVDS-1 with Your eDP-1 or whatever it was on Your machine?


#17

No, the eDP-1 is there, but there is something wrong with my shell environment.

I’m using LXDE windows dekstop so I start shell by clicking on LXTerminal icon.

Maybe something wrong there somewhere. Investigating…

It was fine on the initial install but then a few days ago it did an update while I was shutting down, so I have to investigate that now.

Thanks !
J.


#18

I would suspect, Your shell is not bash.

Test:

$ `which ps` $$
  PID TT  STAT       TIME COMMAND
66121 p6  Ss      0:00.12 -bash (bash)

#19

AHA !!! It’s working fine when I use LUMINA desktop.

So WHAT in the heck does LXDE do with the shell environment ?

Eeeeeek !!

Investigating…

Thanks I think I can take if from here. Sherlock Holmes cap on…Alimentary my dear Watson !
But Holmes ! Didn’t you mean elementary ?
No Watson, ALIMENTARY, it’s time to eat !!!


#20

AHA #2 !!! NEWSFLASH !!! BSDTESTER NAILS IT !!!

IT TELLS ME I’M USING CSH !!!

OK, now I just figure out how to tell it to do bash, not cshell.

Wow, what a trip.

I wonder if they have any openings in the monastery…

THANKS 1!!

J.