A few minor annoyances

#1

Greetings,

I am currently running Trident U8 and most things are working just fine.
I first installed Trueos 18.03 about 8 or so months ago.
I then installed Trident 18.12 release into a new boot environment.

about

Project Trident Information

OS Version: 18.12-RELEASE-U8
Build Date: Thu Mar 28 07:53:42 CDT 2019
Boot Type: UEFI

TrueOS Sources Used:
Base Repository: https://github.com/trueos/trueos
Base Commit Branch or Tag: trueos-stable-18.12-cleanbuild
Ports Repository: https://github.com/trueos/trueos-ports
Ports Commit Branch or Tag: cf1e3da140169d9cccb1bb5cc15a167c722230f3

System Specs:
Boot Method: UEFI
Intel® Core™ i5-4460 CPU @ 3.20GHz
Physical CPUs: 4
Physical Memory: 7.83 GB

GPU Information:
vgapci0@pci0:0:2:0: class=0x030000 card=0x85341043 chip=0x04128086 rev=0x06 hdr=0x00
vendor = ‘Intel Corporation’
device = ‘Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller’
class = display
subclass = VGA

Network Device Information
em0@pci0:0:25:0: class=0x020000 card=0x859f1043 chip=0x153b8086 rev=0x05 hdr=0x00
vendor = ‘Intel Corporation’
device = ‘Ethernet Connection I217-V’
class = network
subclass = ethernet

neofetch

OS: FreeBSD 13.0-CURRENT amd64
Uptime: 19 hours, 16 mins
Packages: 690 (pkg)
Shell: tcsh 6.20.00
Resolution: 1920x1080
DE: Lumina
WM: Fluxbox
WM Theme: bloe
Theme: Breeze-Dark [GTK2/3]
Icons: breeze-dark [GTK2/3]
Terminal: qterminal
Terminal Font: Noto Mono 12
CPU: Intel i5-4460 (4) @ 3.192GHz
GPU: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Con
Memory: 4469MiB / 8021MiB

I have found answers for most of my issues.
However, there are a few minor issues I have that I have not found answers to.
Not a big deal it’s just annoying.

  1. I have an issue with the entries in Start Menu>Preferences>Desktop Configuration:
    I also had this issue in Trueos (18.03).

Items that open in a new window open 2 windows.
e.x. Customize Look and Feel, Lumina Theme Manager, and Service Manager.

  1. tsch history is a mess. I appear to have this problem with mc:
    I also had this issue in Trueos (18.03).

https://midnight-commander.org/ticket/3063

It mentions using HISTCONTROL=ignoreboth but that is for bash not tcsh.

I’ve tried using the -r option but I have no clue if it has worked.

When trying to clear or clean out the .history file old history entries keep coming back.
I even went so far as to log in as root at the terminal and deleted the users .history file.
Never the less, old entries return and I have no clue where they are coming from.

  1. I have an issue with multi-line prompts with color in tcsh:

I set up a multi-line prompt with color and I seem to have an issue similar to:

I now have a couple of multi-line prompts I can use.

One works fine:

And the other has issues no matter what I’ve tried.

Hare are a few descriptions of what it looks like is happening
(depending on which prompt I am testing):

a. rprompt is not all the way to the right on first run of qterminal
b. it looks like a \n is ignored and the second line overwrites the first.
c. I see no first line (the second line is first)

From what I’ve read this could be due to the trailing \n in the prompt being ignored.

Though prompts after the first are fine.
I’m just confused as to why the issues only occur the first time through.

Also, with the prompts that have an issue, when using the up/down arrow to scroll through history
the line gets messed up for long history entries that are longer than one line.

This does not happen when I use the prompt that works.

From what I’ve read it is because of non printable characters in the prompt
not being properly escaped.

in .cshrc

	alias precmd 'set rprompt=%~\:$?\); /bin/sh /home/alpha/Documents/scripts/prompt.sh'
	set prompt="${white}(%#${normal} "

in prompt.sh

This code works:

if [ `whoami` != "root" ]; then
	printf "`printf \"\r\n\`((date -j +"%A %B %d %I:%M %p %Z %Y"))\`\"`\r\n\033[37;0m(\033[32;1m`whoami`\033[37;0m@\033[34;1m`hostname -s`\033[37;0m)\033[0m \n"
else
	printf "`printf \"\r\n\`((date -j +"%A %B %d %I:%M %p %Z %Y"))\`\"`\r\n\033[37;0m(\033[31;1m`whoami`\033[37;0m@\033[33;1m`hostname -s`\033[37;0m)\033[0m \n"
fi

There is an issue with this code:

printf "\n`date -j +"%A %B %d %I:%M %p %Z %Y"`" | lolcat
if [ `whoami` != "root" ]; then
        printf "\r\n\033[37;0m(\033[32;1m`whoami`\033[37;0m@\033[34;1m`hostname -s`\033[37;0m)033[0m \n"
else
        printf "\r\n\033[37;0m(\033[31;1m`whoami`\033[37;0m@\033[33;1m`hostname -s`\033[37;0m)\033[0m \n"
fi

Does anyone have any hints or pointers that could lead me in the right direction to fix these?

Thanks

p.s. I left out the code for the colors.

0 Likes