1811 prerelease is out in the wild


#1

taken from Telegram

@beanpole135

New ISO and packages available now.
18.11- PRELEASE is based off of:
OS: TrueOS master as of Nov 20th, 2018
Packages: TrueOS ports as of Nov 19th, 2018
The ISO is slightly smaller than RC3 now (~4.4 GB) as TrueOS is just now starting to commit all the ISO slimming options to their build framework. I am hoping to get the ISO back down to ~3.5GB for the next release.


#2

Update from pre-release 1 to pre-release 2 went fine. Just as experienced with beta3 to PR1.
Using “trueos-update upgrade” command.

Only difference I noticed sofar between PR1 and 2 is that “about” now gives me more useful information. But I’m sure there are many more and more serious improvements that I didn’t catch yet or are not so much in-your-face.

By the way: is there any other way to change the limit of kept BEs other than installing the on Trident “not to be used” pc-update manager to get the familiar option within sysadm? “Beadm” doesn’t give me any hints.


#3

the new “about” command is trident generated. the previous command was a trueos thing, and gave little useful info.

Not that I am aware at the moment… The trueos utils are owned by iXsystems, so we are needing to re-create a lot of utils from scratch.


#4

One issue I have noticed on my test machine, a Thinkpad T530, is that once I log out of a session (be it Lumina, KDE, etc), I get a black screen. I ssh’ed in, tried to restart pcdm, and got the following:

 * Stopping session on vt9
 * Cleaning up sessions
 * Cleaning up sessions
 * Starting session on vt9
Error: powerd is the name of a real and virtual service.
 * start-stop-daemon: /usr/local/sbin/PCDMd is already running
 * ERROR: pcdm.vt9 failed to start
 * Starting PCDM (vt9) ...
 * start-stop-daemon: /usr/local/sbin/PCDMd is already running
 * Failed to start PCDM (vt9)                                              [ !! ]
 * ERROR: pcdm.vt9 failed to start

Even after going in and killing and restarting all of the pcdm-related processes, I still get a blank screen. In fact, all of the consoles are dark as well. I ended up having to reboot from my remote session.


#5

Isn’t there some .conf or other file which one could edit manually to set the limit of number of BEs? I looked around a bit after I installed pc-updatemanager but could find any.
But I don’t want to keep pc-updatemanager installed because it screws with the update check / update ports/repositories.

On another note: I’m all for the update process to asked me first if I want allow it to just delete the oldest BE just because the set limit is reached.

There should be some sort of a multiple choice question, like:

"The set limit of number of BEs is reached. Do you want me to…

  1. … delete an existing BE (exept for the current one)? If yes, which one?
    A) The oldest.
    B) One of your choice.

  2. … increase the limit of numbers of BEs by one and keep all existing BEs?

  3. … abort the current update process in order for you to manage your BEs first."

And/or beadm should have an option to manage the limit of number of BEs. At the moment I can’t see any, anyway.

That’d be my Trident christmas wish list… :slight_smile:


#6

have you searched through discourse? there are a number of threads similar to this.


#7

In TrueOS, it was in /usr/local/etc/trueos.conf in a variable MAXBE. Haven’t found it in Trident yet.


#8

I have. Most of the threads that I found referring to black or blank screens predate the existence of trident.


#9
The X server will continue to run without the pcdm service.
# service pcdm stop
# pkill xinit

Can you duplicate the black screen behavior with the SCFB vice the modesetting driver?
John
groenveld@acm.org

#10

Thanks for the hint.
I just checked. I have such an MAXBE entry in my /usr/local/etc/trueos.conf.
As I temporarely installed pc-updatemanager to set the max. number of BEs and the new limit is shown in the trueos.conf I guess Trident uses the same file and manually editing the file (adding the MAXBE entry) should work, too.