1811 pre-release out in the wild. Discussion


#21

My solution to this problem was to switch from the graphical installer to a terminal via CTRL-ALT-F4. From there I issued the command # start-trident-installer to return to the graphical installer. Then the option to install into a boot environment was activated and I could continue installing into a new boot environment.


#22

Coming from Trident Prerelease 1 the update via # trueos-update check and # trueos-update upgrade went flawlessly.
Thank you for the new ‘about’ command:

[rudy@trident-2417 ~]% about
Project Trident Information
--------------------------------------
OS Version: 18.11-PRERELEASE_2
Build Date: 2018.11.28-21.47.41
--------------------------------------
TrueOS Sources Used:
  Base Repository: https://github.com/trueos/trueos
  Base Commit Tag: d4817554001ef23200da49d28756e36f498c17cb
  Ports Repository: https://github.com/trueos/trueos-ports
  Ports Commit Tag: ce8771a042dad00e7bbe62ca5c710b5d63813f57
--------------------------------------
System Specs:
  Boot Method: BIOS
  AMD A4-3300 APU with Radeon(tm) HD Graphics
  Physical CPUs: 2
  Physical Memory: 3.43 GB
--------------------------------------
GPU Information:
  vgapci0@pci0:0:1:0:   class=0x030000 card=0x84c81043 chip=0x96451002 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD/ATI]'
    device     = 'Sumo [Radeon HD 6410D]'
    class      = display
    subclass   = VGA
--------------------------------------
Network Device Information
  re0@pci0:3:0:0:       class=0x020000 card=0x84321043 chip=0x816810ec rev=0x06 hdr=0x00
    vendor     = 'Realtek Semiconductor Co., Ltd.'
    device     = 'RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller'
    class      = network
    subclass   = ethernet

That is a little more complete than @beanpole135 's command:
TridentVersionIndicator2018-12-02-17-20-52
which results in:

[rudy@trident-2417 ~]% jq -r '."os_version"' /var/db/trueos-manifest.json
18.11-PRERELEASE_2

Now AppCafe has the ‘Trident’ option back - I like it! Thank you for this as well!


#23

I’m so sorry it did not work for me (using the last installer released yesterday).

First: it refuses to start, claiming the X display is locked. Well… I unlock it and then I issue the command again. The installer starts (again) but the button remains disabled.

I try a different approach, exiting to a prompt and doing the same again. No way, still.

I would like to know which are the requirements in order to enable that option. Then, I would quit groping in the dark.


#24

I am very sorry to hear this!

To make sure my procedure really worked I just repeated the process. Here is the step by step procedure:

  1. Booting the iso image up to the graphical installer

  2. Clicking [Next] --> Boot Environment not selectable

  3. Clicking [Go to Terminal] --> coming up the request to login

  4. Typing ‘root’ ; [Enter] --> coming up the root prompt

  5. Entering the command # start-trident-installer --> coming up the first page of the graphical installer

  6. Clicking [Next] --> Boot Environment is selectable

The only difference is, I am using the Trident Prerelease 1 iso. To get Prerelease 2 I simply updated the Prerelease 1 system. So it is possible the installer changed and this procedure won’t be working anymore.


#25

Thanks. It’s not working here.

Edit: This post shows possibly the cause. But I’m not sure I’m willing to do a whole system fresh install anytime soon. :frowning:


#26

Very understandable!
TrueOS 18.03 Lumina desktop environment is still my main system and sitting well on its own hardware. That I will only replace with a Trident Release. All the playing with Betas, Release Candidates, and PreReleases is done on different hardware - just to be save and not so sorry. :sunglasses:


#27

I have this version running on a quad opteron with some sas drives. It’s my favorite OS in a while. I really like Lumina with XFCE being a close second. I am having trouble figuring out how to setup Raid-Z1 on multiple drives during the Trident install. I can see all the drives but only the “single drive” option is available. The TrueOS server installation let me pick raid-z at the end of the install setup. Thanks for any help.


#28

Boot problem - once again.

I just installed Trident from Trident-18.11-PRERELEASE_2-x64-20181130.iso. The installation process did work without any problems. But once again, just like RC3, it won’t boot. The boot menu shows up just normally but if I select the “FreeBSD” entry, nothing happens except for the cursor blinking.


#29

what boot menu? take a pic so we can see


#30

I have two Linux partitions and one Trident partition (ada0s3) on this disk. The MBR is already overwritten by GRUB, but the boot menu looked like this iirc:

F1 Linux
F2 Linux
F3 FreeBSD
F5 Boot from first drive
F6 PXE

Pressing F1 and F2 caused nothing but “#” to occur on the screen because the FreeBSD boot loader can’t boot Linux. Pressing F3 only caused the boot menu to vanish and the blinking cursor to occur, but nothing else happened.


#31

So I re-installed Trident again, same result. Pressing F3 -> blinking cursor, nothing happens. I had to reboot by reset. BTW, F6 didn’t work either.


#32

i’m out of ideas.

check your linux partitions, and see where the /efi/boot partitions are located. some linux distros do their own thing.

on the boot drive, they all (*.efi files) shoujd be in the hiddent /efi/boot partition


#33

This is an old BIOS PC, no EFI. DOS PT used.


#34

then I’m out of ideas :frowning:

edit:

have you triple checked that the freebsd entry points to the correct location?


#35

you know, looking at this pic, it reminds me of an old multi-boot program call BootEasy (or possibly OSBoot). they were around in the late nineties, early 2000s. i used it a couple of times. if i remember rightly, each OS had to be on a separate drive.

is that how it’s configured?

also, back then, it was all MBR booting, no GPT, and no uefi. you would probably have to customize a MBR based boot loader.

one more thing - those days were 32bit systems. are you sure you’re not trying to load a 64bit OS onto 32bit hardware? that’s just not going anywhere…

–jim b


#36

I just did a normal fresh install of Trident and it worked without visible problems. Yes, I have to clean that monitor :sunglasses: And yes, I am sure that my system is a 64-Bit, since it’s an Athlon 64 X2 5000+.


#37

"have you triple checked that the freebsd entry points to the correct location?"
If you tell me where this is stored, I will try. I’m still a FreeBSD boot loader newbie and I don’t speak neither FORTH nor LUA.


#38

I’m certainly NOT one to complain about monitors :wink:

So, looking at the last 2 messages, you finally got Trident installed?

Awesome


#39

Yes but I can’t boot it. Installation went always fine but since RC3 boot doesn’t work.


#40

can you post you grub info for trident/freebsd?