18-11-Prerelease sound issue


#1

Installed Trident in a BE on my Zareason laptop with no problem. I have a sound issue with Falkon. After booting, start Falkon and try to play local .mp4 video and I have no sound. After booting, start VLC and play local .mp4 video with good sound. Then, in same session, try with Falkon and have good sound. After booting, start Firefox and play local .mp4 video with good sound. Then, in same session, try with Falkon and have good sound. Any ideas as to what is going on? I want to use Falkon for watching streaming video from Acorn and can only do so if I activate the sound system with VLC or Firefox first. Thanks - Richard


#2

It could be the default sound device that is being used by Falkon.
VLC and Firefox may be causing a different kernel module to be loaded and if you get that loaded then Falkon would “just work”.
A way of trying to determine this:

Reboot
output of “kldstat”
run firefox, verify sound plays.
output of “kldstat”

You want to look for the differences in the module names (the last column) between the 2 runs of kldstat.

Once you have that difference list:
reboot
as root kldload module where module is a module name from the differences you determined above.
run falkon, check audio.


#3

Thanks. The output of kldstat is identical with Firefox/sound, VLC/sound and Falkon/no sound. Guess I’ll dig into the Falkon configuration but in the meantime, use Firefox or VLC for a minute to initialize the sound before starting Falkon. Thanks again.


#4

also try

start-pulseaudio-x11

and reboot


#5

Thanks. Tried it and no change.


#6

open a terminal and makew sure you have pavucontrol installed

pkg info | grep pavucontrol
pavucontrol-3.0_3 GTK mixer for PulseAudio

if not install it.

Once installed run it, and run falkon, going to youtube to grab any music video. Tinker with pavucontrol until you get sound


#7

Thanks Rod. Installed pavucontrol and solved the problem. Richard


#8

That’s interesting. I wonder if pavucontrol winds up setting the sysctl for the default sound device or the values for the default device and that’s what’s making things work.
Anyway glad it’s working for you.


#9

it can. that’s why I have to use it.

For me. everything works fine, as the default, except falkon. have to run pavucontrol for falkon to have sound. I think thats why @beanpole135 installs it by default


#10

Thanks. I typically just go and look at /dev/sndstat and then do sysctls to muck with the default device and then you can use amixer from the base to do more.

I wonder what “sysctl -a | grep snd | grep default” shows before and after pavucontrol running. Thinking out loud, not really looking for more things to do.